#1  
Old 14th December 2007, 14:56
mufasa mufasa is offline
Member
 
Join Date: Dec 2007
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default Invalid Signature

Hi All

I am using Fedora 7 and used the perfect server setup to install

When trying to login to ispconfig I get the following error:

Quote:
Could not establish an encrypted connection because certificate presented by xxx.xxx.xxx.xxx has an invalid signature
I have tried to generate a new cert by using the following commands but still get the same error:

Code:
openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024

chmod 600 smtpd.key
openssl req -new -key smtpd.key -out smtpd.csr

openssl x509 -req -days 3650 -in smtpd.csr -signkey smtpd.key -out smtpd.crt

openssl rsa -in smtpd.key -out smtpd.key.unencrypted

mv -f smtpd.key.unencrypted smtpd.key
openssl req -new -x509 -extensions v3_ca -keyout cakey.pem -out cacert.pem -days 3650
Can anybody tellme where Im going wrong

Thanks

John
Reply With Quote
Sponsored Links
  #2  
Old 15th December 2007, 16:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Recreate the certificate as shown in http://www.howtoforge.com/forums/showthread.php?t=121 and accept the default values.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th December 2007, 07:36
mufasa mufasa is offline
Member
 
Join Date: Dec 2007
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default Invalid Signature

Hi

Ok did the 'netstat -tap' and cannot see ispconfig listed anywhere there so restarted it as instructed and checked again, it is still not listed.

What do I do now?

Thanks

John
Reply With Quote
  #4  
Old 16th December 2007, 08:36
mufasa mufasa is offline
Member
 
Join Date: Dec 2007
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Invalid Signature

Created new certificate with your instructions and can now access ispconfig,
Thanks for the help!!

John
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing ISPConfig on Suse10.1 nliebherr Installation/Configuration 18 14th September 2007 00:30
Invalid Signature kreya Installation/Configuration 1 7th June 2007 14:37
installing Perl module GD - ran into problems Ovidiu Installation/Configuration 6 19th September 2006 09:32
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29
chgrp: invalid group `admispconfig' wwparrish Installation/Configuration 1 8th February 2006 06:23


All times are GMT +2. The time now is 08:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.