Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th August 2005, 18:09
skeeta skeeta is offline
Junior Member
 
Join Date: Aug 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default I Can send but not receive emails

Well I've perused the forums but to no avail and feel more confused than ever

I was unable to send/receive external emails until I started "sendmail".
Now I am able to send emails but I am not receiving any.
Local network emails worked fine.

Should I install/start "fetchmail"?

To avoid port problems I have temporarily disabled all firewalls and was sending to and from a hotmail account to check if the mail server could be found from "out there". No mail error messages were received so one would expect to see the emails on the server .

Last edited by skeeta; 24th August 2005 at 18:16.
Reply With Quote
Sponsored Links
  #2  
Old 24th August 2005, 18:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Quote:
Originally Posted by skeeta
Well I've perused the forums but to no avail and feel more confused than ever

I was unable to send/receive external emails until I started "sendmail".
Now I am able to send emails but I am not receiving any.
Local network emails worked fine.

Should I install/start "fetchmail"?
No.

Quote:
Originally Posted by skeeta
To avoid port problems I have temporarily disabled all firewalls and was sending to and from a hotmail account to check if the mail server could be found from "out there". No mail error messages were received so one would expect to see the emails on the server .
Which linux distribution have you installed?
Have you set mbox / maildir correctly for your server setup under Management > Server > Settings in the controlpanel?
Did you get messages in the logs that the emails have been received ord dont you get any messages in the logs?
Reply With Quote
  #3  
Old 24th August 2005, 23:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Does the MX record for your domain point to your machine?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 13th April 2006, 23:41
sultan_muhd sultan_muhd is offline
Junior Member
 
Join Date: Apr 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem, i did post under the thread "i can send mail but not reciev"
my isp is not blocking port no.25.becouse i can telnet from other servers
and i can send email. Linux Fire wall is off and my router is pointing port no 25 and 110 to the server. i thing there is some thing to do with DNS but i dont know what.
while when use dig command i got this i have 2 domain in ISPConfig for one i have selected to creat mx record and for the second not and didnt select for both in ISPConfig to creat a dns.

[root@localhost dev]# dig mx mydomain.org

; <<>> DiG 9.3.1 <<>> mx mydomain.org
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24914
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomain.org. IN MX

;; ANSWER SECTION:
mydomain.org. 86400 IN MX 10 mail.mydomain.org.

;; Query time: 60 msec
;; SERVER: 195.121.1.34#53(195.121.1.34)
;; WHEN: Thu Apr 13 22:47:48 2006
;; MSG SIZE rcvd: 50

[root@localhost dev]# dig mx mydomain.net

; <<>> DiG 9.3.1 <<>> mx mydomain.net
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20381
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;mydomain.net. IN MX

;; ANSWER SECTION:
mydomain.net. 86400 IN MX 10 mail.mydomain.net.

;; ADDITIONAL SECTION:
mail.mydomain.net. 86400 IN A 83.80.23.15

;; Query time: 32 msec
;; SERVER: 195.121.1.34#53(195.121.1.34)
;; WHEN: Thu Apr 13 22:50:51 2006
;; MSG SIZE rcvd: 66

[root@localhost dev]#

i installed more then 10 times fedora 4 and ispconfig but it didnt work can some one help please.

Last edited by sultan_muhd; 14th April 2006 at 00:04.
Reply With Quote
  #5  
Old 14th April 2006, 00:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Does the MX record of the recipient domain point to the correct server?
Anything in the mail logs? What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 14th April 2006, 00:37
sultan_muhd sultan_muhd is offline
Junior Member
 
Join Date: Apr 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Red face

I am not sure about that this is the netsat

[root@localhost dev]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:32769 *:* LISTEN 1726/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 2176/mysqld
tcp 0 0 *:netbios-ssn *:* LISTEN 4904/smbd
tcp 0 0 *:sunrpc *:* LISTEN 1708/portmap
tcp 0 0 *:81 *:* LISTEN 2505/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 2639/proftpd: (acce
tcp 0 0 10.0.0.100:domain *:* LISTEN 2625/named
tcp 0 0 localhost.server1:domain *:* LISTEN 2625/named
tcp 0 0 localhost.server1:ipp *:* LISTEN 2037/cupsd
tcp 0 0 localhost.server1:5335 *:* LISTEN 2019/mDNSResponder
tcp 0 0 localhost.server1:rndc *:* LISTEN 2625/named
tcp 0 0 *:smtp *:* LISTEN 2600/master
tcp 0 0 *:microsoft-ds *:* LISTEN 4904/smbd
tcp 0 0 10.0.0.100:microsoft-ds 10.0.0.2:2020 ESTABLISHED 4951/smbd
tcp 0 0 *:imaps *:* LISTEN 2200/dovecot
tcp 0 0 *op3s *:* LISTEN 2200/dovecot
tcp 0 0 *op3 *:* LISTEN 2200/dovecot
tcp 0 0 *:imap *:* LISTEN 2200/dovecot
tcp 0 0 *:http *:* LISTEN 2528/httpd
tcp 0 0 *:ssh *:* LISTEN 2085/sshd
tcp 0 0 *:https *:* LISTEN 2528/httpd
tcp 0 296 ::ffff:10.0.0.100:ssh ::ffff:10.0.0.2:1990 ESTABLISHED 3994/1
[root@localhost dev]#

maillog is just normel but the sender to my server got this with non delivered mail
Deferred: mail.mydomain.net.: No route to host

Last edited by sultan_muhd; 14th April 2006 at 00:46.
Reply With Quote
  #7  
Old 14th April 2006, 00:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Ok, you're using dovecot which uses the Maildir format to store emails. Please make sure you've enabled Maildir under Management -> Server -> Settings -> Email in ISPConfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 14th April 2006, 00:55
sultan_muhd sultan_muhd is offline
Junior Member
 
Join Date: Apr 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes it was not but i did enabeled it now and still not working the strange thing is that i can reciev mails from the same server and from the email what my ISP has provided.
maillog is just normel but the sender to my server got this with non delivered mail
Deferred: mail.mydomain.net.: No route to host

Last edited by sultan_muhd; 14th April 2006 at 00:59.
Reply With Quote
  #9  
Old 14th April 2006, 15:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by sultan_muhd
Deferred: mail.mydomain.net.: No route to host
Check that mail.domain.net points to the correct (public!) IP address, and if your server is behind a router, make sure you forward port 25 from your router to your ISPConfig server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 14th April 2006, 19:16
sultan_muhd sultan_muhd is offline
Junior Member
 
Join Date: Apr 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

port no.25 is pointing to the box on which postfix and ispconfig is running.
where and how to check it if its pointed to the corect ip address?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending mails to remote domains is not working. nandhu HOWTO-Related Questions 17 20th February 2006 21:27
Unable to receive emails?!!! nandhu HOWTO-Related Questions 7 24th October 2005 00:49
Send emails with inline images claudio Programming/Scripts 2 25th April 2005 12:42


All times are GMT +2. The time now is 19:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.