Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th July 2007, 20:38
TheMaximumWeasel TheMaximumWeasel is offline
Junior Member
 
Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default All emails to admispconfig@localhost.localdomain undeliverable

I keep getting these emails:
Return-Path: <>
X-Spam-Checker-Version: SpamAssassin 3.2.1 (2007-05-02) on maxweisel.com
X-Spam-Level:
X-Spam-Status: No, score=0.0 required=5.0 tests=none autolearn=ham
version=3.2.1
X-Original-To: web1_max@maxweisel.com
Delivered-To: web1_max@maxweisel.com
Received: from rwcrmhc13.comcast.net (rwcrmhc13.comcast.net [216.148.227.153])
by maxweisel.com (Postfix) with ESMTP id 7BB7A18A815E
for <web1_max@maxweisel.com>; Fri, 27 Jul 2007 01:29:01 -0700 (MST)
Received: from rwcrmhc13.comcast.net (localhost[127.0.0.1])
by comcast.net (rwcrmhc13) with ESMTP
id <20070727082901m13005lftfe>; Fri, 27 Jul 2007 08:29:01 +0000
From: Mail Delivery Subsystem <mailer-daemon@comcast.net>
Subject: Returned mail: delivery problems encountered
Message-Id: <20070727081358m1300qfd00e@comcast.net>
Date: 27 Jul 2007 8:13:58 +0000
To: <web1_max@maxweisel.com>
Mime-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status; boundary="_46a9a946.69ed.0+comcast.net=_"
X-Virus-Status: No
X-Virus-Checker-Version: clamassassin 1.2.4 with clamscan / ClamAV 0.91.1/3779/Thu Jul 26 12:33:22 2007

--_46a9a946.69ed.0+comcast.net=_
Content-Type: text/plain

A message (from <web1_max@maxweisel.com>) was received at 25 Jul 2007 2:41:34 +0000.

The following addresses had delivery problems:

admispconfig@localhost.localdomain.com
Persistent Transient Failure: Delivery time expired
Delivery last attempted at 25 Jul 2007 2:41:34 +0000

--_46a9a946.69ed.0+comcast.net=_
Content-Type: message/delivery-status

Reporting-MTA: dns; comcast.net
Arrival-Date: 25 Jul 2007 2:41:34 +0000

Final-Recipient: rfc822; admispconfig@localhost.localdomain.com
Action: failed
Status: 4.4.7 Unable to contact host for 2 days,
Diagnostic-Code: smtp; Persistent Transient Failure: Delivery time expired
Last-Attempt-Date: 25 Jul 2007 2:41:34 +0000

--_46a9a946.69ed.0+comcast.net=_
Content-Type: message/rfc822

Received: from maxweisel.com ([69.252.140.253])
by comcast.net (rwcrmhc13) with ESMTP
id <20070725024134m13006qqr0e>; Wed, 25 Jul 2007 02:41:34 +0000
Received: from maxweisel.com (maxweisel.com [127.0.0.1])
(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
(No client certificate requested)
by maxweisel.com (Postfix) with ESMTP id 9A5DB18A816B
for <admispconfig@localhost.localdomain.com>; Tue, 24 Jul 2007 19:41:33 -0700 (MST)
Received: (from web1_max@localhost)
by maxweisel.com (8.13.8/8.13.8/Submit) id l6P2fXA1003887
for admispconfig@localhost.localdomain; Tue, 24 Jul 2007 19:41:33 -0700
Date: Tue, 24 Jul 2007 19:41:33 -0700
From: Max Weisel <web1_max@maxweisel.com>
Message-Id: <200707250241.l6P2fXA1003887@maxweisel.com>
X-Loop: web1_max@localhost.localdomain
Subject: Mailsize: web1_max
To: undisclosed-recipients:;

955


--_46a9a946.69ed.0+comcast.net=_--

And I am getting these from comcast because I have comcasts smtp server set as my relayhost. So basically the problem is my server doesn't see localhost.localdomain as my server.

Max
Reply With Quote
Sponsored Links
  #2  
Old 28th July 2007, 10:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I'm not sure why it says localhost.localdomain.com (should be localhost.localdomain instead), but you can add localhost.localdomain.com to the end of /etc/postfix/local-host-names and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th July 2007, 19:41
TheMaximumWeasel TheMaximumWeasel is offline
Junior Member
 
Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think when comcast gets the email to localhost.localdomain it adds .com to it because it probably thinks the user forgot to add .com or .net or whatevere it was. One thing that I know is my server doesn't see itself as being localhost.localdomain even though in my /etc/hosts files localhost.localdomain points to localhost

Max
Reply With Quote
  #4  
Old 28th July 2007, 22:27
TheMaximumWeasel TheMaximumWeasel is offline
Junior Member
 
Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default I figured out exactly whats wrong now how do I fix it?

I think I know what the problem is. When I installed Centos 5 by using the perfect set-up guide. I set-up MailDIR's then not liking how it was running later on I removed the two lines from postfix's main.cf and unchecked the maildir option in ispconfig. After that I got this same error message for all previously created mail users. How I solved it was to edit each mail user and then save it in ispconfig and ispconfig fixed everything. I guess admispconfig is still set for using maildir's how do I fix it.
Reply With Quote
  #5  
Old 29th July 2007, 14:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by TheMaximumWeasel
I guess admispconfig is still set for using maildir's how do I fix it.
There'S nothing you must fix. admispconfig always uses Maildir, regardless of what other users use.
Please try what I suggested above.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 29th July 2007, 15:52
TheMaximumWeasel TheMaximumWeasel is offline
Junior Member
 
Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am trying your solution now. I only get these emails late at night so tomorrow morning I will have a look. I switched all of my email accounts over to Maildir. I have some old /var/spool/mail files from a previous server and would like to know how I can convert them from mbox to maildir.

Max

I still can't figure out mb2md
Reply With Quote
  #7  
Old 30th July 2007, 17:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by TheMaximumWeasel
I still can't figure out mb2md
What problems do you have with mb2md?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 30th July 2007, 17:57
TheMaximumWeasel TheMaximumWeasel is offline
Junior Member
 
Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I added localhost.localdomain.com to that list and I still get those undeliverable emails every morning. Any other Ideas??

Max
Reply With Quote
  #9  
Old 30th July 2007, 18:01
TheMaximumWeasel TheMaximumWeasel is offline
Junior Member
 
Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think ISPConfig removed localhost.localdomain.com before all of the undeliverable emails were sent out because I just checked the localhost names file for postfix and it wasn't there.

Max
Reply With Quote
  #10  
Old 30th July 2007, 18:03
TheMaximumWeasel TheMaximumWeasel is offline
Junior Member
 
Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Also All of the undeliverable messages are coming from comcast. So I think my server relays all of the email statistics messages to comcast. Comcast then tries to deliver them then sends them back to me. So I think each set of undeliverable messages are two days old because comcast says it tried to deliver these messages for two days before it sent them back.

Max
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I get no emails - Postfix Problem Lausch Installation/Configuration 4 11th May 2007 01:53
Emails are not delivered to external mail server. kanour General 2 18th October 2006 11:36
webmail not show emails euricojunior Installation/Configuration 2 11th August 2006 16:20
Cannot receive emails skeeta Installation/Configuration 18 22nd April 2006 16:02
Emails received but I cannot read them skeeta Installation/Configuration 2 28th August 2005 12:24


All times are GMT +2. The time now is 12:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.