Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th November 2005, 01:43
picard picard is offline
Junior Member
 
Join Date: Nov 2005
Location: Brandon, Manitoba, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to picard
Default ISPConfig php install error

When i try to install ISPConfig, it dies on the following error:

Code:
/tmp/install_ispconfig/compile_aps/php-5.0.4/ext/sqlite/libsqlite/src/vbde.c:491
6: internal compiler error: in sbitmap_difference, at sbitmap.c:305
Please submit a full bug report,
with preprocessed source if appropriate.
...
omitted
...
make: *** [ext/sqlite/libsqlite/src/vdbe.lo] Error1
ERROR: Coulr not make PHP

I just wanted to know if anyone would know what is missing or what i can do to fix this and get the program installed.

Picard
Reply With Quote
Sponsored Links
  #2  
Old 28th November 2005, 02:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Strange - an SQLite related error...
Which distribution do you use? Did you follow any of the "Perfect Setup" tutorials on HowtoForge?
Do you use a 32- or 64-bit system?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th November 2005, 02:07
picard picard is offline
Junior Member
 
Join Date: Nov 2005
Location: Brandon, Manitoba, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to picard
Default

hey,

i'm using ubuntu 5.10 and yes i did go through the setup for that on the website.

im running 32bit ubuntu on a 64bit amd..

ive been reading that i need to edit the installed for 64bit, but i havn't seen this error in the forum, so thought id give it a shot..

Picard

Last edited by picard; 28th November 2005 at 02:10.
Reply With Quote
  #4  
Old 28th November 2005, 11:48
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,483
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

If you are running a 32 bit linux you dont have to edit the compile scripts! You only have to make the changes for 64 bit linux (not 64 bit CPU).
Reply With Quote
  #5  
Old 28th November 2005, 20:20
picard picard is offline
Junior Member
 
Join Date: Nov 2005
Location: Brandon, Manitoba, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to picard
Default

Hey guys..

I deleted the install directory and retryed it.. now i get this msg.

/home/ispconfig/install_ispconfig/compile_aps/php-5.0.4/ext/sqlite/libsqlite/src/vdbe.c: In function 'sqliteVdbeExec':
/home/ispconfig/install_ispconfig/compile_aps/php-5.0.4/ext/sqlite/libsqlite/src/vdbe.c:4916: internal compiler error: in sbitmap_difference, at sbitmap.c:305
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
For Debian GNU/Linux specific bug reporting instructions,
see <URL:file:///usr/share/doc/gcc-4.0/README.Bugs>.
make: *** [ext/sqlite/libsqlite/src/vdbe.lo] Error 1
ERROR: Could not make PHP


Running 32bit Ubuntu 5.10 and i followed the ubuntu 5.10 install guide from the website.

Is there anything that i can do to atleast get further in the installation?

Picard
Reply With Quote
  #6  
Old 29th November 2005, 02:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Originally Posted by picard
Running 32bit Ubuntu 5.10 and i followed the ubuntu 5.10 install guide from the website.

Is there anything that i can do to atleast get further in the installation?
I recommend that you follow the tutorial to the letter (except for settings like hostname or IP addresses). The best way is to use an SSH client like PuTTY and then copy and paste all the commands from the tutorial in order to avoid typos.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 29th November 2005, 02:43
picard picard is offline
Junior Member
 
Join Date: Nov 2005
Location: Brandon, Manitoba, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to picard
Default

k thanx..

i will reinstall and see how far i get this time..

Picard
Reply With Quote
  #8  
Old 29th November 2005, 05:34
picard picard is offline
Junior Member
 
Join Date: Nov 2005
Location: Brandon, Manitoba, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to picard
Default

k i reinstalled the server following the same instructions that were posted in the perfect setup.

tried to install the ispconfig again, and again got the same problem.

Then i deleted the directory and tried to reinstall and got a different msg:

/home/ispconfig/install_ispconfig/compile_aps/php-5.0.4/ext/pcre/pcrelib/pcre.c: In function 'compile_regex':
/home/ispconfig/install_ispconfig/compile_aps/php-5.0.4/ext/pcre/pcrelib/pcre.c:3599: internal compiler error: in var_ann, at tree-flow-inline.h:34
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
For Debian GNU/Linux specific bug reporting instructions,
see <URL:file:///usr/share/doc/gcc-4.0/README.Bugs>.
make: *** [ext/pcre/pcrelib/pcre.lo] Error 1
ERROR: Could not make PHP
./compile: line 45: 17625 Segmentation fault rm -fr ${OPENSSL}

Any ideas?

Picard
Reply With Quote
  #9  
Old 29th November 2005, 10:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Originally Posted by picard
./compile: line 45: 17625 Segmentation fault rm -fr ${OPENSSL}
Hm, a segmentation fault can mean anything - it's even possible that it's a problem with your RAM or your hard disk...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 3rd December 2005, 03:21
MrB MrB is offline
Junior Member
 
Join Date: Dec 2005
Location: Santa Ana Costa Rica
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Simmilar problems but with a 64AMD processor

Hello,
Iam trying to install isp-config on an AMD 64 with ubuntu 5.10 and get the following error:

Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zen d_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.l o Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.l o Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_e xceptions.lo Zend/zend_strtod.lo Zend/zend_objects.lo Zend/zend_object_handlers. lo Zend/zend_objects_API.lo Zend/zend_mm.lo Zend/zend_default_classes.lo Zend/ze nd_reflection_api.lo Zend/zend_execute.lo sapi/apache/sapi_apache.lo sapi/apache /mod_php5.lo sapi/apache/php_apache.lo main/internal_functions.lo -lcrypt -lcryp t -lmysqlclient -lssl -lcrypto -lresolv -lm -ldl -lnsl -lcrypt -lcrypt -o libph p5.la
/usr/bin/ld: /root/ispconfig/openssl/lib/libssl.a(s2_srvr.o): relocation R_X86_6 4_32 against `a local symbol' can not be used when making a shared object; recom pile with -fPIC
/root/ispconfig/openssl/lib/libssl.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1
ERROR: Could not make PHP

Is there any fix for this or? Perhaps that could help for the above posts as well

MrB
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I get PHP to work after ISPConfig Install alvadore Installation/Configuration 22 30th March 2008 16:57
ISPConfig install error g8rbait Server Operation 2 10th November 2005 22:09
Another ISPConfig install error mphayesuk General 2 6th November 2005 18:18
Could not make OpenSSL yontengyatso Installation/Configuration 3 3rd November 2005 11:50
ISPConfig install error mphayesuk General 5 29th October 2005 17:05


All times are GMT +2. The time now is 18:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.