Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th July 2007, 06:24
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
Default PostGrey v1.27 for FC6 ?

Hi,

I was using successfully postgrey for a while on FC4 and it really cuts on spam,
now I upgraded to FC6 and this tutorial doesn't work for me because I can't find /etc/default/postgrey is that because I installed using rpm from here ? and not used apt-get install postgrey ?

Thanks!

Last edited by micko_escalade; 27th July 2007 at 16:36.
Reply With Quote
Sponsored Links
  #2  
Old 26th July 2007, 06:36
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
Default

I just re-installed postgrey using apt-get install postgrey command, and /etc/default/postgrey is still not visible.
Reply With Quote
  #3  
Old 27th July 2007, 16:37
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
Default

Anyone, please ?
Reply With Quote
  #4  
Old 27th July 2007, 18:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

I think that tutorial is based on Debian, so it won't work on Fedora. Probably the Postgrey configuration is somewhere else on Fedora. You can try and run
Code:
updatedb
locate postgrey
to find the file(s).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 28th July 2007, 06:06
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
Default

falko,

Thanks for helping me with this!
with that tutorial beeing for debian /etc/default/postgrey does not exists on fedora,

Code:
[root@linux ~]# locate postgrey
/etc/postfix/postgrey_whitelist_clients
/etc/postfix/postgrey_whitelist_clients.local
/etc/postfix/postgrey_whitelist_recipients
/etc/rc.d/init.d/postgrey
/etc/rc.d/rc0.d/K31postgrey
/etc/rc.d/rc1.d/K31postgrey
/etc/rc.d/rc2.d/K31postgrey
/etc/rc.d/rc3.d/K31postgrey
/etc/rc.d/rc4.d/K31postgrey
/etc/rc.d/rc5.d/K31postgrey
/etc/rc.d/rc6.d/K31postgrey
/usr/sbin/postgrey
/usr/sbin/postgreyreport
/usr/share/doc/postgrey-1.27
/usr/share/doc/postgrey-1.27/COPYING
/usr/share/doc/postgrey-1.27/Changes
/usr/share/doc/postgrey-1.27/README
/usr/share/doc/postgrey-1.27/README-rpm
/usr/share/man/man8/postgrey.8.gz
/var/cache/apt/archives/postgrey_1.27-4.fc6_noarch.rpm
/var/spool/postfix/postgrey
/var/spool/postfix/postgrey/__db.001
/var/spool/postfix/postgrey/__db.002
/var/spool/postfix/postgrey/__db.003
/var/spool/postfix/postgrey/__db.004
/var/spool/postfix/postgrey/log.0000000001
/var/spool/postfix/postgrey/postgrey.db
/var/spool/postfix/postgrey/postgrey.lock
/var/spool/postfix/postgrey/postgrey_clients.db
[root@linux ~]#
but I was able to find this tutorial,
so I found OPTIONS="--unix=$SOCKET" in /etc/rc.d/init.d/postgrey so I changed it to OPTIONS="--unix=$SOCKET --inet=127.0.0.1:60000 --delay=59"
then I added check_policy_service inet:127.0.0.1:60000 to
/etc/postfix/main.cf at smtpd_recipient_restrictions = line
so that it looks like this
Code:
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,check_policy_service inet:127.0.0.1:60000
I made a test a excluded scd.yahoo.com from /etc/postfix/postgrey_whitelist_clients file then I tried sending mail and it got rejected?

Code:
Jul 27 23:36:51 linux postfix/smtpd[2487]: connect from web34805.mail.mud.yahoo.com[209.191.68.169]
Jul 27 23:36:51 linux postfix/smtpd[2487]: NOQUEUE: reject: RCPT from web34805.mail.mud.yahoo.com[209.191.68.169]: 450 4.7.1 <my_user_name@mydomain.com>: Recipient address rejected: Greylisted, see http://isg.ee.ethz.ch/tools/postgrey/help/mydomain.com.html; from=<my_user_name@yahoo.com> to=<my_user_name@mydomain.com> proto=SMTP helo=<web34805.mail.mud.yahoo.com>
Jul 27 23:36:51 linux postfix/smtpd[2487]: disconnect from web34805.mail.mud.yahoo.com[209.191.68.169]
Reply With Quote
  #6  
Old 28th July 2007, 07:38
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
 
Default

I found sqlgrey which is same as postgrey but it can use mySQL DB, looks good,
installed it using step # 7. Setup Grey Listing
Will post review after couple of weeks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Killing that spam with greylisting using Postfix and Postgrey erk Tips/Tricks/Mods 11 18th June 2008 05:09


All times are GMT +2. The time now is 07:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.