Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th July 2007, 21:13
fvonpinho fvonpinho is offline
Junior Member
 
Join Date: Jul 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't setup DNS server correctly?

I am new to linux. I have followed the HowTo Perfect Setup - OpenSuse 10.2, and everything looks like got installed right. Now, I have some questions about using the servers.

Before those questions, a little background of my setup:

I have a wireless router connected to the ISP through a fixed ip. After that, I have the linux machine (the one I used the HowTo on) that and many other XP machines. The Linux machine gets a fixed IP and I fowrded the ports on the router to this machine (80, 25, 110, 21, and 22). All XP machines are on DHCP and will authenticate on this linux machine using Samba. I installed ISPConfig, but didn't like it, so I did the Maildir code provided in the HowTo. I will then use Webmin. This linux machine is goingo to be my email, http, ftp and samba machine.

Here are the questions:

1- My website is in this linux machine. People from outside my network can see the web site. I can see the website if I type localhost on the linux machine or the IP of that machine on any XP machine inside my network. But if I type in www.mydomain.com, it doesn't work. I am thinking it is related to the DNS server, so I created A records inside the DNS to point www.mydomain.com to the IP of that machine, but it still doesn't work. I am also thinking that if it is related to DNS, how am I going to specify DNS server for the machines that are connected wireless?

2- What is the POP3 and SMTP server names? If I configure an email client to go to the IP of the machine with the POP3 installed, it works, but it won't work with any name.

3- I referred to Falko's posting on how to create email accounts. Is there another way to create an account, or do I always need to keep changing the virtusertable file?

The HowTos are great! Falko has done a great job.
Thank you very much!

Regards,
Fred
Reply With Quote
Sponsored Links
  #2  
Old 18th July 2007, 19:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by fvonpinho
1- My website is in this linux machine. People from outside my network can see the web site. I can see the website if I type localhost on the linux machine or the IP of that machine on any XP machine inside my network. But if I type in www.mydomain.com, it doesn't work. I am thinking it is related to the DNS server, so I created A records inside the DNS to point www.mydomain.com to the IP of that machine, but it still doesn't work. I am also thinking that if it is related to DNS, how am I going to specify DNS server for the machines that are connected wireless?
Sounds as if your router doesn't support loopbacks into your LAN...

Quote:
Originally Posted by fvonpinho
2- What is the POP3 and SMTP server names? If I configure an email client to go to the IP of the machine with the POP3 installed, it works, but it won't work with any name.
You can use any IP address or FQDN that points to your server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th July 2007, 20:14
fvonpinho fvonpinho is offline
Junior Member
 
Join Date: Jul 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

1- So you don't think it has to do with the DNS? I edit the host.conf file to add www.mydomain.com 192.168.1.2 and it works. The problem is that I can't do this with the windows machines that I have on the network, because many of them are laptops that need to access internet from other networks when people are travelling.

2- I can receive email correctly now (still have the problem where I need to specify the IP if I am inside of my network and if I go outside of the network, I need to change it to the server1.mydomain.com), but can't send email. I did a telnet on port 25 and sent an email through SMTP commands and it worked fine. This was inside my network. Now if I am outside the network, with my laptop, I cannot telnet to port 25 at all. Why is that? Router port is open and the linux firewall port is also open.

Thank you!

Regards,
Fred
Reply With Quote
  #4  
Old 19th July 2007, 15:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Quote:
Originally Posted by fvonpinho
1- So you don't think it has to do with the DNS? I edit the host.conf file to add www.mydomain.com 192.168.1.2 and it works. The problem is that I can't do this with the windows machines that I have on the network, because many of them are laptops that need to access internet from other networks when people are travelling.
You could set up a BIND server with views inside your LAN: http://www.howtoforge.com/two_in_one_dns_bind9_views

Quote:
Originally Posted by fvonpinho
2- I can receive email correctly now (still have the problem where I need to specify the IP if I am inside of my network and if I go outside of the network, I need to change it to the server1.mydomain.com), but can't send email. I did a telnet on port 25 and sent an email through SMTP commands and it worked fine. This was inside my network. Now if I am outside the network, with my laptop, I cannot telnet to port 25 at all. Why is that? Router port is open and the linux firewall port is also open.
Please make sure that your ISP doesn't block port 25.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Setting up a DNS server to slave from ISPConfig jerutley Installation/Configuration 4 6th November 2006 19:22
Server Not Autorative for Domain Error drbista Installation/Configuration 10 20th December 2005 16:41
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30
DNS Server questions BlueStream Server Operation 2 18th October 2005 18:47


All times are GMT +2. The time now is 05:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.