Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th October 2006, 22:16
Boon-Dog-Danny Boon-Dog-Danny is offline
Member
 
Join Date: Jul 2006
Posts: 97
Thanks: 11
Thanked 1 Time in 1 Post
Question Trouble with function.include

Hello all..

Hope everyone has been healthy wealthy and warm.. hey my servers are working ok I always use my wsftp to upload files no troubles there.. Today I login to look at the file protection deal that I seen before.. and major trouble.. everything is ok with ISP Config until I try to go to the webftp.. then it stalls kinda but connects and then switches to german.. plus..

all these errors..

this is in the header area..

Warning: include(/home/admispconfig/ispconfig/web//lib/module.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 240

Warning: include() [function.include]: Failed opening '/home/admispconfig/ispconfig/web//lib/module.inc.php' for inclusion (include_path='.:') in /home/admispconfig/ispconfig/lib/session.inc.php on line 240


and these errors are above the deal that is the file protection stuff.. But i'm not sure because its in german..


Warning: include(/home/admispconfig/ispconfig/web//lib/module.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 240

Warning: include() [function.include]: Failed opening '/home/admispconfig/ispconfig/web//lib/module.inc.php' for inclusion (include_path='.:') in /home/admispconfig/ispconfig/lib/session.inc.php on line 240

Warning: Invalid argument supplied for foreach() in /home/admispconfig/ispconfig/web/isp_file/frame_start.php on line 118



and when I try to log out from the webftp I get



Warning: include(/home/admispconfig/ispconfig/web//lib/module.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 240

Warning: include() [function.include]: Failed opening '/home/admispconfig/ispconfig/web//lib/module.inc.php' for inclusion (include_path='.:') in /home/admispconfig/ispconfig/lib/session.inc.php on line 240

Warning: require_once(login/lib/lang/.lng) [function.require-once]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/web/logoff.php on line 31

Fatal error: require_once() [function.require]: Failed opening required 'login/lib/lang/.lng' (include_path='.:') in /home/admispconfig/ispconfig/web/logoff.php on line 31



So i'm seeing its ..isp config is missing function.include.. how do i fix this? do I have to reinstall ISP Config?

thanks for any help.
__________________
Debian(rocks) + Ispconfig 3.0.3


Boon-Inc.com Great Video
Boon-File.com Create flash text
Boon-Host.com Get great FREE games here
Boon-Dog.com glitter text makers,music and more
Reply With Quote
Sponsored Links
  #2  
Old 28th October 2006, 15:13
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

The problem is not with a missing file in ISPConfig, it is a problem with a missing session variable.

Do you get this error with all websites in WebFTP? Please try to use another browser too.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th October 2006, 15:42
Boon-Dog-Danny Boon-Dog-Danny is offline
Member
 
Join Date: Jul 2006
Posts: 97
Thanks: 11
Thanked 1 Time in 1 Post
Default Hi Till

Hi Till how you have been, well I hope..

Ok I tried it with firefox..

no error at the very top with firefox.. but this is above the part that I need.. and it still switches to German.. ya know this all worked before.. I seen this working, used it.. and by the way every other part of isp config works. just this area fails.. another thing Till, about two weeks ago the server shut off .. it powered off. My server deal lost power, when it restarted, everything seemed fine.. could the un-expected power-off have unconfigured it?.. I have three servers.. and the other two are working fine.. Oh this is Boon-Dog's server so its the only site on it, so I cant check if its on this site only.. If I have to I can move everything and reload the server but if we can fix it I'd rather not move 19gig around.. thanks Till ..or anyone for any help.

Danny


Warning: include(/home/admispconfig/ispconfig/web//lib/module.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 240

Warning: include() [function.include]: Failed opening '/home/admispconfig/ispconfig/web//lib/module.inc.php' for inclusion (include_path='.:') in /home/admispconfig/ispconfig/lib/session.inc.php on line 240
Es ist folgender Fehler aufgetreten:






Fehler: Sie haben nicht die notwendige Gruppenrechte


Das kann folgende Ursachen haben:
1. Sie benutzen das System im Testmodus
- Melden Sie sich mit Ihrem Benutzernamen und Passwort an.

2. Sie versuchen ein Element zu ändern, das einer anderen Nutzergruppe zugeordnet ist.
In dieser Gruppe besitzen Sie keine Berechtigung zum Schreiben
- Bitten Sie den Eigentümer der Gruppe Ihnen Schreibrechte auf diese Ressource zu geben.

Weiter >>
__________________
Debian(rocks) + Ispconfig 3.0.3


Boon-Inc.com Great Video
Boon-File.com Create flash text
Boon-Host.com Get great FREE games here
Boon-Dog.com glitter text makers,music and more

Last edited by Boon-Dog-Danny; 28th October 2006 at 15:46.
Reply With Quote
  #4  
Old 29th October 2006, 13:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Does this happen when you're logged in as admin, as a reseller, or as a client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 29th October 2006, 16:23
Boon-Dog-Danny Boon-Dog-Danny is offline
Member
 
Join Date: Jul 2006
Posts: 97
Thanks: 11
Thanked 1 Time in 1 Post
Default re

Hi Falko..

and thanks..

it happens under admin.
__________________
Debian(rocks) + Ispconfig 3.0.3


Boon-Inc.com Great Video
Boon-File.com Create flash text
Boon-Host.com Get great FREE games here
Boon-Dog.com glitter text makers,music and more
Reply With Quote
  #6  
Old 30th October 2006, 13:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Any errors in the error log in /root/ispconfig/httpd/logs? What's the output of
Code:
netstat -tap
and
Code:
df- h
?

Have you tried to reboot the system?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 30th October 2006, 18:32
Boon-Dog-Danny Boon-Dog-Danny is offline
Member
 
Join Date: Jul 2006
Posts: 97
Thanks: 11
Thanked 1 Time in 1 Post
Default re

yes tried rebooting no help there.


netstat -tap gave me a ton of stuff..

admin@dog:~$ tcp 0 0 *:smtp *:* LISTEN -
-bash: tcp: command not found
admin@dog:~$ tcp 0 0 localhost.localdoma:953 *:* LISTEN -
-bash: tcp: command not found
admin@dog:~$ tcp6 0 0 *:imaps *:* LISTEN -
-bash: tcp6: command not found
admin@dog:~$ tcp6 0 0 *op3s *:* LISTEN -
-bash: tcp6: command not found
admin@dog:~$ tcp6 0 0 *op3 *:* LISTEN -
-bash: tcp6: command not found
admin@dog:~$ tcp6 0 0 *:imap2 *:* LISTEN -
-bash: tcp6: command not found
admin@dog:~$ tcp6 0 0 *:www *:* LISTEN -
-bash: tcp6: command not found
admin@dog:~$ tcp6 0 0 *:ssh *:* LISTEN -
-bash: tcp6: command not found
admin@dog:~$ tcp6 0 0 *:smtp *:* LISTEN -
-bash: tcp6: command not found
admin@dog:~$ tcp6 0 0 ip6-localhost:953 *:* LISTEN -
-bash: tcp6: command not found
admin@dog:~$ tcp6 0 0 *:https *:* LISTEN -
-bash: tcp6: command not found


the rest was just whos calling what


anyway the
df- h said bad command

and the logs shows nothing.

You know I have three servers.. the other two are fine,I'm thinking move the site to one of those.. and reload ispconfig and then reload the site...
I can do that..
I'm not really any good with linux.. I can nav around a bit, really basic stuff like view and simple edits to a file,

so unless you see anything that jumps out? i'll just reload the server.

and thanks.
__________________
Debian(rocks) + Ispconfig 3.0.3


Boon-Inc.com Great Video
Boon-File.com Create flash text
Boon-Host.com Get great FREE games here
Boon-Dog.com glitter text makers,music and more
Reply With Quote
  #8  
Old 31st October 2006, 09:16
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

It looks like your FTP server is not running. Please try to start your FTP server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 31st October 2006, 13:57
Boon-Dog-Danny Boon-Dog-Danny is offline
Member
 
Join Date: Jul 2006
Posts: 97
Thanks: 11
Thanked 1 Time in 1 Post
Default re

Oh Till, I was so hoping that would of worked, I had restarted isp config but not the ftp only.. so I tried but it did not work..

I just needed a secure folder.. I use wsftp and it works fine, so I just made one one server two.. Thanks for all of your input .. I'll just reload this sometime when its slow.

Thanks all

Danny
__________________
Debian(rocks) + Ispconfig 3.0.3


Boon-Inc.com Great Video
Boon-File.com Create flash text
Boon-Host.com Get great FREE games here
Boon-Dog.com glitter text makers,music and more
Reply With Quote
  #10  
Old 8th November 2006, 19:34
dmgeurts dmgeurts is offline
Junior Member
 
Join Date: Nov 2005
Location: Netherlands
Posts: 26
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default Trouble with function.include

Same here, everything works fine but the webftp. Didn't notice the 'new feature' untill recently.

1) Log into ISPconfig as admin
2) Go to webftp and log into a users site
3) Left frame comes up but center and top frames give the errors shown in this thread. Going back will then crap out entirely. I have to open another window and log into ispconfig again.

Reason that the going back doesn't work is that the credentials change when logging into the users webftp page. They do not revert, I'm wondering whether that's the issue here; user rights to various files.

Djerk
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Big trouble: separate domain appears as ServerAlias for another domain Dmitry General 7 17th July 2006 17:28
Ethereal Trouble mcrosby Installation/Configuration 8 25th June 2006 03:50
ISPConfig configuration or ipcop firewall being the cuase of trouble? AZMel Installation/Configuration 6 15th March 2006 00:20
Mail trouble web-worlds Installation/Configuration 15 27th January 2006 10:45
Trouble Ticket adamluz Feature Requests 1 17th August 2005 07:21


All times are GMT +2. The time now is 09:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.