Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #51  
Old 18th May 2006, 08:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Yes, one of the latest updates removed the splitting for localhost logs.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #52  
Old 18th May 2006, 09:35
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

Quote:
Originally Posted by Tenaka
one more question,

I see that everything is fine now, statistics compiling, no error reports but still the logfiles of my sites are aroung 1.1GB although I set max log size to 500 which means 500MB if I am not wrong.

any hints? how to test or enforce this? I guess if they keep growing I'll get problems soon enough.
still my logs are growing and ignoring the max logsize I entered...

is there a log processing file I can manually run to see if I get any errors? there was something called logs.php as far as I remember. right?
Reply With Quote
  #53  
Old 18th May 2006, 19:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by Tenaka
is there a log processing file I can manually run to see if I get any errors? there was something called logs.php as far as I remember. right?
Yes. Run
Code:
crontab -l
to find the appropriate commands.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #54  
Old 30th August 2006, 16:12
wr19026 wr19026 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 172
Thanks: 7
Thanked 1 Time in 1 Post
Default

I originally installs ISPConfig version 2.2.3 and recently upgraded to 2.2.6

My Webalizer statistics are compiling nicely and I have no problem with those.

However, I have a user with a quota of 200MB and the logs are set to take up the default max. of 30%. In my opinion that should therefore be no more than 60MB

Looking at the statistics for that client I see that their logs now, after a good 2 months of operation, are at 67MB.

crontab -l shows me this:
# ISPConfig
30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null
15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null

And I have changed the defaults in php.ini to allow for more time (600 and 120secs respectively) and more (128MB) memory.

Still the logfiles continue to grow.

Any suggestions what might be the cause and, more importantly, what I can do about it? Like I said, Webalizer creates the statistics without a problem.
Reply With Quote
  #55  
Old 30th August 2006, 19:10
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
Default

Quote:
Originally Posted by wr19026
And I have changed the defaults in php.ini to allow for more time (600 and 120secs respectively) and more (128MB) memory.

Still the logfiles continue to grow.
My suggestion is to try changing the 120 seconds to 240 seconds, but I'm not sure it will work. What I tend to do it to go round each month, deleting the previous month's log directories. It's not ideal, because some logs get past 500MB in a month.

As I type, I'm running the script with 600sec / 240sec / 96MB to see if that manages to trim the logs - there should be no new entries to parse becasue I didn't run logs.php first.
Reply With Quote
  #56  
Old 30th August 2006, 21:12
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
Default

Quote:
Originally Posted by hairydog2
As I type, I'm running the script with 600sec / 240sec / 96MB to see if that manages to trim the logs - there should be no new entries to parse becasue I didn't run logs.php first.
That took a long time to finish, but it produced some interesting results. Amongst the other entries, there were these two:

2069754 records (2069754 ignored) in 113.97 seconds, 18160/sec
2359521 records (2359501 ignored) in 184.96 seconds, 12756/sec

So setting the 240 seconds was not so high - it needed 185 seconds for one file - but the log stayed at 567MB, and the script is definitely not reducing the log size. Perhaps I need to increase the 600 sec to 6000 sec?

Once webalyzer has run, there's nothing to stop you deleting the log file, though.
Reply With Quote
  #57  
Old 31st August 2006, 09:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Quote:
Originally Posted by hairydog2
So setting the 240 seconds was not so high - it needed 185 seconds for one file - but the log stayed at 567MB, and the script is definitely not reducing the log size. Perhaps I need to increase the 600 sec to 6000 sec?
If I remember correctly the time limit is disabled in the webalizer.php script by setting time_limit(0) at the beginning of the script. This means the script ignores the php.ini setting and runs until it is finished.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #58  
Old 31st August 2006, 11:29
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
Default

Quote:
Originally Posted by till
If I remember correctly the time limit is disabled in the webalizer.php script by setting time_limit(0) at the beginning of the script. This means the script ignores the php.ini setting and runs until it is finished.
It has set_time_limit(0); at the beginning already, but I'm not sure that works, because after changing the timeout in php.ini even higher, it has finally managed to trim the logs in last night's run - even though I reduced the memory allocation.

Should the line at the beginning of webalizer.php be time_limit(0) instead of set_time_limit(0): ?
Reply With Quote
  #59  
Old 31st August 2006, 23:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

It must be
Code:
set_time_limit(0);
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #60  
Old 1st September 2006, 01:12
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
 
Default

Thanks. That is what is in the file, but wasn't allowing the scripts to finish. Increasing ther time limits seems to have sorted it out, but I suspect that the whole machine is running more slowly all the rest of the time.

After tonight's run I'll set the limits back and see if it speeds up again.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.