Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #41  
Old 28th March 2006, 13:33
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

could you plz look it up? I just realized I have a localhost directory there as well. I would be very grateful to get rid of this problem
Reply With Quote
Sponsored Links
  #42  
Old 28th March 2006, 23:59
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

like suggested in another thread I used my local installation of php instead of the one that came with ispcfg and got another error than before:

Quote:
Warning: closedir(): supplied argument is not a valid Directory resource in /root/ispconfig/scripts/shell/webalizer.php on line 167
Array
(
[/var/www/web2/log/2006/03/web.log] => 1143070222
)
Array
(
[/var/www/web2/log/2006/03/web.log] => 1143070222
)

Warning: closedir(): supplied argument is not a valid Directory resource in /root/ispconfig/scripts/shell/webalizer.php on line 167
Array
(
[/var/www/web2/log/error.log] => 1143576847
[/var/www/web2/log/2006/03/web.log] => 1143070222
)

Warning: closedir(): supplied argument is not a valid Directory resource in /root/ispconfig/scripts/shell/webalizer.php on line 167
the part with the array is gone now, but what about the remaining errors?
Reply With Quote
  #43  
Old 29th March 2006, 10:22
brice brice is offline
Junior Member
 
Join Date: Mar 2006
Location: France
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had this localhost directory problem.
As a workaround, I edited line 122 in /root/ispconfig/scripts/shell/logs.php to
Code:
if(trim($virtual_host) != '' && trim($virtual_host)!='localhost') {
instead of
Code:
if(trim($virtual_host) != '') {
and my stats are now compiled daily.
Reply With Quote
  #44  
Old 29th March 2006, 11:45
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

thx, that worked for me, here is the result:

Quote:
h5810:/usr/local# /usr/bin/php /root/ispconfig/scripts/shell/webalizer.php
26758 records (26758 ignored) in 0,16 seconds
445572 records (445572 ignored) in 9,05 seconds, 49234/sec
112205 records (112202 ignored) in 1,36 seconds, 82503/sec
131 records (131 ignored) in 0,00 seconds
2479 records (2479 ignored) in 0,01 seconds
615 records (615 ignored) in 0,00 seconds
1025 records (1025 ignored) in 0,01 seconds
h5810:/usr/local#
BUT I am missing the logs from 5 days which lay in between,... anyway thx, its ok so far, I hope it will continue to work automatically now
Reply With Quote
  #45  
Old 29th March 2006, 13:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
Originally Posted by brice
I had this localhost directory problem.
As a workaround, I edited line 122 in /root/ispconfig/scripts/shell/logs.php to
Code:
if(trim($virtual_host) != '' && trim($virtual_host)!='localhost') {
instead of
Code:
if(trim($virtual_host) != '') {
and my stats are now compiled daily.
I added this to logs.php for the next release.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #46  
Old 29th March 2006, 22:04
brice brice is offline
Junior Member
 
Join Date: Mar 2006
Location: France
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm honoured !
Reply With Quote
  #47  
Old 1st May 2006, 11:52
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

sorry to disturb again the peace of this threat but my stats stopped compiling again on the 25. of april and since then the logfiles have been growing again. on the 28. of april I have upgraded ispconfig to the latest version so that is not the reason as they stopped working before...

here is what a manual execution of webalizer gives me now:

Quote:
h5810:/# /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php
Warning: Truncating oversized referrer field
7325 records (7325 ignored) in 0,04 seconds
9002042 records (9002042 ignored) in 97,63 seconds, 92205/sec
89635 records (89635 ignored) in 0,84 seconds
166 records (166 ignored) in 0,00 seconds
424 records (424 ignored) in 0,01 seconds
62838 records (62838 ignored) in 0,65 seconds
123 records (123 ignored) in 0,00 seconds

Warning: array_merge(): Argument #1 is not an array in /root/ispconfig/scripts/shell/webalizer.php on line 161

Warning: array_merge(): Argument #2 is not an array in /root/ispconfig/scripts/shell/webalizer.php on line 161

Warning: array_merge(): Argument #1 is not an array in /root/ispconfig/scripts/shell/webalizer.php on line 161

Warning: array_merge(): Argument #2 is not an array in /root/ispconfig/scripts/shell/webalizer.php on line 161

Warning: array_merge(): Argument #1 is not an array in /root/ispconfig/scripts/shell/webalizer.php on line 161

Warning: array_merge(): Argument #2 is not an array in /root/ispconfig/scripts/shell/webalizer.php on line 161
h5810:/#
also here is whats inside my /var/www:

Quote:
h5810:/var/www# ls -al
insgesamt 56
drwxr-xr-x 14 root root 4096 2006-03-29 00:30 .
drwxr-xr-x 15 root root 4096 2006-02-28 21:29 ..
drwxr-xr-x 2 root root 4096 2006-02-28 21:29 apache2-default
drwxr-xr-x 3 root root 4096 2006-03-29 00:30 localhost
drwxr-xr-x 3 root root 4096 2006-03-29 00:30 mail
drwxr-xr-x 2 root root 4096 2006-02-28 21:42 sharedip
drwxr-xr-x 13 web1_postmaster web1 4096 2006-03-31 16:01 web1
drwxr-xr-x 12 web2_info web2 4096 2006-04-14 23:27 web2
drwxr-xr-x 13 web3_melanie web3 4096 2006-03-26 16:27 web3
drwxr-xr-x 9 web4_ossi web4 4096 2006-04-17 23:50 web4
drwxr-xr-x 9 web5_postmaster web5 4096 2006-03-13 13:18 web5
drwxr-xr-x 10 web6_postmaster web6 4096 2006-04-05 15:25 web6
drwxr-xr-x 10 web7_admin web7 4096 2006-03-23 11:47 web7
drwxr-xr-x 5 root www-data 4096 2005-10-05 20:49 webmail
lrwxrwxrwx 1 www-data web2 13 2006-02-28 22:51 www.hai-hui.net -> /var/www/web2
lrwxrwxrwx 1 www-data web4 13 2006-03-01 09:26 www.kissaki.de -> /var/www/web4
lrwxrwxrwx 1 www-data web7 13 2006-03-14 22:44 www.klub-kamikaze.com -> /var/www/web7
lrwxrwxrwx 1 www-data web6 13 2006-03-01 12:10 www.pacura.ru -> /var/www/web6
lrwxrwxrwx 1 www-data web3 13 2006-02-28 23:04 www.rum-reisen.de -> /var/www/web3
lrwxrwxrwx 1 www-data web1 13 2006-02-28 22:46 www.web-designerz.de -> /var/www/web1
lrwxrwxrwx 1 www-data web5 13 2006-03-01 12:06 www.zice.ro -> /var/www/web5
Please help me, this can't go on like this.

Last edited by Ovidiu; 1st May 2006 at 11:59.
Reply With Quote
  #48  
Old 1st May 2006, 15:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

http://www.howtoforge.com/forums/sho...p?t=562&page=7
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #49  
Old 17th May 2006, 10:56
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

one more question,

I see that everything is fine now, statistics compiling, no error reports but still the logfiles of my sites are aroung 1.1GB although I set max log size to 500 which means 500MB if I am not wrong.

any hints? how to test or enforce this? I guess if they keep growing I'll get problems soon enough.
Reply With Quote
  #50  
Old 17th May 2006, 23:09
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
 
Default

Quote:
Originally Posted by Tenaka
could you plz look it up? I just realized I have a localhost directory there as well. I would be very grateful to get rid of this problem
I'm sorry I overlooked this till now.

Yes, I made a directory /home/notwww/web0/ and made a softlink called "localhost" to there in /home/www/

So the script splits out stuff destined for localhost and puts it in /home/notwww/web0/log/2006/05/

What appears in there is just the evidence of hacking attempts. This is a recent sample:

64.246.188.65 - - [15/May/2006:11:45:55 +0100] "GET / HTTP/1.0" 200 895 "-" "Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)"
64.246.188.65 - - [15/May/2006:11:45:55 +0100] "GET / HTTP/1.0" 200 895 "-" "Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)"
66.221.207.46 - - [15/May/2006:14:48:01 +0100] "GET /a1b2c3d4e5f6g7h8i9/nonexistentfile.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:02 +0100] "GET /adxmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:02 +0100] "GET /adserver/adxmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:02 +0100] "GET /phpAdsNew/adxmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:03 +0100] "GET /phpadsnew/adxmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:03 +0100] "GET /phpads/adxmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:03 +0100] "GET /Ads/adxmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:03 +0100] "GET /ads/adxmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:04 +0100] "GET /xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:04 +0100] "GET /xmlrpc/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:04 +0100] "GET /xmlsrv/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:04 +0100] "GET /blog/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:05 +0100] "GET /drupal/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:05 +0100] "GET /community/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:05 +0100] "GET /blogs/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:05 +0100] "GET /blogs/xmlsrv/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:05 +0100] "GET /blog/xmlsrv/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:06 +0100] "GET /blogtest/xmlsrv/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
66.221.207.46 - - [15/May/2006:14:48:06 +0100] "GET /b2/xmlsrv/xmlrpc.php HTTP/1.0" 404 1098 "-" "-"
221.167.208.202 - - [15/May/2006:18:17:16 +0100] "GET / HTTP/1.0" 200 895 "-" "-"
83.104.39.2 - - [15/May/2006:20:54:21 +0100] "HEAD / HTTP/1.0" 200 - "-" "-"
58.68.4.26 - - [16/May/2006:03:29:12 +0100] "GET //README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
58.68.4.26 - - [16/May/2006:03:29:13 +0100] "GET /horde//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
58.68.4.26 - - [16/May/2006:03:29:14 +0100] "GET /horde2//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
58.68.4.26 - - [16/May/2006:03:29:15 +0100] "GET /horde3//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
58.68.4.26 - - [16/May/2006:03:29:15 +0100] "GET /horde-3.0.9//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
58.68.4.26 - - [16/May/2006:03:29:16 +0100] "GET /Horde//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
62.233.144.195 - - [16/May/2006:14:21:46 +0100] "GET //README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
62.233.144.195 - - [16/May/2006:14:21:47 +0100] "GET /horde//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
62.233.144.195 - - [16/May/2006:14:21:47 +0100] "GET /horde2//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
62.233.144.195 - - [16/May/2006:14:21:47 +0100] "GET /horde3//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
62.233.144.195 - - [16/May/2006:14:21:47 +0100] "GET /horde-3.0.9//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
62.233.144.195 - - [16/May/2006:14:21:47 +0100] "GET /Horde//README HTTP/1.1" 404 1100 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
83.104.39.2 - - [16/May/2006:15:58:35 +0100] "HEAD / HTTP/1.0" 200 - "-" "-"


I suspect that 2.2.2 has changed how localhost accesses are logged, but I've not upgraded yet.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.