Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 18th July 2007, 14:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,037
Thanks: 841
Thanked 5,659 Times in 4,466 Posts
Default

Have a look at your mail log file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 18th July 2007, 15:30
Griff Griff is offline
Member
 
Join Date: May 2006
Posts: 53
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Jul 18 12:47:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 18 12:47:01 server1 imapd: chdir Maildir: No such file or directory
Jul 18 12:49:50 server1 postfix/smtpd[4188]: connect from localhost[127.0.0.1]
Jul 18 12:49:50 server1 postfix/smtpd[4188]: lost connection after CONNECT from localhost[127.0.0.1]
Jul 18 12:49:50 server1 postfix/smtpd[4188]: disconnect from localhost[127.0.0.1]
Reply With Quote
  #13  
Old 18th July 2007, 17:45
Griff Griff is offline
Member
 
Join Date: May 2006
Posts: 53
Thanks: 3
Thanked 0 Times in 0 Posts
Default

I have uploaded the complete Log ... Please ignore the rcpt to errors as i've not forwarded the domains completly yet since i swapped from a Bare Linux system to this fresh install of Server2

Regards
Attached Files
File Type: txt mail.log.txt (29.3 KB, 231 views)

Last edited by Griff; 18th July 2007 at 17:50.
Reply With Quote
  #14  
Old 19th July 2007, 15:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by Griff
Jul 18 12:47:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 18 12:47:01 server1 imapd: chdir Maildir: No such file or directory
Did you send a mail to that account first before you tried to fetch mails? Maildir is created automatically when the first mail arrives.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 19th July 2007, 21:13
Griff Griff is offline
Member
 
Join Date: May 2006
Posts: 53
Thanks: 3
Thanked 0 Times in 0 Posts
Default

I sent the email from another server i have access to.

Quote:
Jul 19 19:05:28 server1 postfix/smtpd[30021]: TLS connection established from wombat.tirsek.com[212.10.30.241]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Jul 19 19:05:28 server1 postfix/smtpd[30021]: A4980168008: client=wombat.tirsek.com[212.10.30.241]
Jul 19 19:05:28 server1 postfix/cleanup[30025]: A4980168008: message-id=<Pine.LNX.4.64.0707192005050.13268@wombat.tirse k.com>
Jul 19 19:05:28 server1 postfix/qmgr[13106]: A4980168008: from=<party@wombat.tirsek.com>, size=830, nrcpt=1 (queue active)
Jul 19 19:05:28 server1 postfix/local[30026]: A4980168008: to=<web2_admin@amrhosting.info>, relay=local, delay=0.38, delays=0.24/0.01/0/0.13, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Jul 19 19:05:28 server1 postfix/qmgr[13106]: A4980168008: removed
Jul 19 19:05:28 server1 postfix/pickup[29430]: F0EEB168024: uid=10001 from=<web2_admin>
Jul 19 19:05:28 server1 postfix/cleanup[30025]: F0EEB168024: message-id=<20070719180528.F0EEB168024@server1.amrhosting. info>
Jul 19 19:05:28 server1 postfix/qmgr[13106]: F0EEB168024: from=<web2_admin@server1.amrhosting.info>, size=396, nrcpt=1 (queue active)
Jul 19 19:05:29 server1 postfix/smtpd[30021]: disconnect from wombat.tirsek.com[212.10.30.241]
Jul 19 19:05:29 server1 postfix/local[30026]: F0EEB168024: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.08, delays=0.02/0/0/0.06, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Jul 19 19:05:29 server1 postfix/qmgr[13106]: F0EEB168024: removed
Jul 19 19:06:08 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 19 19:06:08 server1 imapd: chdir Maildir: No such file or directory
Am i using the correct syntax for the login - username web2_admin
then the password which i set

or should it be web2_admin@serverdomain

Regards

Griff
Reply With Quote
  #16  
Old 20th July 2007, 17:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Did you enable Maildir under Management > Server > Settings > Email?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Griff (20th July 2007)
  #17  
Old 20th July 2007, 21:24
Griff Griff is offline
Member
 
Join Date: May 2006
Posts: 53
Thanks: 3
Thanked 0 Times in 0 Posts
Default

YAY i finally got the mail sorted thanks to Falko BUT now i've got another problem... I can send mail using the internal webmail client but when i use a client such as Outlook or Thunderbird i get the following error

Quote:
Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'geminisounds.com', Server: 'amrhosting.info', Protocol: SMTP, Port: 25, Secure(SSL): No, Error Number: 0x800CCC0F
I have enabled my Server Requires authentication and tried all of the options that come with that but still to no avail. Postconf -n is as follows

Quote:
server1:~# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
home_mailbox = Maildir/
inet_interfaces = all
mailbox_command =
mailbox_size_limit = 0
mydestination = /etc/postfix/local-host-names
myhostname = server1.amrhosting.info
mynetworks = 127.0.0.0/8 192.168.1.3/24
myorigin = /etc/mailname
recipient_delimiter = +
relayhost =
smtp_tls_note_starttls_offer = yes
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
server1:~#
I forgot to mention when i do turn on my server requires authentication i keep getting the enter username and password box constantly i have tried entering numerous different usernames and passwords including the root username and password for the Debian Server but to no avail

Quote:
server1:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 1415/couriertcpd
tcp 0 0 *op3s *:* LISTEN 1442/couriertcpd
tcp 0 0 localhost.localdo:mysql *:* LISTEN 1330/mysqld
tcp 0 0 *op3 *:* LISTEN 1422/couriertcpd
tcp 0 0 *:imap2 *:* LISTEN 10896/couriertcpd
tcp 0 0 *:www *:* LISTEN 7715/apache2
tcp 0 0 *:81 *:* LISTEN 1686/ispconfig_http
tcp 0 0 server1.amrhosti:domain *:* LISTEN 7460/named
tcp 0 0 localhost.locald:domain *:* LISTEN 7460/named
tcp 0 0 *:ftp *:* LISTEN 7087/proftpd: (acce
tcp 0 0 *:ssh *:* LISTEN 1546/sshd
tcp 0 0 *:smtp *:* LISTEN 19612/master
tcp 0 0 localhost.localdoma:953 *:* LISTEN 7460/named
tcp 0 0 *:https *:* LISTEN 7715/apache2
tcp 0 0 server1.amrhosting.:ssh 79-66-124-71.dynam:3442 ESTABLISHED17918/0
tcp 0 288 server1.amrhosting.:ssh 79-66-124-71.dynam:3729 ESTABLISHED18703/1
tcp 0 0 localhost.localdoma:ftp localhost.localdo:33585 TIME_WAIT -
tcp 0 0 localhost.localdo:33584 localhost.localdoma:www TIME_WAIT -
server1:~#
Quote:
Jul 20 19:29:12 server1 postfix/smtpd[19616]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Jul 20 19:29:12 server1 postfix/smtpd[19616]: warning: 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]: SASL LOGIN authentication failed: generic failure
Jul 20 19:29:12 server1 postfix/smtpd[19616]: lost connection after AUTH from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]
Jul 20 19:29:12 server1 postfix/smtpd[19616]: disconnect from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]
Jul 20 19:29:12 server1 postfix/smtpd[19616]: connect from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]
Jul 20 19:29:12 server1 postfix/smtpd[19616]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Jul 20 19:29:12 server1 postfix/smtpd[19616]: warning: 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]: SASL LOGIN authentication failed: generic failure
Jul 20 19:29:12 server1 postfix/smtpd[19616]: lost connection after AUTH from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]
Jul 20 19:29:12 server1 postfix/smtpd[19616]: disconnect from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]
Jul 20 19:29:13 server1 postfix/smtpd[19616]: connect from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]
Jul 20 19:29:14 server1 postfix/smtpd[19616]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Jul 20 19:29:14 server1 postfix/smtpd[19616]: warning: 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]: SASL LOGIN authentication failed: generic failure
Jul 20 19:29:14 server1 postfix/smtpd[19616]: lost connection after AUTH from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]
Jul 20 19:29:14 server1 postfix/smtpd[19616]: disconnect from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]
Jul 20 19:30:37 server1 courierpop3login: Connection, ip=[::ffff:79.66.124.71]
Jul 20 19:30:38 server1 courierpop3login: LOGIN, user=web2_info, ip=[::ffff:79.66.124.71]
Jul 20 19:30:38 server1 courierpop3login: LOGOUT, user=web2_info, ip=[::ffff:79.66.124.71], top=0, retr=0, rcvd=12, sent=39, time=0
Ok so it looks like SASLAUTH is failing here

Quote:
Jul 20 19:28:48 server1 postfix/smtpd[19616]: connect from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]
Jul 20 19:28:48 server1 postfix/smtpd[19616]: NOQUEUE: reject: RCPT from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]: 554 5.7.1 <admin@dynamiteradio.co.uk>: Relay access denied; from=<info@geminisounds.com> to=<admin@$
Jul 20 19:28:48 server1 postfix/smtpd[19616]: disconnect from 79-66-124-71.dynamic.dsl.as9105.com[79.66.124.71]

Last edited by Griff; 20th July 2007 at 21:33.
Reply With Quote
  #18  
Old 21st July 2007, 19:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

What's in /etc/default/saslauthd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 22nd July 2007, 20:04
Griff Griff is offline
Member
 
Join Date: May 2006
Posts: 53
Thanks: 3
Thanked 0 Times in 0 Posts
Default

i'm baffled by this one.. all looks ok to me

/etc/default/saslauthd


Quote:
#
# Settings for saslauthd daemon
#

# Should saslauthd run automatically on startup? (default: no)
START=yes

PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"

# Which authentication mechanisms should saslauthd use? (default: pam)
#
# Available options in this Debian package:
# getpwent -- use the getpwent() library function
# kerberos5 -- use Kerberos 5
# pam -- use PAM
# rimap -- use a remote IMAP server
# shadow -- use the local shadow password file
# sasldb -- use the local sasldb database file
# ldap -- use LDAP (configuration is in /etc/saslauthd.conf)
#
# Only one option may be used at a time. See the saslauthd man page
# for more information.
#
# Example: MECHANISMS="pam"
MECHANISMS="pam"

# Additional options for this mechanism. (default: none)
# See the saslauthd man page for information about mech-specific options.
MECH_OPTIONS=""

# How many saslauthd processes should we run? (default: 5)
# A value of 0 will fork a new process for each connection.
THREADS=5

# Other options (default: -c)
# See the saslauthd man page for information about these options.
#
# Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
# Note: See /usr/share/doc/sasl2-bin/README.Debian
OPTIONS="-c"
Reply With Quote
  #20  
Old 23rd July 2007, 07:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,037
Thanks: 841
Thanked 5,659 Times in 4,466 Posts
 
Default

I guess you used the perfect setup for the wrong linux version to install your server.

Please remove the line:

PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"

and replace:

OPTIONS="-c"

with:

OPTIONS="-m /var/spool/postfix/var/run/saslauthd -r"

and restart saslauthd.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Griff (27th July 2007)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 10:29
php eating cpu shajazzi Server Operation 15 15th August 2007 02:19
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 10:54
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18


All times are GMT +2. The time now is 02:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.