#1  
Old 6th July 2007, 00:52
tmdg tmdg is offline
Junior Member
 
Join Date: Sep 2006
Posts: 22
Thanks: 2
Thanked 1 Time in 1 Post
Question DNS zone file problems.

Hi,

I'm running two ISPConfig systems both are on 2.2.14.

On server 1 everything seems fine. The zone files are in /var/named/chroot/var/named
On server 2 there are zone files in /var/named/chroot/var/named but if I add a new host the zone files don't change. If I add a new domain the zone files don't get created.

I'm sure server 2 used to work but I recently updated from 2.2.6 or may be 2.2.9.

I don't see any errors in the /var/log/messages nor do I see any errors /home/admispconfig/ispconfig/ispconfig.log

Does anyone have suggestion of were to look for the cause of the problem?

Regards,
Tom.
Reply With Quote
Sponsored Links
  #2  
Old 6th July 2007, 12:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Please have a look at the ispconfig.log logfile if you see any errors. Also make sure that /var/named/chroot/var/named is world readable.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th July 2007, 16:51
tmdg tmdg is offline
Junior Member
 
Join Date: Sep 2006
Posts: 22
Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
Please have a look at the ispconfig.log logfile if you see any errors. Also make sure that /var/named/chroot/var/named is world readable.

As I siad in my post I don't see any errors in ispconfig.log

# pwd
/var/named/chroot/var
# ls -l
total 24
drwxrwxr-x 4 root named 4096 Jul 6 08:58 named
drwxrwxr-x 4 root named 4096 Mar 13 2003 run
drwxrwx--- 2 named named 4096 Mar 13 2003 tmp

and the zone files in /var/named/chroot/var/named are owned by named group named.

Regards,
Tom.
Reply With Quote
  #4  
Old 6th July 2007, 18:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
ls -la /root/ispconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
tmdg (6th July 2007)
  #5  
Old 6th July 2007, 20:40
tmdg tmdg is offline
Junior Member
 
Join Date: Sep 2006
Posts: 22
Thanks: 2
Thanked 1 Time in 1 Post
Default

]# ll -a /root/ispconfig/
total 104
drwxr-xr-x 9 root root 4096 Jul 6 19:30 .
drwxr-x--- 5 root root 4096 Jul 5 21:00 ..
-rwxr-xr-x 1 root root 33072 Jun 30 09:48 cronolog
-rwxr-xr-x 1 root root 9673 Jun 30 09:48 cronosplit
drwxr-xr-x 12 root root 4096 Jun 30 09:26 httpd
drwxr-xr-x 15 root root 4096 Jun 30 09:48 isp
-rw-r--r-- 1 root root 0 Jul 6 19:30 .ispconfig_lock
-rw-r--r-- 1 root root 8 Jul 6 19:30 .old_path_httpd_root
drwxr-xr-x 6 root root 4096 Jun 30 09:26 openssl
drwxr-xr-x 6 root root 4096 Jun 30 09:37 php
drwxr-xr-x 4 root root 4096 Jun 30 09:48 scripts
drwxr-xr-x 4 root root 4096 Jun 30 09:48 standard_cgis
drwxr-xr-x 2 root root 4096 Jun 30 09:48 sv
-rwx------ 1 root root 9389 Jun 30 09:48 uninstall

I'm gonna guess that the .ispcong_lock is the problem.

I removed it and bingo several of the zone files updated.

it's still not right as the lock reappears though.

tom.
Reply With Quote
  #6  
Old 7th July 2007, 13:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

The lockfile must appear while the script is running. If it does not get removed after the end of the script run, then something caused the script to die, maybe a segfault.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 7th July 2007, 14:14
tmdg tmdg is offline
Junior Member
 
Join Date: Sep 2006
Posts: 22
Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
The lockfile must appear while the script is running. If it does not get removed after the end of the script run, then something caused the script to die, maybe a segfault.
So I need to fix something then.

It's kind of sorted itself out now. If I use DNS manager to alter a zone file then the only thing that happens is named.conf gets screwed up.
But the lock file is lot left. Ir is removed.

Line 3 is changed to
directory "/home/admispconfig/ispconfig/web/multidoc/edit";
When it should read
directory "/var/named/chroot/var/named";

So named fails to start. I correct the file and the named starts but my zone file is still not updated.

Where do I look to work out why the named.conf is getting the wrong directory?

Regards,
Tom.
Reply With Quote
  #8  
Old 7th July 2007, 15:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Which linux distribution do you use?

Please redo the steps for the bind configuration from the perfect setup for your linux distribution to fix the permission problem. If the problem is fixed, ISPConfig will use the correct directory for your bind files when you set it under management > server > settings in ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 7th July 2007, 17:42
tmdg tmdg is offline
Junior Member
 
Join Date: Sep 2006
Posts: 22
Thanks: 2
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by till
Which linux distribution do you use?
Fedora Core 5.
Quote:
Originally Posted by till
ISPConfig will use the correct directory for your bind files when you set it under
management > server > settings in ISPConfig.
Thats is I think. Well it looks like it works now.

Regards,
Tom.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 03:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
BIND broke adamluz Installation/Configuration 4 2nd June 2006 21:31


All times are GMT +2. The time now is 10:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.