Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd November 2005, 12:01
new_bee05 new_bee05 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default The Perfect Setup Suse 9.3 - Postfix problems

I have just completed the Suse 9.3 perfect setup. I am interested in setting up my mail server. However i am having trouble sending email. I don't think the maildir is set up properly if at all. I have tried to set up a email account in outlook express and kmail without success.What is the very first step after completing the suse setup 9.3 for mail, be as specific for a newbie as possible. Thanks.
__________________
www.ecomp.com.au
Reply With Quote
Sponsored Links
  #2  
Old 22nd November 2005, 15:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Did you install ISPConfig as well, or do you set up your email accounts manually? In the latter case have a look here: http://www.howtoforge.com/forums/showthread.php?t=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 23rd November 2005, 00:06
new_bee05 new_bee05 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

falco, i did not have any files named "local-host-names" or "virtusertable" so I created them and added the appropriate data. I have created a Maildir account in KMail and I can send an email to myself (admin@ecomputer.com.it). I can't receive an email from a real domain account or send to a real domain account. Also emails just seem to be comming back to the account that they were sent from.
__________________
www.ecomp.com.au

Last edited by new_bee05; 23rd November 2005 at 01:01.
Reply With Quote
  #4  
Old 23rd November 2005, 01:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's in the mail log in /var/log/?

Do you have proper DNS records for your domain(s)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd November 2005, 02:14
new_bee05 new_bee05 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falco, i only have done what's in the Perfect Setup in regards to DNS.

/var/log/mail (this is a text file) - i don't have a /var/log/mail.log

I can now send email from within the domain to members of my local network. However I can't send to my FQDN ecomp.com.au. I get Name server errors (Name server: ecomputer.com.it: host not found)

Is what i am doing possible as this is only a figtitious domain name that i am working with.
__________________
www.ecomp.com.au

Last edited by new_bee05; 23rd November 2005 at 06:28.
Reply With Quote
  #6  
Old 23rd November 2005, 10:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by new_bee05
/var/log/mail (this is a text file) - i don't have a /var/log/mail.log
Are there errors/warnings in /var/log/mail?

Quote:
Originally Posted by new_bee05
I can now send email from within the domain to members of my local network. However I can't send to my FQDN ecomp.com.au. I get Name server errors (Name server: ecomputer.com.it: host not found)
Please post the content of your /etc/resolv.conf.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 23rd November 2005, 12:25
new_bee05 new_bee05 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

falco,error messages in mail log:

Nov 22 15:37:33 SERVER postfix/master[6284]: warning: process /usr/lib/postfix/pickup pid 6970 exit status 1
Nov 22 15:37:33 SERVER postfix/master[6284]: warning: /usr/lib/postfix/pickup: bad command startup -- throttling
Nov 22 15:37:33 SERVER postfix/master[6284]: warning: process /usr/lib/postfix/qmgr pid 6971 exit status 1
Nov 22 15:37:33 SERVER postfix/master[6284]: warning: /usr/lib/postfix/qmgr: bad command startup -- throttling
Nov 22 15:38:17 SERVER postfix/smtpd[6972]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory

/etc/resolve.conf
nameserver 192.168.1.5
nameserver 203.0.178.191
nameserver 203.2.75.12
search site
__________________
www.ecomp.com.au
Reply With Quote
  #8  
Old 23rd November 2005, 12:37
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,398
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

The file /etc/postfix/local-host-names is missing.
You can create it with the command:

touch /etc/postfix/local-host-names

Have you installed ISPConfig on the server? Then create a new site and ISPConfig creates the local-host-names file for you.
Reply With Quote
  #9  
Old 23rd November 2005, 15:11
new_bee05 new_bee05 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok I have created the file now what?
__________________
www.ecomp.com.au
Reply With Quote
  #10  
Old 23rd November 2005, 18:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

http://www.howtoforge.com/forums/showthread.php?t=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Attempting The Perfect Setup (To Some Extent) PsyVision HOWTO-Related Questions 3 3rd November 2005 11:50
Suse 9.3 setup probs with php5 hyperclock Tips/Tricks/Mods 0 21st September 2005 02:34
PEAR Support with Perfect Setup SuSE 9.3 SidSkiba Installation/Configuration 8 31st August 2005 08:42
The Perfect Setup - Suse 9.3 Dr D With a PHD Installation/Configuration 7 21st August 2005 21:47
MYSQL and the perfect setup 9.2 Suse pkfrizzlefry HOWTO-Related Questions 7 21st May 2005 20:12


All times are GMT +2. The time now is 12:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.