Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th July 2007, 10:16
pssara pssara is offline
Junior Member
 
Join Date: Jan 2007
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Greek Support on ISPConfig 2.2.14, lost tools menu

Hello, i just upgraded from 2.2.12 to 2.2.14 to use the Greek Menus.
Unfortunately, the support of the Greek Language is not ported well:
  • The encoding of the pages is still 8859-1 where is should be 8859-7
  • I totally lost tools menu, after changing to Greek language. When pressing the tools menu i get an empty page.
The problem is that i cannot change back to English, as i lost the tools menu. Is there another way to change the language back to English?
Reply With Quote
Sponsored Links
  #2  
Old 5th July 2007, 11:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

Quote:
The encoding of the pages is still 8859-1 where is should be 8859-7
You must change the encoding if you change the language. the encoding is set in /home/admispconfig/ispconfig/lib/config.inc.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 5th July 2007, 12:31
pssara pssara is offline
Junior Member
 
Join Date: Jan 2007
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks.
But still the left panel has no page encoding at all.
And i still have problem with the tools menu it opens as a blank page.
Any help with changing the language from command prompt or Sql ?
Reply With Quote
  #4  
Old 6th July 2007, 18:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Hm, not sure if this thread can help you: http://www.howtoforge.com/forums/sho...ding+ispconfig
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th July 2007, 19:19
pssara pssara is offline
Junior Member
 
Join Date: Jan 2007
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks. I have already changed the encoding but it didnt work on the left panel. I would also like some help on changing the language back to English without using the tools menu, which is not accessible.
Reply With Quote
  #6  
Old 8th July 2007, 19:43
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default

Because your tools screen is not accessible anymore, which means you can't use the Tools menu anymore, i suggest to do the following:

Create a copy of your Greek Language file:
cp /home/admispconfig/ispconfig/web/tools/lib/lang/gr.lng /home/admispconfig/ispconfig/web/tools/lib/lang/gr-old.lng

Overwrite the Greek language file with the English one:
cp /home/admispconfig/ispconfig/web/tools/lib/lang/en.lng /home/admispconfig/ispconfig/web/tools/lib/lang/gr.lng

It would be nice if you could find out why the Greek Tools screen is not functioning anymore, so we can correct it.
__________________
Hans

MrHostman | Managed Hosting

Last edited by Hans; 8th July 2007 at 19:45.
Reply With Quote
  #7  
Old 8th July 2007, 19:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
 
Default

Or you change the complete user in the database back to english.

http://www.howtoforge.com/forums/showthread.php?t=13793
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! micko_escalade Installation/Configuration 35 30th March 2007 12:31
ISPConfig 2.2.0 released till General 17 7th April 2006 05:39
ISPConfig Language support! cybereatl Installation/Configuration 10 1st March 2006 22:55
ISPConfig Failure on SuSe 9.3 gimhan90 Installation/Configuration 13 2nd February 2006 11:29
Menu Support for JSP and aspx pontifex Feature Requests 1 19th September 2005 21:08


All times are GMT +2. The time now is 04:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.