Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st July 2007, 10:01
Elfchen Elfchen is offline
Member
 
Join Date: Jun 2007
Posts: 56
Thanks: 2
Thanked 1 Time in 1 Post
Question suddenly vhosts created without correct user on Suse 10.2

Till now ispconfiig worked well for different vhosts.

Normally for every vhost a user was created like:

web123_domain.tld

with group

web123

this worked very well till yesterday ...

now when I create a new vhost the necessary user user ie.

web123_domain.tld

is not any longer created. instead of this the vhost directory is owned by:

drwxr-xr-x 8 wwwrun web18 4096 Jul 1 11:32 web18/

the wwwrun user.

I don't know why it didn't create the user accounts and bind to the correct homedir any longer. Any suggestions?

Using latest version with Suse 10.2
Reply With Quote
Sponsored Links
  #2  
Old 1st July 2007, 10:21
Elfchen Elfchen is offline
Member
 
Join Date: Jun 2007
Posts: 56
Thanks: 2
Thanked 1 Time in 1 Post
Post Strange

After a few clicks into user & mail and creating a mailuser the account seems to be created inside /etc/passwd now.

Maybe it's necessary to create inside vhost settings user & mail + FTP to create a complete working account. Wondering why this is not done automatically when creating vhost.

PS:
Thank you developers. You did a really good job with this solution.
Reply With Quote
  #3  
Old 1st July 2007, 10:50
Elfchen Elfchen is offline
Member
 
Join Date: Jun 2007
Posts: 56
Thanks: 2
Thanked 1 Time in 1 Post
Default still 403

But still getting an 403 when trying to access web-content:

Access forbidden!

You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If you think this is a server error, please contact the webmaster.
Error 403

-rw-rw-r-- 1 web19_domain.tld web19 1222 Jul 1 12:18 index.php

now it's not searching into vhosts home:

[Sun Jul 01 12:23:30 2007] [error] [client 1.2.3.4] client denied by server configuration: /var/www/sharedip/install.php

I become silly now!

Now vhost is shown inside ISPConfig but not created inside Vhosts_ispconfig.conf

It's simply completly missing there.



Cool:

http://<serverip>

[Sun Jul 01 12:28:19 2007] [error] [client 1.2.3.4] client denied by server configuration: /var/www/sharedip/
[Sun Jul 01 12:28:19 2007] [error] [client 1.2.3.4] client denied by server configuration: /var/www/sharedip/favicon.ico

Access forbidden!

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.
Error 403
1.2.3.4
Sun Jul 1 12:29:40 2007
Apache/2.2.3 (Linux/SUSE)


Is it possible that ISPConfig can't handle .name domains?


Additional - why must I add .htaccess configuration manually inside http.conf?

Why my directive

AllowOverwrting All

inside vhost settings is ignored?

Apache Direktiven
(Optional):

php_admin_flag register_globals on
AllowOverride All

but htaccess directive is not added:

######################################
# Vhost: www.domain.tld:80
######################################
#
#
<VirtualHost 1.2.3.4:80>
php_admin_flag register_globals on
AccessFileName .htaccess
ServerName www.domain.tld:80
ServerAdmin webmaster@domain.tld
DocumentRoot /home/www/web10/web
ServerAlias domain.tld
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /home/www/web10/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /home/www/web10/log/error.log
AddHandler application/x-httpd-php .php .php3 .php4 .php5
php_admin_flag safe_mode Off
Alias /error/ "/home/www/web10/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /home/www/web10/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web10/user/$1/web/$3
</VirtualHost>

Very confused ...

Last edited by Elfchen; 1st July 2007 at 11:02.
Reply With Quote
  #4  
Old 1st July 2007, 11:20
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,988
Thanks: 825
Thanked 5,373 Times in 4,220 Posts
Default

Quote:
Maybe it's necessary to create inside vhost settings user & mail + FTP to create a complete working account. Wondering why this is not done automatically when creating vhost.
Sure you must create a administrator account. ISPConfig can not guess the username password and email address of the user

To your second problem, you must access the website by its domain name and not IP.

Quote:
AllowOverwrting All
There is no such directive. I guess you mean "AllowOverride All". and it should be placed inside of directory directives.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st July 2007, 11:30
Elfchen Elfchen is offline
Member
 
Join Date: Jun 2007
Posts: 56
Thanks: 2
Thanked 1 Time in 1 Post
Unhappy

Quote:
Originally Posted by till
Sure you must create a administrator account. ISPConfig can not guess the username password and email address of the user
Ok did it, but in vhosts/Vhosts_ispconfig.conf there are still no new hosts added. I can create whatever I want trough ISPConfig admin panel - no host is added to these file.

Quote:
Originally Posted by till
To your second problem, you must access the website by its domain name and not IP.
I know ... but there is a standard page created by you which should inform the user that he should use domainname instead of IP. You've created it here:
/var/www/sharedip/index.html

and it should show these page and not a 403 error

Quote:
Originally Posted by till
There is no such directive. I guess you mean "AllowOverride All". and it should be placed inside of directory directives.
sorry only a type mismatch (night was too long ... still up since yesterday morning). I have added AllowOverride All but it's ignored and not added into apaches vhost config, too - like the first that no vhost is now created whatever i do.

inside passwd the user now is created - but now the vhost entry is missing.

Additional link in the past in /home/www had:

lrwxrwxrwx 1 root web8

now they are:

lrwxrwxrwx 1 wwwrun web20

The only thing I did since nothing is working is to add your phpmyadmin addon (even when I hate it, but user has requested). Since I did this I have these massive problems and nothing is done correct. I am very confused and don't know how to fix that.


Next thing broken:

No welcome mails are sent when anything is created ...


WARNING:
It seems like the phpmyadmin addon completly crashes the whole system.

Last edited by Elfchen; 1st July 2007 at 11:39.
Reply With Quote
  #6  
Old 2nd July 2007, 18:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Is AppArmor disabled?
What are the output of
Code:
ls -la /root/ispconfig
and
Code:
df -h
?
Any errors in your log files?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 6th July 2007, 17:01
Elfchen Elfchen is offline
Member
 
Join Date: Jun 2007
Posts: 56
Thanks: 2
Thanked 1 Time in 1 Post
Question here it is

Code:
ls -la /root/ispconfig
total 12
drwxr-xr-x 3 root root 4096 Jul  1 13:46 .
drwx------ 9 root root 4096 Jul  1 13:46 ..
drwxr-xr-x 3 root root 4096 Jul  1 13:46 httpd
and here the next you've requested:

Code:
df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda5              15G  3.5G   11G  26% /
udev                  125M   84K  125M   1% /dev
/dev/hda6              22G  763M   20G   4% /home
Remember that /home/www/htdocs is used instead of /srv/www/htdocs

the last you've requested:

Code:
# apparmor_status
apparmor module is not loaded.
Note: vhosts I've installed before phpmyadmin addon works well. vhost I've created after .htaccess and phpmyadmin did not work.

Only this is added to httpd.conf to get .htaccess password protection working:

Code:
<Directory "/home/www/web10/web">
#Options FollowSymLinks
AllowOverride All
</Directory>
Code:
l /home/www/
total 52
drwxr-xr-x 13 root                       root  4096 Jul  1 12:55 ./
drwxr-xr-x  7 root                       root  4096 Jun 24 10:42 ../
drwxr-xr-x  3 root                       root  4096 Jun 25 00:30 1.2.3.4/
drwxr-xr-x  3 root                       root  4096 Jun 24 10:42 servername.domain-name.com/
drwxr-xr-x  2 root                       root  4096 Jun 24 10:42 cgi-bin/
drwxr-xr-x  3 root                       root  4096 Jun 25 10:06 htdocs/
drwxr-xr-x  3 root                       root  4096 Jun 24 10:42 localhost/
drwxr-xr-x  2 root                       root  4096 Jun 24 10:42 perl-lib/
drwxr-xr-x  8 web10_domain.de              web10 4096 Jun 30 20:18 web10/
drwxr-xr-x  8 web11_domain.us        web11 4096 Jun 26 00:45 web11/
drwxr-xr-x  8 web12_domain.com       web12 4096 Jun 25 04:00 web12/
drwxr-xr-x  8 web20_domain.net     web20 4096 Jul  1 12:55 web20/
drwxr-xr-x  8 web8_domain.biz web8  4096 Jun 25 12:38 web8/
lrwxrwxrwx  1 root                       web10   15 Jun 24 11:37 www.domain.de -> /home/www/web10/
lrwxrwxrwx  1 root                       web12   15 Jun 24 11:58 www.domain.com -> /home/www/web12/
lrwxrwxrwx  1 root                       web11   15 Jun 24 11:38 www.domain.us -> /home/www/web11/
lrwxrwxrwx  1 wwwrun                     web20   15 Jul  1 12:55 www.domain.net -> /home/www/web20/
lrwxrwxrwx  1 root                       web8    14 Jun 24 11:22 www.domain.biz -> /home/www/web8/
but last host (domain.net) is not created inside /etc/apache2/vhosts/Vhosts_ispconfig.conf
There an entry for this host is completly missing.

please note the difference in ownership root / wwwrun

deleting and recreation of the vhost will always end in the same result.

Code:
l /etc/apache2/vhosts/
total 336
drwxr-xr-x  2 root root 4096 Jul  1 12:55 ./
drwxr-xr-x 13 root root 4096 Jul  6 19:59 ../
-rw-r--r--  1 root root 5061 Jul  1 12:55 Vhosts_ispconfig.conf
-rw-r--r--  1 root root 6164 Jul  1 05:15 Vhosts_ispconfig.conf_01-07-07_05-15-40
-rw-r--r--  1 root root 7237 Jul  1 05:16 Vhosts_ispconfig.conf_01-07-07_05-16-09
-rw-r--r--  1 root root 6164 Jul  1 11:22 Vhosts_ispconfig.conf_01-07-07_11-22-23
-rw-r--r--  1 root root 5111 Jul  1 11:22 Vhosts_ispconfig.conf_01-07-07_11-22-40
-rw-r--r--  1 root root 5111 Jul  1 11:23 Vhosts_ispconfig.conf_01-07-07_11-23-58
-rw-r--r--  1 root root 6531 Jul  1 11:24 Vhosts_ispconfig.conf_01-07-07_11-24-27
-rw-r--r--  1 root root 6531 Jul  1 11:25 Vhosts_ispconfig.conf_01-07-07_11-25-07
-rw-r--r--  1 root root 6531 Jul  1 11:25 Vhosts_ispconfig.conf_01-07-07_11-25-25
-rw-r--r--  1 root root 6531 Jul  1 11:26 Vhosts_ispconfig.conf_01-07-07_11-26-31
-rw-r--r--  1 root root 5111 Jul  1 11:31 Vhosts_ispconfig.conf_01-07-07_11-31-16
-rw-r--r--  1 root root 5111 Jul  1 11:32 Vhosts_ispconfig.conf_01-07-07_11-32-14
-rw-r--r--  1 root root 6097 Jul  1 11:32 Vhosts_ispconfig.conf_01-07-07_11-32-42
-rw-r--r--  1 root root 5111 Jul  1 11:41 Vhosts_ispconfig.conf_01-07-07_11-41-00
-rw-r--r--  1 root root 5111 Jul  1 11:41 Vhosts_ispconfig.conf_01-07-07_11-41-17
-rw-r--r--  1 root root 6285 Jul  1 11:44 Vhosts_ispconfig.conf_01-07-07_11-44-57
-rw-r--r--  1 root root 6285 Jul  1 11:46 Vhosts_ispconfig.conf_01-07-07_11-46-25
-rw-r--r--  1 root root 6285 Jul  1 11:47 Vhosts_ispconfig.conf_01-07-07_11-47-11
-rw-r--r--  1 root root 6285 Jul  1 11:54 Vhosts_ispconfig.conf_01-07-07_11-54-09
-rw-r--r--  1 root root 6285 Jul  1 11:54 Vhosts_ispconfig.conf_01-07-07_11-54-28
-rw-r--r--  1 root root 6285 Jul  1 11:55 Vhosts_ispconfig.conf_01-07-07_11-55-34
-rw-r--r--  1 root root 6285 Jul  1 12:14 Vhosts_ispconfig.conf_01-07-07_12-14-12
-rw-r--r--  1 root root 6285 Jul  1 12:14 Vhosts_ispconfig.conf_01-07-07_12-14-49
-rw-r--r--  1 root root 6474 Jul  1 12:27 Vhosts_ispconfig.conf_01-07-07_12-27-47
-rw-r--r--  1 root root 5111 Jul  1 12:31 Vhosts_ispconfig.conf_01-07-07_12-31-03
-rw-r--r--  1 root root 5111 Jul  1 12:31 Vhosts_ispconfig.conf_01-07-07_12-31-30
-rw-r--r--  1 root root 5111 Jul  1 12:33 Vhosts_ispconfig.conf_01-07-07_12-34-00
-rw-r--r--  1 root root 5111 Jul  1 12:38 Vhosts_ispconfig.conf_01-07-07_12-38-49
-rw-r--r--  1 root root 6462 Jul  1 12:55 Vhosts_ispconfig.conf_01-07-07_12-55-19
-rw-r--r--  1 root root 6462 Jul  1 12:55 Vhosts_ispconfig.conf_01-07-07_12-55-38
-rw-r--r--  1 root root 5061 Jun 26 21:26 Vhosts_ispconfig.conf_26-06-07_21-26-26
-rw-r--r--  1 root root 5061 Jun 26 21:27 Vhosts_ispconfig.conf_26-06-07_21-27-13
-rw-r--r--  1 root root 5054 Jun 26 21:28 Vhosts_ispconfig.conf_26-06-07_21-28-12
-rw-r--r--  1 root root 5054 Jun 26 21:28 Vhosts_ispconfig.conf_26-06-07_21-28-28
-rw-r--r--  1 root root 5061 Jun 26 21:38 Vhosts_ispconfig.conf_26-06-07_21-38-47
-rw-r--r--  1 root root 5061 Jun 26 21:39 Vhosts_ispconfig.conf_26-06-07_21-39-02
-rw-r--r--  1 root root 5061 Jun 26 21:42 Vhosts_ispconfig.conf_26-06-07_21-42-31
-rw-r--r--  1 root root 5054 Jun 26 21:47 Vhosts_ispconfig.conf_26-06-07_21-47-50
-rw-r--r--  1 root root 5054 Jun 26 21:48 Vhosts_ispconfig.conf_26-06-07_21-48-06
-rw-r--r--  1 root root 5054 Jun 26 22:06 Vhosts_ispconfig.conf_26-06-07_22-06-44
-rw-r--r--  1 root root 5111 Jun 30 20:18 Vhosts_ispconfig.conf_30-06-07_20-18-37

Last edited by Elfchen; 6th July 2007 at 19:02.
Reply With Quote
  #8  
Old 7th July 2007, 17:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by Elfchen
Code:
ls -la /root/ispconfig
total 12
drwxr-xr-x 3 root root 4096 Jul  1 13:46 .
drwx------ 9 root root 4096 Jul  1 13:46 ..
drwxr-xr-x 3 root root 4096 Jul  1 13:46 httpd
The whole ISPConfig backend (except for ISPConfig's Apache) is missing! Did you accidentally delete it?
What's in the /home/admispconfig directory? Does the ISPConfig MySQL database still exist, and if so, is it empty, or are the ISPConfig tables in it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 7th July 2007, 17:42
Elfchen Elfchen is offline
Member
 
Join Date: Jun 2007
Posts: 56
Thanks: 2
Thanked 1 Time in 1 Post
Default

no it's not missing. please read what I wrote - ISPConfig works well - I can create, add, modify ... a.s.o. without any problem:

see it here:

Code:
/home # l
total 40
drwxr-xr-x  7 root         root          4096 Jun 24 10:42 ./
drwxr-xr-x 20 root         root          4096 Jul  7 12:00 ../
drwxr-xr-x  4 admispconfig admispconfig  4096 Jun 19 18:34 admispconfig/
drwx------  2 root         root         16384 Mar 25 13:01 lost+found/
drwxr-xr-x  9         1000 users         4096 Jun 26 00:17 nibbler/
drwxr-xr-x  4 root         root          4096 Jul  1 13:44 ullahuppman/
drwxr-xr-x 13 root         root          4096 Jul  1 12:55 www/
Seems there is a path problem anywhere ... when you call https://ip:81 the ISPConfig panel works well.


maybe this will help you:

Code:
01.07.2007 - 12:38:43 => INFO - Signalfile Set: update
01.07.2007 - 12:38:47 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
01.07.2007 - 12:38:47 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
01.07.2007 - 12:38:48 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
01.07.2007 - 12:38:48 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1231: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
01.07.2007 - 12:38:48 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1892: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
01.07.2007 - 12:38:49 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2390: WARNING: could not httpd -t  &> /dev/null
01.07.2007 - 12:38:49 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2401: httpd syntax seems to contain errors, restarting with old configuration
01.07.2007 - 12:38:49 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2402: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf_01-07-07_12-38-49
01.07.2007 - 12:38:49 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2403: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf~ /etc/apache2/vhosts/Vhosts_ispconfig.conf
01.07.2007 - 12:38:53 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/apache2 restart &> /dev/null
01.07.2007 - 12:38:53 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/bastille-firewall stop &> /dev/null
01.07.2007 - 12:55:06 => INFO - Signalfile Set: insert
01.07.2007 - 12:55:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1059: cp -fr /root/ispconfig/isp/error_de /home/www/web20/web/error
01.07.2007 - 12:55:17 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1099: ln -s /home/www/web20 /home/www/www.domain.net
01.07.2007 - 12:55:18 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 94: setquota -g web20 512000 513024 0 0 -a &> /dev/null
01.07.2007 - 12:55:18 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 95: setquota -T -g web20 604800 604800 -a &> /dev/null
01.07.2007 - 12:55:18 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 116: Connected successfully
01.07.2007 - 12:55:18 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 214: MySQL FLUSH PRIVILEGES
01.07.2007 - 12:55:18 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
01.07.2007 - 12:55:18 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
01.07.2007 - 12:55:19 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
01.07.2007 - 12:55:19 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1231: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
01.07.2007 - 12:55:19 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2418: WARNING: could not httpd -t  &> /dev/null
01.07.2007 - 12:55:19 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2429: httpd syntax seems to contain errors, reloading with old configuration
01.07.2007 - 12:55:19 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2430: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf_01-07-07_12-55-19
01.07.2007 - 12:55:19 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2431: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf~ /etc/apache2/vhosts/Vhosts_ispconfig.conf
01.07.2007 - 12:55:22 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/apache2 reload &> /dev/null
01.07.2007 - 12:55:22 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix stop &> /dev/null
01.07.2007 - 12:55:23 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix start &> /dev/null
01.07.2007 - 12:55:23 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1892: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
01.07.2007 - 12:55:27 => INFO - Signalfile Set: insert
01.07.2007 - 12:55:35 => INFO - USER:
web20_domain.net:x:10011:10020:domain.net:/home/www/web20:/bin/false
01.07.2007 - 12:55:36 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 709: create /var/spool/mail/web20_domain.net
01.07.2007 - 12:55:36 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 710: chown web20_domain.net:mail /var/spool/mail/web20_domain.net &> /dev/null
01.07.2007 - 12:55:36 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 711: chmod 600 /var/spool/mail/web20_domain.net
01.07.2007 - 12:55:36 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 717: setquota -u web20_domain.net 0 0 0 0 -a &> /dev/null
01.07.2007 - 12:55:36 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 718: setquota -T -u web20_domain.net 604800 604800 -a &> /dev/null
01.07.2007 - 12:55:36 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 57: cp -f /root/ispconfig/isp/conf/forward.master /home/www/web20/.forward
01.07.2007 - 12:55:36 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
01.07.2007 - 12:55:36 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
01.07.2007 - 12:55:37 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
01.07.2007 - 12:55:37 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1231: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
01.07.2007 - 12:55:38 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2418: WARNING: could not httpd -t  &> /dev/null
01.07.2007 - 12:55:38 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2429: httpd syntax seems to contain errors, reloading with old configuration
01.07.2007 - 12:55:38 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2430: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf_01-07-07_12-55-38
01.07.2007 - 12:55:38 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2431: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf~ /etc/apache2/vhosts/Vhosts_ispconfig.conf
01.07.2007 - 12:55:39 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/apache2 reload &> /dev/null
01.07.2007 - 12:55:40 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix stop &> /dev/null
01.07.2007 - 12:55:41 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix start &> /dev/null
01.07.2007 - 12:55:41 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1892: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
01.07.2007 - 13:18:10 => DEBUG - Installation instructions not found: /home/admispconfig/ispconfig/temp/2ee9e27046af12869f64942066d52c11/package.ins
tell me if you need access to server.

Last edited by Elfchen; 7th July 2007 at 17:53.
Reply With Quote
  #10  
Old 7th July 2007, 17:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,988
Thanks: 825
Thanked 5,373 Times in 4,220 Posts
 
Default

Falko has read your post correctly and gave the correct answer. The complete backend is missing. If you can create someting in the ISPConfig frontend is not relevant. When the backensd is missing, nothing is written to the config files.

The backend is in /root/ispconfig and not /home.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Anything I can do against illegal login-requests? schmidtedv Installation/Configuration 17 7th November 2008 09:25
log files cruz Technical 3 15th May 2007 14:35
Perfect setup and kernel ubgrade for SUSE 10.2 simby Suggest HOWTO 7 21st December 2006 18:41
email accounts created with user name jlorenzo Installation/Configuration 7 30th August 2006 08:58


All times are GMT +2. The time now is 12:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.