Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th June 2007, 20:04
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 149 Times in 130 Posts
Default Postix and 2nd IP problem (on one of my servrs)

Okay.. I've been at this some time now, and I'm about to give up!..

I'm trying to get postfix to use my 2nd IP when sending email!
I've got it working fine on server-1, but on my server-2 I can not get it to work for some reason! (it keeps using the main IP)

I've been comparing some files, and they are all setup the same (exept IP's and domain names)

Both postfix main.cf files are setup the same.
postconf -n and postconf are setup the same.
Filrewals on both system are setup the same.
DNS records on both systems are setup the same.
hostname -f and hostname showup the same.
Both server have the same /etc/hosts setup.

I've restarted postfix about a 100 times..

When I did the setup for server-1 I think that I had to do some "trick" to get it to work. (it's a long time ago)

Sending email from server-1 shows my 2nd IP (what I want).
Sending email from server-2 shows my 1st IP (NOT what I want. I want it to show my 2nd IP of server-2).

Anyone here who might have a clue for me?
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Sponsored Links
  #2  
Old 28th June 2007, 21:53
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 149 Times in 130 Posts
Default

Okay,

After adding "smtp_bind_address=21.21.21.21" to the postfix main.cf (and restarting postfix) I got it to work for my server-2

The strange thing is that I do not have this in the working server-1 setup!
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 29th June 2007, 18:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
 
Default

Quote:
Originally Posted by edge
After adding "smtp_bind_address=21.21.21.21" to the postfix main.cf (and restarting postfix) I got it to work for my server-2
That's the correct setting. Don't know why server1 does it without it...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.