Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Technical

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd November 2005, 07:51
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,235
Thanks: 69
Thanked 21 Times in 17 Posts
Default I am getting glibc errors

I do not know anything about this, so I`ll post some lines from my logfiles:

Quote:
Nov 22 14:05:08 hxxxx proftpd[1213]: hxxxx.serverkompetenz.net
(218.234.13.xxx[218.234.13.xxx]) - USER web: no such user found from 218.234.13.xxx
[218.234.13.xxx] to 81.169.xxx.xxx:21
Nov 22 14:05:08 hxxxx *** glibc detected *** corrupted double-linked list:
0x081102a0 ***
Nov 22 14:05:08 hxxxx proftpd[1235]: hxxxx.serverkompetenz.net
Quote:
Nov 22 14:05:11 hxxxx proftpd[1252]: hxxxx.serverkompetenz.net
(218.234.13.xxx[218.234.13.xxx]) - no such user 'web'
Nov 22 14:05:11 hxxxx *** glibc detected *** free(): invalid next size (fast):
0x08110270 ***
Nov 22 14:05:11 hxxxx proftpd[1251]: hxxxx.serverkompetenz.net
Quote:
Nov 23 00:28:40 hxxxx *** glibc detected *** malloc(): memory corruption: 0x081118b0
***
Any idea how to track this error down and remove?
Reply With Quote
Sponsored Links
  #2  
Old 4th December 2005, 20:51
themachine themachine is offline
Senior Member
 
Join Date: Oct 2005
Location: Texas, USA
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Tenaka
Any idea how to track this error down and remove?

What OS and version are you running?


What version of glibc is it? Please post the output of one of the following:

RedHt/Fedorea:
Code:
# rpm -qa | grep -i glibc

or

# rpm -qa | grep -i libc6

or something...
Debian:
Code:
# dpkg -l libc6
__________________
themachine
5dollarwhitebox.org
Reply With Quote
  #3  
Old 4th December 2005, 22:53
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,235
Thanks: 69
Thanked 21 Times in 17 Posts
Default

debian 3.1

Quote:
h5810:~/eaccelerator-0.9.4-rc1# dpkg -l libc6
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Säubern/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/Fehlgeschl. Konf./Halb install.
|/ Fehler?=(keiner)/Halten/R=Neuinst. notw/X=beides (Status, Fehler: GROß=schlecht)
||/ Name Version Beschreibung
+++-==============-==============-============================================
ii libc6 2.3.5-6 GNU C Library: Shared libraries and Timezone
h5810:~/eaccelerator-0.9.4-rc1#
Reply With Quote
  #4  
Old 5th December 2005, 02:22
themachine themachine is offline
Senior Member
 
Join Date: Oct 2005
Location: Texas, USA
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Tenaka
debian 3.1

Did you manually upgrade that at some point? On my 3.1 box I have version 2.3.2.ds1-22...


Check out this forum... your not the only one having those issues with libc6 2.3.5*... http://www.linuxquestions.org/questi...hreadid=349135
__________________
themachine
5dollarwhitebox.org

Last edited by themachine; 5th December 2005 at 02:25.
Reply With Quote
  #5  
Old 5th December 2005, 10:09
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,235
Thanks: 69
Thanked 21 Times in 17 Posts
Default

I already googled around, I remember seeing that post too, but as I have not programmed anything, using only ready - made packages (almost) I thought no longer about this issue...

I guess I'll try a downgrade tonight but I do not remember who or what programm requiered newer version of libc6...
Reply With Quote
  #6  
Old 5th December 2005, 20:31
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,235
Thanks: 69
Thanked 21 Times in 17 Posts
Default

if I downgrade to that version with apt-get install libc6=2.3.2.ds1-22 there are a lot of packages marked for removal.
How would I also mark those dependencies for downgrade ?

While waiting for help I will upgrade libc6 to its unstable version which will only upgrade 2 more packages to unstable, maybe the problem is solved with the never package!?

the upgrade helped with ftp uploads, it no longer disconnects me when uploading but when trying to list a remote folder it still gives glibc errors...

any suggestion on how to downgrade libc6 and its dependencies? or might an upgrade of proftpd help?

Last edited by Ovidiu; 5th December 2005 at 20:58.
Reply With Quote
  #7  
Old 20th December 2005, 14:31
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,235
Thanks: 69
Thanked 21 Times in 17 Posts
Default

to revive that old post:

I did not succeed in downgrading, upgrading did not help.

maybe someone can help here:

Quote:
if I downgrade to that version with apt-get install libc6=2.3.2.ds1-22 there are a lot of packages marked for removal.
How would I also mark those dependencies for downgrade ?
Reply With Quote
  #8  
Old 20th December 2005, 16:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

To be honest: it's not the best idea to upgrade/downgrade glibc, because too many programs rely on it. If you do it nevertheless, chances are good that you mess up your system.

If it is not a production system, I'd suggest that you re-install the system from the beginning.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 20th December 2005, 17:05
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,235
Thanks: 69
Thanked 21 Times in 17 Posts
Default

ok I udnerstood that but is it technicall ypossible?

i.e. If I upgrade a package, packages relying upon it are automatically marked for upgrade as well, but if I downgrade a package the packages depending on it are marked for deletion instead, so how would I go about this if I would want to do it?
Reply With Quote
  #10  
Old 20th December 2005, 20:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

I've never been able to upgrade/downgrade glibc without getting dependancy errors, so - theoretically it should be possible, practically it's more than difficult...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile Kernel 2.6 under Debian Sarge falko Kernel Questions 117 28th September 2009 13:03
Several errors and ideas for features jmroth Feature Requests 16 6th March 2006 05:39
FC3 Perfect Installation Make Errors solderboy HOWTO-Related Questions 3 2nd October 2005 16:55
Perfect Fedora Core 4 install (GPG key errors) linuxfast HOWTO-Related Questions 2 16th September 2005 19:54
Postfix Errors? bolinux General 5 20th August 2005 16:06


All times are GMT +2. The time now is 01:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.