Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd June 2007, 15:12
tannnk tannnk is offline
Junior Member
 
Join Date: Jun 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default vhost not working on ISPConfig 2.2.13

Hi, I have a problem setting a virtual host on apache2.
I did a clean install on a Debian 4.0 using the perfect setup howto.
My box has an internal IP address and is on DMZ on my gateway. I declared the external IP in ispconfig and selected that external address when I declared the new website.
The problem is that when I go to www.xxx.com it redirects me to www.xxx.com/apache2-default/ and there is nothing I can do to get to my vhost.
I have applied php 5.0.4 patch
Reply With Quote
Sponsored Links
  #2  
Old 22nd June 2007, 15:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

You must use your internal and not external IP in ISPConfig.

Quote:
I have applied php 5.0.4 patch
This patch is deprected and unneeded but it does not harm.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd June 2007, 15:31
tannnk tannnk is offline
Junior Member
 
Join Date: Jun 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till
You must use your internal and not external IP in ISPConfig.



This patch is deprected and unneeded but it does not harm.
I had the problem where Vhosts_ispconfig.conf was not being updated. After applying the patch it worked fine.

I changed the IP address of my website from the external address to the internal and it worked fine.
Thanks!

Last edited by tannnk; 22nd June 2007 at 16:21.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 5.x + ISPConfig 2.2.13 bradis Installation/Configuration 2 6th June 2007 10:07
FTP has stopped working for ISPConfig accounts manyowls Installation/Configuration 2 4th August 2006 14:49
FC4 Setup DNS and ISPCONFIG issues The General Installation/Configuration 7 15th May 2006 10:45
42goISP vs. ISPConfig nveid General 1 16th January 2006 10:07
ISPconfig not working Venkatesh.S Installation/Configuration 2 28th July 2005 14:28


All times are GMT +2. The time now is 02:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.