Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th June 2007, 23:36
bagpiperdude90 bagpiperdude90 is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 4
Thanked 22 Times in 5 Posts
Default Postfix isn't working right on my (port 25 blocked) connection

Hey,

Ok - long story short, I'm a small web designer, and I end up hosting most of my clients sites on my Fedora 6 server, running ISPConfig and Postfix.

Right now, if they need email, I just sign them up with google's apps for your domain service, which provides free email domain hosting. Works great, until now... I have two clients; one wants a PHPbb forum, and the other wants Zen cart. Both *need* emails to be able to be sent from the website via PHP scripts. I want to be able to use their domain name, (i.e. Sales@domain.com, instead of StoreName@hotmail.com). Simple - just use Postfix.

Well, I have another problem. I'm on a Bellsouth DSL connection, with port 25 blocked. I've talked with them, and threatened to leave, and they won't unblock port 25.

Supposedly, I can authenticate all my outgoing mail through my ISP's email servers, because my gmail account can send outgoing just fine. So, connecting the dots, you'd think I would be able to send my domain.com email through their mailservers, right? People have told me I can...

Could anybody do me a BIG favor, and let me know how to do this, or link me to some tutorials? I'll make a fresh install of any distro you want, and install whatever packages, and follow any directions. I have a spare server to use. I don't care if its postfix or sendmail at this point - I just want something to work, so I can see that it does work and how it does work.

FYI: ISP is bellsouth, so mailservers are mail.bellsouth.net.

Thank you very very very much for any replies!
Reply With Quote
Sponsored Links
  #2  
Old 20th June 2007, 23:52
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 649 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Hi,

This thread could be very interesting for you:
http://www.howtoforge.com/forums/showthread.php?t=13556
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #3  
Old 21st June 2007, 00:26
bagpiperdude90 bagpiperdude90 is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 4
Thanked 22 Times in 5 Posts
Default

wow, most entertaining thread in a while! Sends me in circles...

Check the link... you linked to this one ;-)

Thanks for replying though!
Reply With Quote
  #4  
Old 21st June 2007, 04:20
aqua aqua is offline
Member
 
Join Date: Mar 2006
Posts: 60
Thanks: 4
Thanked 3 Times in 3 Posts
Default

Thistut by falko is what you need.

http://www.howtoforge.com/postfix_re...her_mailserver

Make sure that your php forums *actually* use your postfix. most of them default to trying to send out mail on their own, which is as you found out, blocked.

aqua
Reply With Quote
The Following User Says Thank You to aqua For This Useful Post:
bagpiperdude90 (21st June 2007)
  #5  
Old 21st June 2007, 04:46
bagpiperdude90 bagpiperdude90 is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 4
Thanked 22 Times in 5 Posts
Default

ah! ok thanks!
Reply With Quote
  #6  
Old 21st June 2007, 05:01
bagpiperdude90 bagpiperdude90 is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 4
Thanked 22 Times in 5 Posts
Default

Well, I followed the directions... here's what I got back...


Quote:

This is the mail system at host localhost.localdomain.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system
Next is this:

Quote:
<********@gmail.com>: host mx00.mail.bellsouth.net[205.152.58.32] said:
550 #5.1.0 Address rejected. (in reply to RCPT TO command)
Or this:

Quote:
<********@gmail.com>: host mx01.mail.bellsouth.net[205.152.58.33] said:
550 relaying mail to gmail.com is not allowed (in reply to RCPT TO command)
Continues:

Quote:
Reporting-MTA: dns; localhost.localdomain
X-Postfix-Queue-ID: 6F58E14C8320
X-Postfix-Sender: rfc822; admin@[mydomain].com
Arrival-Date: Wed, 20 Jun 2007 22:57:32 -0400 (EDT)

Final-Recipient: rfc822; ********@gmail.com
Original-Recipient: rfc822;**********@gmail.com
Action: failed
Status: 5.0.0
Remote-MTA: dns; mx00.mail.bellsouth.net
Diagnostic-Code: smtp; 550 #5.1.0 Address rejected.


I'll look around to see what's going on.

Last edited by bagpiperdude90; 21st June 2007 at 05:06.
Reply With Quote
  #7  
Old 21st June 2007, 05:07
bagpiperdude90 bagpiperdude90 is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 4
Thanked 22 Times in 5 Posts
Default

Funny thing is... it works if I send it to the bellsouth.net address I'm SMTP-AUTHing with.
Reply With Quote
  #8  
Old 21st June 2007, 05:53
bagpiperdude90 bagpiperdude90 is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 4
Thanked 22 Times in 5 Posts
Default

hmm... maybe bellsouth.net doesn't even require SMTP-AUTH? I can enter this into console: (reply is in quotes, my commands are in non-quotes)

[root@localhost]# telnet mail.bellsouth.net 25
Quote:
Trying 205.152.59.16...
Connected to mail.bellsouth.net.
Escape character is '^]'.
220 ibm69aec.bellsouth.net ESMTP server ready Wed, Jun 20, 2007 23:43:20 -0400
EHLO
Quote:
250-ibm69aec.bellsouth.net
250-HELP
250-PIPELINING
250-DSN
250-8BITMIME
250 SIZE 26214400
quit
Quote:
221 ibm69aec.bellsouth.net ESMTP server closing connection
Connection closed by foreign host.

Didn't ask for Authentication. Does that mean I don't need SMTP-AUTH?

I'm so confused...


EDIT -

So, I turned off SMTP-AUTH by doing this:

"
postconf -e 'relayhost = mail.bellsouth.net'
postconf -e 'smtp_sasl_auth_enable = no'
"

And tried sending mail. I can still connect... but I get the same old "Diagnostic-Code: smtp; 550 #5.1.0 Address rejected." thing.

Grrrr.

Appreciate any help... :-)

Last edited by bagpiperdude90; 21st June 2007 at 05:58.
Reply With Quote
  #9  
Old 21st June 2007, 06:18
bagpiperdude90 bagpiperdude90 is offline
Member
 
Join Date: Mar 2007
Posts: 34
Thanks: 4
Thanked 22 Times in 5 Posts
 
Default

IT WORKS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

2 months later... finally!

Thanks for sending me that link... turns out all I had to do was:

edit my /etc/postfix/main.cf file, and add:

"
relayhost = [mail.bellsouth.net]
"
Then of course, restarting postfix.

It needed those darned brackets. No SMTP-AUTH needed. Just takes it as I send it. Dang.

I assume that was the same as saying:

"
postconf -e 'relayhost = [mail.bellsouth.net]'
"


Man. Finally. Thanks for all the help, people! I'm one happy camper now :-)



Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
My php scripts don't send e-mail html forms. CombatGod Installation/Configuration 5 8th November 2006 10:16
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 22:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.