Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 11th July 2007, 09:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,383
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

The stats are not updated because you removed the cronjobs.

What happens if you execute the following commands:

/root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php

/root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php

/root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 11th July 2007, 19:03
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Hi Till,
I tried those commands and nothing seems to happen

shajazzi
Reply With Quote
  #13  
Old 12th July 2007, 13:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

But were the FTP and mail stats updated?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 16th July 2007, 01:17
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 3 Times in 3 Posts
Default

The mail stats where updated but nothing in the web logs.
I deleted all web and mail logs, also awstats and all stats from all sites.
Replaced the following in cron, just to see if this was causing any problem in that my logs maybe too large.

59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null

Then reinstalled awstats and all was ok for a couple of days.
Then tonight at 23.59 php started eating my cpu again. I stopped it with this command `pkill php` and all is ok and everything seems to work OK without a reboot.
I seem to have so many problems with SUSE, if i cannot fix this problem without a complete reinstall i am switching to debian

shajazzi
Reply With Quote
  #15  
Old 16th July 2007, 14:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by shajazzi
I seem to have so many problems with SUSE, if i cannot fix this problem without a complete reinstall i am switching to debian
That would be a good move!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 15th August 2007, 01:19
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 3 Times in 3 Posts
 
Default

OK,
I have changed to Debian and all is well.
I have found the problem, it seems that my server was being hit with a lot of mail at 23.59 hrs so i changed the lines in cron from

59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null

to

57 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
57 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
57 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null

All has been working OK for the last 2 weeks. It seem that spam is hitting my mail boxes at 23.59 hrs every evening causing heavy php useage and my server seems to get stuck in a stagnant loop.

shajazzi
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 09:54
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 13th March 2006 23:58


All times are GMT +2. The time now is 08:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.