#11  
Old 16th June 2007, 18:57
Liac Liac is offline
Junior Member
 
Join Date: Jun 2007
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Okay, but still, thank you so much for trying to help me

Take care
Reply With Quote
Sponsored Links
  #12  
Old 17th June 2007, 13:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

What's the directory where you've put your .htaccess file? Do you use ISPConfig?

Any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 18th June 2007, 06:14
Liac Liac is offline
Junior Member
 
Join Date: Jun 2007
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Default

No, I don't use ISPConfig.

The directory where I put my .htaccess file (and already have my PHP scripts, etc) is: /var/www/

Apache's error log is full of errors saying that /var/www/favicon.ico does not exist . But apart from that, no errors that refer to .htaccess.

I just tried "ls -l" in "/var/www/" and the .htaccess file didn't show up. Yet, in my OpenSSH client it shows up and I can even edit it. Could this be the problem--that Apache simply does not see the file? Any ideas on how to fix this problem?
Reply With Quote
  #14  
Old 19th June 2007, 13:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by Liac
I just tried "ls -l" in "/var/www/" and the .htaccess file didn't show up. Yet, in my OpenSSH client it shows up and I can even edit it. Could this be the problem--that Apache simply does not see the file? Any ideas on how to fix this problem?
Files beginning with a dot (like .htaccess) are only shown if you use the -a switch (e.g.
Code:
ls -la /var/www
). That's the default behaviour and nothing to worry about.

Do you use Debian or Ubuntu? If so, what's in /etc/apache2/sites-available/default?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Liac (19th June 2007)
  #15  
Old 19th June 2007, 14:22
Liac Liac is offline
Junior Member
 
Join Date: Jun 2007
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I'm using Ubuntu Server 7.04.

Quote:
If so, what's in /etc/apache2/sites-available/default?
Wow, that led me into the right direction. The first lines were like this:

Code:
NameVirtualHost *
<VirtualHost *>
	ServerAdmin webmaster@localhost
	
	DocumentRoot /var/www/
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
		# This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                #RedirectMatch ^/$ /apache2-default/
	</Directory>
I changed in both the directory / and /var/www "AllowOverride None" to "AllowOverride All" and that did the trick. Thank you so much!

Can you explain why it disregarded the same <directory> tags in httpd.conf AND apache2.conf, while at the same time accepting it, when I change it in the "default" file? What's happening?

And what's the "default" file for, exactly? Do I have to put additional directives into this file? Or can I get rid of it so that I have only one configuration file, that is, httpd.conf?

Kind regards.
Reply With Quote
  #16  
Old 20th June 2007, 15:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
 
Default

The default file contains the default vhost (with the document root /var/www). That's why you must modify that vhost configuration if you put your files into /var/www.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wordpress MU and ISPconfig .htaccess isues palkat General 4 18th October 2006 11:57
ISPConfig and .htaccess ionut89 Feature Requests 1 17th October 2006 17:45
.htaccess login challenge broken with mod_rewrite ozonblue Installation/Configuration 2 13th September 2006 10:09
.htaccess never executed galmiche Server Operation 2 4th June 2006 21:44
No .htaccess in automatic backup? tron Installation/Configuration 3 22nd March 2006 18:03


All times are GMT +2. The time now is 12:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.