#1  
Old 13th June 2007, 21:02
tera7 tera7 is offline
Member
 
Join Date: Apr 2007
Posts: 44
Thanks: 0
Thanked 1 Time in 1 Post
Default postfix receive mail

hello i have just installed postfix following one of the howto's of this site and refered to others too.now i can sent mails but i can not receive it returns


Recipient address rejected: Relay access denied
554 5.0.0 Service unavailable
<<< 554 5.5.1 Error: no valid recipients

i searched the forum and saw about smtp_sasl_auth_enable.
but i dont think that is the problem.
thanks
Reply With Quote
Sponsored Links
  #2  
Old 14th June 2007, 21:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Do you use ISPConfig, or do you create your email accounts manually?
What's the output of
Code:
postconf -n
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th June 2007, 20:31
tera7 tera7 is offline
Member
 
Join Date: Apr 2007
Posts: 44
Thanks: 0
Thanked 1 Time in 1 Post
Default

no i dont use ispconfig.

the output is :


PHP Code:
alias_database hash:/etc/aliases
alias_maps 
hash:/etc/aliases
broken_sasl_auth_clients 
yes
command_directory 
= /usr/sbin
config_directory 
= /etc/postfix
daemon_directory 
= /usr/libexec/postfix
debug_peer_level 
2
home_mailbox 
Maildir/
html_directory no
inet_interfaces 
all
mail_owner 
postfix
mail_spool_directory 
= /var/spool/mail
mailbox_command 
=
mailq_path = /usr/bin/mailq.postfix
manpage_directory 
= /usr/share/man
mydestination 
$myhostnamelocalhost.$mydomain
mydomain 
pirateuropa.net
myhostname 
mail.pirateuropa.net
mynetworks 
127.0.0.0/8
myorigin 
$mydomain
newaliases_path 
= /usr/bin/newaliases.postfix
queue_directory 
= /var/spool/postfix
readme_directory 
= /usr/share/doc/postfix-2.3.3/
sample_directory = /usr/share/doc/postfix-2.3.3/
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group 
postdrop
smtp_tls_note_starttls_offer 
yes
smtp_use_tls 
yes
smtpd_recipient_restrictions 
permit_sasl_authe
_relay_domains
smtpd_sasl_auth_enable 
yes
smtpd_sasl_local_domain 
=
smtpd_sasl_security_options noanonymous
smtpd_tls_CAfile 
= /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only 
no
smtpd_tls_cert_file 
= /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file 
= /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel 
1
smtpd_tls_received_header 
yes
smtpd_tls_session_cache_timeout 
3600s
smtpd_use_tls 
yes
tls_random_source 
dev:/dev/urandom
unknown_local_recipient_reject_code 
550 
Reply With Quote
  #4  
Old 16th June 2007, 14:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You must create your email accounts as shown here: http://www.howtoforge.com/forums/showthread.php?t=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th June 2007, 21:39
tera7 tera7 is offline
Member
 
Join Date: Apr 2007
Posts: 44
Thanks: 0
Thanked 1 Time in 1 Post
Default ok

ok thanks now works perfect.but i want to ask something else.
i am forwarding the mails to my mail but i dont see the senders mail.
i checked dovecot.conf but i cant find something.
thank you
Reply With Quote
  #6  
Old 17th June 2007, 14:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

How do you send the initial mail? With a mail client or on the command line? Because the sender address should be set by the mail client.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 19th June 2007, 20:51
tera7 tera7 is offline
Member
 
Join Date: Apr 2007
Posts: 44
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

ok i was wrong just my mail client do tricks sorry.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix does not receive mail luketb Server Operation 5 16th April 2007 14:19
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16


All times are GMT +2. The time now is 17:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.