Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd March 2008, 23:04
wuptydu wuptydu is offline
Junior Member
 
Join Date: Feb 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Avoid https://name.tld:81 for phpmyadmin and roundcubemail

Hello

Is there a way to avoid https://name.tld:81 when accessing phpmyadmin and roundcubemail

Now the user must enter https://name.tld:81/phpmyadmin and the same for roundcubemail.

Would be nice if it was possible to change it such that they can be accessed like http://name.tld/webmail or http://webmail.name.tld.

A second question is it possible to change the roundcubemail url should that it would be renamed to webmail ?

Cheers
Wupty Du
Reply With Quote
Sponsored Links
  #2  
Old 3rd March 2008, 10:17
jorizzzz jorizzzz is offline
Member
 
Join Date: May 2007
Location: Soest, Netherlands
Posts: 81
Thanks: 1
Thanked 4 Times in 2 Posts
Send a message via MSN to jorizzzz
Default

What i've done is created a new co-domain for my website and set it to forward to my phpmyadmin and roundcubemail

Now if i go to webmail.<mydomain>.com, it automatically redirects me to https://<mydomain>.com:81/roundcubemail
Reply With Quote
  #3  
Old 3rd March 2008, 10:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,597
Thanks: 792
Thanked 4,984 Times in 3,904 Posts
Default

Maybe this is an option for you:

http://www.howtoforge.com/apache_rev...roxy_ispconfig
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 4th March 2008, 19:38
wuptydu wuptydu is offline
Junior Member
 
Join Date: Feb 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

till : It looks nice but i can't see how to transfer this for webmail and phpmyadmin and make it work on any site added in ISPConfig.

Can you give me a hint ?
Reply With Quote
  #5  
Old 5th March 2008, 15:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

I think all you have to do is adjust the ProxyPass and ProxyPassReverse lines.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 5th March 2008, 16:38
TomC TomC is offline
Member
 
Join Date: Mar 2008
Posts: 37
Thanks: 2
Thanked 0 Times in 0 Posts
Default

The Howto looks great, sounds exactly like what I was searching for.

Question: After configuring the ProxyPass, is there a way to disable remote access to port 81?
Reply With Quote
  #7  
Old 6th March 2008, 10:21
TomC TomC is offline
Member
 
Join Date: Mar 2008
Posts: 37
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hi All,

yesterday night I spent some time to configure my ISPConfig so that it would listen to port 80 - as described in the Howto mentioned above by Till.

Some comments on that:

1. I don't know why, but I had to adjust the VirtualHost settings:

Code:
[...]
<VirtualHost 111.222.333.444:80>
        ServerName ispconfig.example.com:80
[...]
Maybe it's because my machine runs on a Virtuozzo virtual server?

2. The performance when addressing ISPConfig via Proxy is awful. Every now and then I get proxy errors because of failed DNS requests, etc. So it looks that I might have another problem on my system that has to do with the resolver?!

3. When it comes to system configuration, I'd rather use SSL. So did you think about adjusting the howto for a SSL configuration?!

4. Once I can reach ISPConfig through my main Apache, there is no need to have the ISPConfig-Apache publically accessible. Is there a way to make this webserver a purely internal machine that is only accessible by proxying through the main webserver?

I'd love to read more about these subjects. Thanks loads in advance!
Tom
Reply With Quote
  #8  
Old 7th March 2008, 15:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by TomC
2. The performance when addressing ISPConfig via Proxy is awful. Every now and then I get proxy errors because of failed DNS requests, etc. So it looks that I might have another problem on my system that has to do with the resolver?!
What's in /etc/resolv.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 7th March 2008, 20:10
TomC TomC is offline
Member
 
Join Date: Mar 2008
Posts: 37
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hi Falco,

the reason for the performance problems were indeed a bad nameserver at 1und1. After correcting the entries in resolv.conf everything worked fabulous.

Point 3 is also solved - managed to reconfigure apache2 to forward from an ssl-Connection.

Point 4 is still of interest. How would you block a connect from !=localhost to access ispconfig on port 81?

Regards,
Tom
Reply With Quote
  #10  
Old 8th March 2008, 08:58
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 210
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
 
Default Simple alternative

You also can use the Redirect option within your /etc/apache2/apache2.conf file like this:

Redirect /webmail http://www.yourhostingcompany.com:81/roundcubemail
Redirect /phpmyadmin http://www.yourhostingcompany.com:81/phpmyadmin

Of course restart apache2 afterwards with /etc/init.d/apache2 restart
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005

Last edited by Hans; 8th March 2008 at 09:09.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Roundcubemail on ISPConfig sets identity settings TheMaximumWeasel Tips/Tricks/Mods 2 28th May 2007 01:09


All times are GMT +2. The time now is 17:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.