#1  
Old 13th June 2007, 13:43
t-mug t-mug is offline
Member
 
Join Date: Jun 2007
Posts: 70
Thanks: 11
Thanked 6 Times in 5 Posts
Default squirrelmail login failing

I've got a fresh ISPconfig installation here; the squirrelmail package from http://ispconfig.org/downloads.htm is installed additionally.
But my web login via the https://domain.tld:81/squirrelmail is always failing: "Unknown user or password incorrect."
The /var/log/mail.log says:
Code:
Jun 13 13:27:02 ... imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 13 13:27:02 ... imapd: LOGIN FAILED, user=web1_test@mydomain.tld, ip=[::ffff:127.0.0.1]
Jun 13 13:27:07 ... imapd: LOGOUT, ip=[::ffff:127.0.0.1], rcvd=63, sent=332
The login would probably work if the "user" value would be "web1_test" only (without "@mydomain.tld"), so like it does via my web client. The point is: I've put in the login username box of squirrelmail only "web1_test" as username - it seems that squirrelmail adds automatically this "@mydomain.tld" stuff. Are there any suggestions, how to solve this?

Thanks a lot
Reply With Quote
Sponsored Links
  #2  
Old 13th June 2007, 15:51
bitonw bitonw is offline
Junior Member
 
Join Date: May 2006
Location: Redhill, UK
Posts: 13
Thanks: 3
Thanked 0 Times in 0 Posts
Default

i have the same set up as your and logon with the users real email address...

so if you got blaname@bladomain.com as email address, you use this to logon.

have fun,
bt
__________________
bit4net.com
biton
Reply With Quote
  #3  
Old 13th June 2007, 16:09
t-mug t-mug is offline
Member
 
Join Date: Jun 2007
Posts: 70
Thanks: 11
Thanked 6 Times in 5 Posts
Default The same

Hi bitonw,

thx 4 your reply; if I try to logon by "web1_test@mydomain.tld" the result is exactly the same. Squirrel checks that there's a "dom.tld" extension and does nothing in this case obviously.

But it seems to me, for authentication I need the exact "web1_test" string as user value, since ISPconfig does not support usernames as email addresses? How come these together?

bye & greetings
Reply With Quote
  #4  
Old 13th June 2007, 16:55
t-mug t-mug is offline
Member
 
Join Date: Jun 2007
Posts: 70
Thanks: 11
Thanked 6 Times in 5 Posts
 
Default Solution

OK, I found it out. ISPconfig maps the email address from the squirrel login form to the username expected by postfix by means of a file called /etc/postfix/virtusertable. Here, I then recognized, there was an error done by myself: I created a web as subdomain, so I had to input web1_test@sub.dom.tld as username in squirrel, and the mapping file did the rest well. If I typed only the username, squirrel has completed this by the "@dom.tld" but for this there was no mapping entry in the virtualusertable und the logon failed.
This had confused me!

So thank you again.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squirrelmail login failed. qingsina Server Operation 1 19th April 2007 04:11
Unable to authenticate to SMTP server ashkev Installation/Configuration 15 6th February 2007 17:46
imap + squirrelmail can't login djtremors Installation/Configuration 1 11th August 2006 07:41
Squirrelmail - login error Hans Server Operation 5 18th April 2006 22:24
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 12:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.