Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th June 2007, 19:32
dsadm dsadm is offline
Junior Member
 
Join Date: Jan 2007
Posts: 19
Thanks: 1
Thanked 0 Times in 0 Posts
Default Ispconfig is not saving to the proper Vhosts_ispconfig.conf file

I have noticed when I update server/site info in the Ispconfig web interface the settings are not saved back to the proper Vhosts_ispconfig.conf in /etc/apache2/vhosts but instead they are saved to a new file Vhosts_ispconfig.conf_07-06-07_00-02-45 and I all new configurations are NOT used and appache2 does not see the new changes because of the new file creation.

Is there a way to change this? It used to work properly but of late it has not. I have updated Ispconfig to the 2.2.13 version and the issue still remains.

Thanks for any help.

-Adam
Reply With Quote
Sponsored Links
  #2  
Old 8th June 2007, 08:49
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,396
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

Please try the procedure that is described in this thread to find the problem:

http://www.howtoforge.com/forums/showthread.php?t=7719
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th June 2007, 20:19
dsadm dsadm is offline
Junior Member
 
Join Date: Jan 2007
Posts: 19
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks Till I did follow the sujustions you posted with:

Quote:
1) Make a backup of /etc/apache2/vhosts/Vhosts_ispconfig.conf
2) Rename the latest file /etc/apache2/vhosts/Vhosts_ispconfig.conf_.... that has a date appended to /etc/apache2/vhosts/Vhosts_ispconfig.conf
3) run

httpd -t
This is my result of httpd -t

# httpd -t
Syntax error on line 125 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'suPHP_UserGroup', perhaps mis-spelled or defined by a module not included in the server configuration


my /home/admispconfig/ispconfig/lib/config.inc.php shows this:


$go_info["server"]["sudo_du_enabled"] = 0; // enable sudo for gathering website file usage
$go_info["server"]["apache2_php"] = 'suphp'; // 'filter' = set PHP filters, 'addtype' = Set PHP addtype or 'both' = Set Filter + Addtype, suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


and my log shows this:

Quote:
08.06.2007 - 10:58:40 => INFO - HTTPD_SYNTAX_CHECK: suexec
08.06.2007 - 10:58:40 => INFO - HTTPD_SYNTAX_CHECK: suexec
08.06.2007 - 10:58:40 => INFO - HTTPD_SYNTAX_CHECK: suexec
08.06.2007 - 10:58:40 => INFO - HTTPD_SYNTAX_CHECK: suexec
08.06.2007 - 10:58:40 => INFO - HTTPD_SYNTAX_CHECK: suexec
08.06.2007 - 10:58:40 => INFO - HTTPD_SYNTAX_CHECK: suexec
08.06.2007 - 10:58:40 => INFO - HTTPD_SYNTAX_CHECK: suexec
08.06.2007 - 10:58:40 => INFO - HTTPD_SYNTAX_CHECK: suexec
08.06.2007 - 10:58:40 => INFO - HTTPD_SYNTAX_CHECK: suexec
08.06.2007 - 10:58:40 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2418: WARNING: could not httpd
-t &> /dev/null
08.06.2007 - 10:58:40 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2429: httpd syntax seems to con
tain errors, reloading with old configuration
08.06.2007 - 10:58:40 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2430: mv -f /etc/apache2/vhosts
/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf_08-06-07_10-58-40
08.06.2007 - 10:58:40 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2431: mv -f /etc/apache2/vhosts
/Vhosts_ispconfig.conf~ /etc/apache2/vhosts/Vhosts_ispconfig.conf
08.06.2007 - 10:58:41 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING:
could not /etc/init.d/apache2 reload &> /dev/null
08.06.2007 - 10:58:41 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1892: cp -fr /etc/proftpd_ispco
nfig.conf /etc/proftpd_ispconfig.conf~
08.06.2007 - 11:04:54 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING:
could not /etc/init.d/apache2 restart &> /dev/null
08.06.2007 - 11:04:55 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/ini
t.d/postfix stop &> /dev/null
08.06.2007 - 11:04:58 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/ini
t.d/bind9 restart &> /dev/null
08.06.2007 - 11:05:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/ini
t.d/proftpd restart &> /dev/null
08.06.2007 - 11:07:04 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING:
could not /etc/init.d/apache2 restart &> /dev/null
08.06.2007 - 11:07:05 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/ini
t.d/postfix stop &> /dev/null
08.06.2007 - 11:07:08 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/ini
t.d/bind9 restart &> /dev/null
08.06.2007 - 11:07:10 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/ini
t.d/proftpd restart &> /dev/null
08.06.2007 - 11:14:52 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING:
could not /etc/init.d/apache2 restart &> /dev/null
08.06.2007 - 11:14:53 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/ini
t.d/postfix stop &> /dev/null
08.06.2007 - 11:14:56 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/ini
t.d/bind9 restart &> /dev/null
08.06.2007 - 11:14:59 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/ini
t.d/proftpd restart &> /dev/null
Thank you Till for your help. I have read the other forums but still have issues with the suPHP_UserGroup.

- Adam
Reply With Quote
  #4  
Old 8th June 2007, 20:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,396
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

The error means that you enabled suphp in ISPConfig but missed to install or load mod_suphp in your apache webserver.

Either you switch of suphp in ISPConfig or install mod_suphp in your apache server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 8th June 2007, 22:59
dsadm dsadm is offline
Junior Member
 
Join Date: Jan 2007
Posts: 19
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Till,

I am using apache2 and in my mods-endabled directory I have the link:

lrwxrwxrwx 1 root root 39 2006-12-08 00:22 suexec.load -> /etc/apache2/mods-available/suexec.load
lrwxrwxrwx 1 root root 38 2007-04-05 18:01 suphp.load -> /etc/apache2/mods-available/suphp.load

I am using Ubuntu edgy on PPC and I can not find a mod_suphp but I do have suphp that is loaded when I start apache2.

I have also tried creating an empty Vhosts_ispconfig.conf file and apache starts up just fine. What are causing the issues when I have Ispconfig running is the line: suPHP_UserGroup nobody web2.

suPHP_Engine on
suPHP_UserGroup nobody web2
AddHandler x-httpd-php .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-php



I don't know what creates the line in the IspConfig control panel but from all the research I have found out that the modle is there. I am a bit perplexed.

-Adam
Reply With Quote
  #6  
Old 9th June 2007, 10:58
dsadm dsadm is offline
Junior Member
 
Join Date: Jan 2007
Posts: 19
Thanks: 1
Thanked 0 Times in 0 Posts
Default

OK,

After spending an entire day and very late tonight working on this issue I have done the following:

I have been reconfiguring php5 apache2 suphp and things only got worse not better so I removed all forms of php from the system and then just loaded the apps back that used php and apt-get installed all the proper php dependencies.

Sadly I am still left at the begining with this error when I restart apache:

# /etc/init.d/apache2 start
* Starting apache 2.0 web server... Syntax error on line 125 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'suPHP_UserGroup', perhaps mis-spelled or defined by a module not included in the server configuration
[fail]

The mod_suphp is installed but as far as I can remember this started to happen when I upgraded ispconfig.

I have removed the contents of Vhosts_ispconfig.conf with the file = 0k and restarted apache2 and it worked just fine. I am really, really at a loss with this error and it has been pulling me away from my other work. Sadly. Any help and I mean any help regarding this issue will be so welcomed at this point.

-Adam
Reply With Quote
  #7  
Old 9th June 2007, 11:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Do you use
Code:
$go_info["server"]["apache2_php"] = 'suphp';
in /home/admispconfig/ispconfig/lib/config.inc.php?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 9th June 2007, 20:41
dsadm dsadm is offline
Junior Member
 
Join Date: Jan 2007
Posts: 19
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Yes.. I had it set to $go_info["server"]["apache2_php"] = 'suphp'; from the very begging but it still did not make a difference.

Thank you very much for the sujustion.

-Adam
Reply With Quote
  #9  
Old 10th June 2007, 14:31
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,396
Thanks: 833
Thanked 5,492 Times in 4,323 Posts
Default

Which ISPConfig version do you use? Have you modified anything within the ISPConfig sources or added additional users to the groups created by ISPConfig manually?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 12th June 2007, 01:52
dsadm dsadm is offline
Junior Member
 
Join Date: Jan 2007
Posts: 19
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Till,

OK. I have removed the whole apache2 server and all files and purged all php files from the system. I reinstalled ispconfig and still have my control panel. I am not getting any errors as I did after some grueling work. However after reinstalling some software needed for the web system I am again getting some odd behavior in the vhost directory related to the naming of the backup Vhosts... file.

My Stats for the system are:
Platform: PPC 7400 (mac)
OS: Ubuntu feisty (upgraded)
IspConfig version: 2.2.13
apache2: 2.2.3-3.2b

httpd -t gave me system OK

Right after the reinstall of apache, egroupware, and proper php files the Vhosts_ispconfig.conf file was updated upon every proper change in the control panel and the proper Vhosts_ispconfig.conf~ was also created without any the previous errors.

At this point I did not include suphp.conf or suphp.load in the mods-enabled dir so suphp was not running on the server.

However bring in some of the previous files used on the server made ispconfig now to instead of creating the Vhosts_ispconfig.conf~ file it now creats the file with the date and time. This would be OK but with every change in the crontrol panel saves the backup with new date and time and it does not delete the old Vhosts backup file thus filling up the directory full of backup files.

I now created the suphp links in mods-enabled and I did not receive any http errors but still noticed the backup vhosts issue continues.

I have since purged the newly installed files from the time when the backups were saving with date and time and sadly it continues to save the Vhosts file without the '~'. I have also backed out the suphp modules out of apache2 and the vhosts issue still continues.

Now I am really at a lost as to what is going on.

-Adam
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
Error on install igbe Installation/Configuration 7 28th February 2007 22:55
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
PHP error chrno Installation/Configuration 2 7th September 2006 13:27
Problems with Apache and Updating Jubalint Installation/Configuration 2 21st May 2006 19:50


All times are GMT +2. The time now is 10:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.