#1  
Old 12th June 2007, 06:59
kreya kreya is offline
Member
 
Join Date: May 2007
Posts: 53
Thanks: 6
Thanked 1 Time in 1 Post
Red face MX is host name, not IP

Hi,
when i ran domain test in dnsstuff it said.
Error
MX is Host Name, not IP
ERROR: You have one or more MX record(s) that contain an IP address. This is not valid. A fully RFC-compliant mailserver will not be able to send you mail (although some mail servers will, due to the TCP/IP functions that they use). The problem MX records are:
12.34.56.78

initially i had mx record pointing to my IP but i changed that yesterday.

my configuration at the domain registrar's end
A record
www.mydomain.com
12.34.56.78

A record
server1.mydomain.com
12.34.56.789

CNAME
pop3.mydomain.com
www.mydomain.com


CNAME
smtp.mydomain.com
www.mydomain.com

MX record
server1.mydomain.com

configurations in ISPconfig-managemnt-server settings
hostname : www
domain : mydomain.com

DNS servers : my ISP DNS servers
(prefer to use ISP DNS and not ISPconfig DNS servers)

port forwarding enabled for all DNS,SMTP,POP3...

then i created www.mydomain.com site in isp manager-new site
hostname : www
domain : mydomain.com

do i have to enable DNS & MX record options in that
How do i fix the MX issue
Reply With Quote
Sponsored Links
  #2  
Old 12th June 2007, 08:15
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,072
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
 
Default

It may take up to 48- 72 hours until your change in DNS is recognized by all DNS cacching servers, sou you might have to wait a bit longer.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMTP relay trouble DVS General 3 11th June 2007 09:56
This is %#@*&^$# embarrassing! domino Smalltalk 34 5th February 2007 21:57
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
I broke it.. I think.. Email in is not being delivered? edge Server Operation 1 3rd July 2006 14:22
ISPConfig/Postfix - unable to send mail via Outlook Commdude Installation/Configuration 8 21st March 2006 01:24


All times are GMT +2. The time now is 08:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.