#1  
Old 6th June 2007, 13:53
dimitar dimitar is offline
Member
 
Join Date: Mar 2007
Posts: 64
Thanks: 1
Thanked 0 Times in 0 Posts
Question Local / External Mailserver

Hi All,

I have strange problem on one of my servers running Debian sarge and ispconfig 2.2.12.
The problem is that some of the domains just change the option "Mailserver:" "AUTOMATIC" I mean - that i have setuped every domain to use "Local Mailserver" but after inspecting the situation i find some of the domains set up to "External Mailserver" and after changing it back to "Local Mailserver" the next day the option is again set up to "External Mailserver"

Has anybody some idea whats going on?

another Q: can i somehow setup ALL of the domains to "Local Mailserver" for example from shell or with mysql query... because now i need to go through every domain via the webUI which is very time consuming domains are > 400 ....

Thanks

Last edited by dimitar; 6th June 2007 at 14:53.
Reply With Quote
Sponsored Links
  #2  
Old 8th June 2007, 11:32
torusturtle torusturtle is offline
Senior Member
 
Join Date: Apr 2006
Posts: 296
Thanks: 21
Thanked 24 Times in 16 Posts
Send a message via ICQ to torusturtle Send a message via AIM to torusturtle
Default

Quote:
Originally Posted by dimitar
another Q: can i somehow setup ALL of the domains to "Local Mailserver" for example from shell or with mysql query... because now i need to go through every domain via the webUI which is very time consuming domains are > 400 ....
You could use the mysql query
Code:
set domain_local_mailserver='1' in isp_isp_domain
to change the values and then
Code:
set status='u' in isp_isp_web
to make ISPConfig aware of the change. (only needed for the table isp_isp_domain)

You might have to make a change - doesn't matter what - in the Control Panel to initiate the update.
Reply With Quote
  #3  
Old 8th June 2007, 12:32
dimitar dimitar is offline
Member
 
Join Date: Mar 2007
Posts: 64
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi,

Thanks for the reply.

What do you actually mean with:

Quote:
Originally Posted by torusturtle
You might have to make a change - doesn't matter what - in the Control Panel to initiate the update.
Just change something and click OK ?!

Thanks
Reply With Quote
  #4  
Old 8th June 2007, 16:50
mlz mlz is offline
Senior Member
 
Join Date: Dec 2006
Posts: 189
Thanks: 16
Thanked 9 Times in 9 Posts
Default

Exactly, Even just something minor. This will trigger the scripts that build the config files.
Reply With Quote
  #5  
Old 9th June 2007, 10:21
torusturtle torusturtle is offline
Senior Member
 
Join Date: Apr 2006
Posts: 296
Thanks: 21
Thanked 24 Times in 16 Posts
Send a message via ICQ to torusturtle Send a message via AIM to torusturtle
Default

Quote:
Originally Posted by dimitar
Just change something and click OK ?!
Sounds almost too easy to be true. ;-)
Reply With Quote
  #6  
Old 9th June 2007, 11:50
dimitar dimitar is offline
Member
 
Join Date: Mar 2007
Posts: 64
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by torusturtle
Sounds almost too easy to be true. ;-)
Exactly...
Reply With Quote
  #7  
Old 9th June 2007, 19:55
mlz mlz is offline
Senior Member
 
Join Date: Dec 2006
Posts: 189
Thanks: 16
Thanked 9 Times in 9 Posts
Default

You guys could always put in a feature request to make it more difficult, but they may skip that one....
Reply With Quote
  #8  
Old 10th June 2007, 14:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,405
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
 
Default

Quote:
Originally Posted by dimitar
Hi All,

I have strange problem on one of my servers running Debian sarge and ispconfig 2.2.12.
The problem is that some of the domains just change the option "Mailserver:" "AUTOMATIC" I mean - that i have setuped every domain to use "Local Mailserver" but after inspecting the situation i find some of the domains set up to "External Mailserver" and after changing it back to "Local Mailserver" the next day the option is again set up to "External Mailserver"

Has anybody some idea whats going on?
Which ISPConfig version do you use? I guess you use the dev versions and do not have proper MX records for your domains. Sine ISPConfig 2.3.2, ISPConfig checks for manipulations in the mailserevr, e.g. poeple trying to catch mails for google.com on your server and disables the mail receiving for these accounts.

Please setup proper MX records for your domains that point to your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to use an external mailserver within ISPConfig? Hans General 8 3rd September 2009 19:37
Not able to send mail from local mx to external mx mccyberix Installation/Configuration 2 27th February 2007 13:37
External Mailserver smartcall Installation/Configuration 5 26th January 2007 17:01
Problem setting external mailserver erk Installation/Configuration 4 18th May 2006 10:56
Postfix and external Mailserver vpns2000 Installation/Configuration 2 7th April 2006 22:00


All times are GMT +2. The time now is 00:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.