Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th November 2005, 17:39
phamels phamels is offline
Member
 
Join Date: Aug 2005
Location: Belgium
Posts: 58
Thanks: 2
Thanked 2 Times in 2 Posts
Default 2 Questions (1 SSL Related and 1 dns forward related)

Hello,

I've been using ISPConfig since 2.08 and it's been working great ever since

I have 2 questions tough, one is about setting up SSL.
Everything is working perfect. I'm creating a new domain: domain.tld
This domain is bound to an unused and freshly added ip. This ip will be used entirely for this domain since it's going to use SSL.
When I activate SSL from the webinterface and create the certificate, I see a certificate coming up in de web_userxx/ssl dir.
When i try to connect to https://www.domain.tld using lynx, i get the following errors:
SSL error:self signed certificate-Continue? (y)
i continue...
SSL error:host(www.domain.tld)!=cert(localhost.localdo main)-Continue? (y)
i continue...

Then I see the page located in /var/www/index.html

This isn't very right, right ?
It seems there's a problem with creating the Certficate or something, don't really know much about SSL except I have to set it up lol


Next issue, can i forward a domain so i have domain1.tld and domain2.tld acting as 1 domain, for example: www.domain2.tld should point to www.domain1.tld, blah.domain2.tld should also point to blah.domain1.tld...
Is this possible ? also with SSL activated ?

Thanks in advance !

PS: I'm using Fedora Core 4 and ISPConfig 2.1.1
Reply With Quote
Sponsored Links
  #2  
Old 18th November 2005, 18:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by phamels
Hello,

I've been using ISPConfig since 2.08 and it's been working great ever since

I have 2 questions tough, one is about setting up SSL.
Everything is working perfect. I'm creating a new domain: domain.tld
This domain is bound to an unused and freshly added ip. This ip will be used entirely for this domain since it's going to use SSL.
When I activate SSL from the webinterface and create the certificate, I see a certificate coming up in de web_userxx/ssl dir.
When i try to connect to https://www.domain.tld using lynx, i get the following errors:
SSL error:self signed certificate-Continue? (y)
i continue...
SSL error:host(www.domain.tld)!=cert(localhost.localdo main)-Continue? (y)
i continue...

Then I see the page located in /var/www/index.html

This isn't very right, right ?
It seems there's a problem with creating the Certficate or something, don't really know much about SSL except I have to set it up lol
Does www.domain.tld point to the correct IP address? Can you see an SSL vhost for www.domain.tld in your Vhosts_ispconfig.conf?


Quote:
Originally Posted by phamels
Next issue, can i forward a domain so i have domain1.tld and domain2.tld acting as 1 domain, for example: www.domain2.tld should point to www.domain1.tld, blah.domain2.tld should also point to blah.domain1.tld...
Is this possible ?
Yes, you can create the new domains as Co-Domains in the existing web. You can also work with the Forward feature of Co-Domains.
But please make sure the DNS records for the new domains are correct.

Quote:
Originally Posted by phamels
also with SSL activated ?
Only if you have a wildcard SSL certificate. Normally an SSL certificate is for one FQDN only, any other combination will issue an error.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th November 2005, 23:51
phamels phamels is offline
Member
 
Join Date: Aug 2005
Location: Belgium
Posts: 58
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by falko
Does www.domain.tld point to the correct IP address? Can you see an SSL vhost for www.domain.tld in your Vhosts_ispconfig.conf?
No, it doesn't seem to create an SSL entry, there's an entry for regular http but none for SSL.
Should I create on manually ?
If so, will there be any problems regarding updates?


Quote:
Originally Posted by falko
Yes, you can create the new domains as Co-Domains in the existing web. You can also work with the Forward feature of Co-Domains.
But please make sure the DNS records for the new domains are correct.

Only if you have a wildcard SSL certificate. Normally an SSL certificate is for one FQDN only, any other combination will issue an error.
Thanx !
Reply With Quote
  #4  
Old 19th November 2005, 03:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by phamels
No, it doesn't seem to create an SSL entry, there's an entry for regular http but none for SSL.
Should I create on manually ?
No!
Are there warnings/errors in /home/admispconfig/ispconfig/ispconfig.log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 19th November 2005, 17:24
phamels phamels is offline
Member
 
Join Date: Aug 2005
Location: Belgium
Posts: 58
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by falko
No!
Are there warnings/errors in /home/admispconfig/ispconfig/ispconfig.log?
ok

The following comes up in ispconfig.log when i enable SSL:

Code:
19.11.2005 - 17:19:52 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 270: Connected successfully
19.11.2005 - 17:19:52 => INFO - USER:webxx_user:x:100xx:100xx:Firstname Lastname:/home/www/webxx:/bin/false
19.11.2005 - 17:19:30 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 851: setquota -u webxx_user 0 0 0 0 -a &> /dev/null
19.11.2005 - 17:19:30 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 57: cp -f /root/ispconfig/isp/conf/forward.master /home/www/webxx/.forward
19.11.2005 - 17:19:30 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 136: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
19.11.2005 - 17:19:30 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 283: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
19.11.2005 - 17:19:30 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 288: postmap hash:/etc/postfix/virtusertable
19.11.2005 - 17:19:30 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1191: cp -fr /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf~
19.11.2005 - 17:19:31 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1825: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
19.11.2005 - 17:19:42 => INFO - Signalfile Set: insert
Doesn't seem like there's any warnings coming up...
It's like it's completly ignoring the SSL checkbox.
No entries seem to come up in the vhost config...
Reply With Quote
  #6  
Old 19th November 2005, 18:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Restart ISPConfig:
Code:
/etc/init.d/ispconfig_server restart
and try again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 19th November 2005, 19:07
phamels phamels is offline
Member
 
Join Date: Aug 2005
Location: Belgium
Posts: 58
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Code:
.oO(root@hosting ~)Oo. /etc/init.d/ispconfig_server restart
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd stopped
ISPConfig system stopped!
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
Then i went to the control panel, disabled SSL, enabled SSL again...
deleted the old certificate, recreated a new one.
Tried lynx again, seems to work now.

Code:
SSL error:self signed certificate-Continue? (y)
The self signed error is probably cause it's not an "official certificate".
How do I make it "official" and will it cost me ?

Thanx allot falko !
Keep up the great work, enjoy using your system with such great support !
Reply With Quote
  #8  
Old 19th November 2005, 19:32
phamels phamels is offline
Member
 
Join Date: Aug 2005
Location: Belgium
Posts: 58
Thanks: 2
Thanked 2 Times in 2 Posts
Default DNS Greeting me with all sorts of domains :)

Oh, on the way, i also found a different problem regarding dns.
My dns server seems to greet me with al sorts of domains when I do a query.
Any hints for this ?

Thanks !
Reply With Quote
  #9  
Old 20th November 2005, 02:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by phamels
The self signed error is probably cause it's not an "official certificate".
How do I make it "official" and will it cost me ?
It will cost you! You can buy a certificate from www.instantssl.com, for example. You give them the content of the "SSL Request" field on the SSL tab in ISPConfig, then they give you back an "official" certificate which you paste into the "SSL Certificate" field (replacing the certificate that's already in there). As Action choose "Save certificate".

Quote:
Oh, on the way, i also found a different problem regarding dns.
My dns server seems to greet me with al sorts of domains when I do a query.
Any hints for this ?
What exactly did you do, and what was the result?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 20th November 2005, 14:29
phamels phamels is offline
Member
 
Join Date: Aug 2005
Location: Belgium
Posts: 58
Thanks: 2
Thanked 2 Times in 2 Posts
 
Default

just performing an 'nslookup'.
It just keeps greeting me with different domains that are hosted on that server... :-)

Had the same thing going on with the mail server so i adjusted the conf that it only greets me with one pre-set hostname such as hostingserver.domain.tld
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie questions SidSkiba Installation/Configuration 2 29th August 2005 20:51


All times are GMT +2. The time now is 00:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.