Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd June 2007, 00:34
burlyhousetech burlyhousetech is offline
Junior Member
 
Join Date: Jun 2007
Location: Austin, TX
Posts: 26
Thanks: 6
Thanked 1 Time in 1 Post
Default log message- 'warning: could not open file'

hi folks -

i have ispconfig installed, and have been attempting to customize the DNS configuration on the server.

unfortunately it seems that somewhere in my process i have mucked things up.

when i try to update the Mgmt > Server > Settings i see in my log file:

01.06.2007 - 15:50:22 => INFO - Signalfile Set: update
01.06.2007 - 15:52:29 => WARN - WARNING: could not open file
01.06.2007 - 15:52:29 => WARN - WARNING: could not open file
01.06.2007 - 15:52:29 => WARN - WARNING: could not open file

how does one know what is the file path which is being accessed, so i can resolve this issue?

thanks much in advance for any assistance.

peace,
- nathan
Reply With Quote
Sponsored Links
  #2  
Old 2nd June 2007, 12:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
Default

Are there any fields (that should contain a path or filename) in the database table isp_server empty?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th June 2007, 22:53
burlyhousetech burlyhousetech is offline
Junior Member
 
Join Date: Jun 2007
Location: Austin, TX
Posts: 26
Thanks: 6
Thanked 1 Time in 1 Post
Default

Found and fixed a few improper values in isp_server which were related to my Linux distro. This appears to have fixed a portion of the errors.

However, still a few reports of 'count not open file' remain in the log file.

I admit I'm not installing ISPConfig on a new box, and I thought I'd be able to figure this out. DNS is functional. I feel like postfix & apache paths and permissions are correct, but updates to these server configs are not yet functional.

Finding it difficult to isolate the remaining issue. It'd sure be nice if there were DEBUG-level output with the file path output just prior to attempting access...

Continuing the adventure, now. Advice?
Reply With Quote
  #4  
Old 21st June 2007, 12:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
Default

All these values are set by the ISPConfig installer, you can not copy this table from another server to your new server if the new server does not use the same linux distribution and version.

You should uninstall ISPConfig and then completely reinstall it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 22nd June 2007, 00:51
burlyhousetech burlyhousetech is offline
Junior Member
 
Join Date: Jun 2007
Location: Austin, TX
Posts: 26
Thanks: 6
Thanked 1 Time in 1 Post
Default

I did not copy the values from another server. They were not set correctly by the config script for some reason. Building a fresh server today.

Thanks.
Reply With Quote
  #6  
Old 22nd June 2007, 12:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
Default

Please make sure that you do not install the ISPConfig mysql dump manually. The database must be created by the ispconfig setup script itself and the database dump is inserted automatically with the correct values for your linux distribution.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 22nd June 2007, 20:23
burlyhousetech burlyhousetech is offline
Junior Member
 
Join Date: Jun 2007
Location: Austin, TX
Posts: 26
Thanks: 6
Thanked 1 Time in 1 Post
Default

I should explain further: While running the setup script I exited (control-C) the process. When I later re-ran the setup script it appears to have confused some of the entries. I referenced dist.txt in the ISPConfig-2.2.13 archive (and correlated within the setup script source) to set the proper values for my distribution.

What I feel is goofing this install is related to permissions or a broken symlink, etc. I backed up key config files before installing ISPConfig onto a server which is already in use, and having been working to integrate the prior server environ with ISPConfig.

Oh well, it was worth a shot. Thanks again for your assistance. I'm going to give it one more go, and then install on a new box. (;
Reply With Quote
  #8  
Old 23rd June 2007, 22:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Quote:
Originally Posted by burlyhousetech
I should explain further: While running the setup script I exited (control-C) the process.
Maybe you should've used screen: http://www.howtoforge.com/linux_screen
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE Enterprise, PHP binary coming with ISPConfig does not work properly NexusTechUS Installation/Configuration 1 26th April 2007 21:03
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 04:40
No ftp login for ispconfig-webuser agri Installation/Configuration 12 19th March 2007 11:06
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 18:17
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 06:19


All times are GMT +2. The time now is 10:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.