#1  
Old 20th May 2007, 04:00
djriknet djriknet is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Default mail bounce & no webmail access

Dear all,


First of all, thank you all for the great product ISPCONFIG and the great step by step guide...

We had to install a linux webhosting server for our Bachelor Information Technology and System (BITS) and this helped us a lot.

Our server is now up and running and within a week i will have a public static ip address on it.
For now i was just testing locally, and got 2 problems:


Problem number one:
when i send an e-mail with outlook to myself, outgoing and incomming the fedora core 6 server with ispconfig.

the e-mail is not coming into the mailbox, but when i send it to an e-mail address outside the server. it goes wel.

In the log (/var/logs/maillog) i found this error:

status=bounced (mail for heriso.com loops back to myself)

I think now later on that it could be a error in the 'hosts' file, where the loopback is not good defined, but i'm now not able to contact the server, will check it monday. do anybody else know what this could be if it's not the hosts file?


Question No. 2

When i access my server (this case my test server running on vmware)
(http://190.2.167.204:81) everything goes fine,
i'm using a linksys router, with port forwarding, and when i try to connect to my webmail (http://190.2.167.204:81/webmail) it goes well insite the network but outside not.

so when i connect with my pc insite this same network, great all works.
wen i connect with a pc outsite on the internet the control pannel is coming up file (http://190.2.167.204:81 , you can try it, admin / admin, please do not mess up.....)
but when i try to connect to the webmail, http://190.2.167.204:81/webmail it doesn't work, even the phpmyadmin not.....


is this a security setting? and where can i find that?


Kind regards,


Hendrik Kroon

Last edited by djriknet; 20th May 2007 at 04:04.
Reply With Quote
Sponsored Links
  #2  
Old 21st May 2007, 12:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by djriknet
Problem number one:
when i send an e-mail with outlook to myself, outgoing and incomming the fedora core 6 server with ispconfig.

the e-mail is not coming into the mailbox, but when i send it to an e-mail address outside the server. it goes wel.

In the log (/var/logs/maillog) i found this error:

status=bounced (mail for heriso.com loops back to myself)
Please add heriso.com at the end of /etc/postfix/local-host-names and restart Postfix.

Quote:
Originally Posted by djriknet

Question No. 2

When i access my server (this case my test server running on vmware)
(http://190.2.167.204:81) everything goes fine,
i'm using a linksys router, with port forwarding, and when i try to connect to my webmail (http://190.2.167.204:81/webmail) it goes well insite the network but outside not.

so when i connect with my pc insite this same network, great all works.
wen i connect with a pc outsite on the internet the control pannel is coming up file (http://190.2.167.204:81 , you can try it, admin / admin, please do not mess up.....)
but when i try to connect to the webmail, http://190.2.167.204:81/webmail it doesn't work, even the phpmyadmin not.....


is this a security setting? and where can i find that?
Please try http://190.2.167.204:81/webmail/.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
djriknet (21st May 2007)
  #3  
Old 26th May 2007, 17:40
djriknet djriknet is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Default local domains.

Dear falco,


I tested your reply's the first one worked fine but the one of the bounce mail is already filled good i think.


the file looks like this:

###################################
#
# ISPConfig local-host-names Configuration File
# Version 1.0
#
###################################
localhost
heriso.heriso.com
localhost.heriso.heriso.com
localhost.heriso.com
localhost.localdomain
www.niettestoppen.com
www.heriso.com
www.test.com
www.noteblock.net
niettestoppen.com
heriso.com
curacaophotos.com
noteblock.net
test.com
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####



what should i change?


Kind regards.
Reply With Quote
  #4  
Old 26th May 2007, 20:47
djriknet djriknet is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default Problem solved.

Dear everybody.

this problem is solved by now.
Finaly we setup a other machine, and checked the difference.

we saw a difference in the /etc/postfix/main.cf

the line with the /etc/postfix/local-host-names file was not there.


we replaced that line and it worked fine.

I think i have to do a little explanation how this has happened.
first we followed all the instructions to install a LAMP installation with Fedora Core 6.
after that we installed ISP Config and had some problems with the DNS.

We solved it by fixing a error in dependancy's what effected the postfix also.

we "yum remove" the postfix and installed it again.

That time the main.cf was cleared, we did all the config as described in the installation instructions. and came to the situation as hereabove.


Thanks for all the support


Hendrik Kroon
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 09:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.