Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th May 2007, 04:01
ISPConfigFan ISPConfigFan is offline
Junior Member
 
Join Date: May 2007
Posts: 6
Thanks: 1
Thanked 1 Time in 1 Post
Default KeepAliveTimeout - no effect through ISPConfig

Once again, good evening...

While finetuning Keepalive settings i noticed something strange; don't know if it's a bug or something i just don't realize, but here's the deal:

Keepalive is set to off in the /etc/httpd/conf/httpd.conf
Keepalivetimeout was set to 100 in same file - but has no effect you would say

Keepalive is set to On in vhost through ISPConfig (static content website, very small icons etc)
Keepalivetimeout is set to 5 in same vhost directives

But still 'server-status' showed a lot of K's, remaining in same slots. With nearly 1000 users online at same time this filled up the max-clients within notime.

Now when i changed the Keepalivetimeout in the main apache httpd.conf to 5, suddenly slots are free within 5 seconds as they supposed to be.

It seems like the ISPConfig vhost apache directive Keepalivetimeout has no effect, but the main httpd.conf does...

Running ISPConfig 2.2.11
Reply With Quote
Sponsored Links
  #2  
Old 25th May 2007, 14:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,007
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

I have no idea, it should work in the vhosts too according to the apache documentation, there is nothing special in ISPConfig compared to a non ISPConfig apache vhost configuartion.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th May 2007, 14:40
ISPConfigFan ISPConfigFan is offline
Junior Member
 
Join Date: May 2007
Posts: 6
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

Yes that's what i read too and therefore it took some time to find out what caused the problem.

Just wanted to let you know though.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig after installation cannot reach www.xyz.de:81 Figth4Linux Installation/Configuration 23 6th March 2008 23:38
ISPConfig 2.3.2-dev released till General 9 4th June 2007 11:46
fastcgi and php with ispconfig tosser Tips/Tricks/Mods 3 25th June 2006 22:01
ISPConfig 2.3.1-dev released till General 0 8th May 2006 23:18
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 16:16


All times are GMT +2. The time now is 12:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.