Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 22nd May 2007, 10:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

This looks to me as some enviroment variables are not set correctly on your server or in mandriva in general. But I'am not so familar with mandrive, maybe Falko can shed some light on this.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #22  
Old 22nd May 2007, 12:59
joostvdl joostvdl is offline
Member
 
Join Date: Oct 2005
Posts: 34
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi there

I have another problem.... a much bigger problem. After the update to 2.2.13 all mail to accounts with the spam filter activated and the policy to not accept spam, was deleted. As if the spamfilter was tagging all mail as spam.

A lot of mail is send to bit-heaven....

After restarting the server the problem seemed to be solved and mail is accepted again.

The problem with the folders not available is now also fixed.
Reply With Quote
  #23  
Old 22nd May 2007, 13:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Quote:
Originally Posted by joostvdl
Hi there

I have another problem.... a much bigger problem. After the update to 2.2.13 all mail to accounts with the spam filter activated and the policy to not accept spam, was deleted. As if the spamfilter was tagging all mail as spam.

A lot of mail is send to bit-heaven....

After restarting the server the problem seemed to be solved and mail is accepted again.

The problem with the folders not available is now also fixed.
I guess than you had a general problem on your server, maybe one of your partitions was full. The ISPConfig update script does not change a accounts, so spam scanning settings are not altered at all. I've done sevarl updates with ISPConfig 2.2.13 since yesterday on different servers and can not confirm any of your problems.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #24  
Old 28th May 2007, 11:16
infamous infamous is offline
Junior Member
 
Join Date: Nov 2006
Posts: 9
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hi.

I've just updated from ISPConfig 2.2.12 to 2.2.13 sucefully.

I've created an account and I've selected SpamFilter with policy to accept.

I've send some mails to this account and, when I try to watch the mails, I can't.

Checking the mail log, I see that:

May 28 10:54:05 reser ipop3d[3156]: Can't open INBOX (file /var/mail/web24_prueba): not in valid mailbox format
May 28 10:54:05 reser ipop3d[3156]: Error opening or locking INBOX user=web24_prueba host=[192.168.1.66]

If I open /var/mail/web24_prueba with a text editor, it contains this:

Received: from localhost by reser.mpginfo.com
with SpamAssassin (version 3.2.0);
Mon, 28 May 2007 10:54:02 +0200
Subject: ***SPAM***
X-Spam-Flag: YES
X-Spam-Checker-Version: SpamAssassin 3.2.0 (2007-05-01) on reser.mpginfo.com
X-Spam-Level: ******
X-Spam-Status: Yes, score=6.4 required=5.0 tests=EMPTY_MESSAGE,MISSING_DATE,
MISSING_HEADERS,MISSING_MID,MISSING_SUBJECT,NO_HEA DERS_MESSAGE,NO_RECEIVED,
NO_RELAYS,TVD_SPACE_RATIO autolearn=no version=3.2.0
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="----------=_465A98AA.330BF5E7"

This is a multi-part message in MIME format.

------------=_465A98AA.330BF5E7
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: 8bit

Spam detection software, running on the system "reser.mpginfo.com", has
identified this incoming email as possible spam. The original message
has been attached to this so you can view it (if it isn't spam) or label
similar future email. If you have any questions, see
postmaster@reser.mgpinfo.com for details.

Content preview: [...]

Content analysis details: (6.4 points, 5.0 required)

pts rule name description
---- ---------------------- --------------------------------------------------
0.0 MISSING_MID Missing Message-Id: header
0.0 MISSING_DATE Missing Date: header
-0.0 NO_RELAYS Informational: message was not relayed via SMTP
1.6 MISSING_HEADERS Missing To: header
2.9 TVD_SPACE_RATIO BODY: TVD_SPACE_RATIO
1.3 MISSING_SUBJECT Missing Subject: header
0.6 EMPTY_MESSAGE Message appears to have no textual parts and no
Subject: text
-0.0 NO_RECEIVED Informational: message has no Received headers
0.0 NO_HEADERS_MESSAGE Message appears to be missing most RFC-822 headers



------------=_465A98AA.330BF5E7
Content-Type: message/rfc822; x-spam-type=original
Content-Description: original message before SpamAssassin
Content-Disposition: inline
Content-Transfer-Encoding: 8bit



------------=_465A98AA.330BF5E7--

Any help?

Regards.
Reply With Quote
  #25  
Old 28th May 2007, 13:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Please try to add the line:

reposrt_safe 0

to the file /home/admispconfig/ispconfig/tools/spamassassin/etc/mail/spamassassin/local.cf
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #26  
Old 28th May 2007, 16:19
infamous infamous is offline
Junior Member
 
Join Date: Nov 2006
Posts: 9
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I've add the line and, when I send an email, mailbox contains this:

X-Spam-Flag: YES
X-Spam-Checker-Version: SpamAssassin 3.2.0 (2007-05-01) on reser.mpginfo.com
X-Spam-Level: ******
X-Spam-Status: Yes, score=6.4 required=5.0 tests=EMPTY_MESSAGE,MISSING_DATE,
MISSING_HEADERS,MISSING_MID,MISSING_SUBJECT,NO_HEA DERS_MESSAGE,NO_RECEIVED,
NO_RELAYS,TVD_SPACE_RATIO autolearn=no version=3.2.0
X-Spam-Report:
* 0.0 MISSING_MID Missing Message-Id: header
* 0.0 MISSING_DATE Missing Date: header
* -0.0 NO_RELAYS Informational: message was not relayed via SMTP
* 1.6 MISSING_HEADERS Missing To: header
* 2.9 TVD_SPACE_RATIO BODY: TVD_SPACE_RATIO
* 1.3 MISSING_SUBJECT Missing Subject: header
* 0.6 EMPTY_MESSAGE Message appears to have no textual parts and no
* Subject: text
* -0.0 NO_RECEIVED Informational: message has no Received headers
* 0.0 NO_HEADERS_MESSAGE Message appears to be missing most RFC-822
* headers
Subject: ***SPAM***
X-Spam-Prev-Subject: (nonexistent)

Watching the tests of SpamAssassin, I see EMPTY_MESSAGE. I don't know why. Message is not empty.
Reply With Quote
  #27  
Old 5th June 2007, 18:35
minskog minskog is offline
Member
 
Join Date: Mar 2006
Posts: 73
Thanks: 7
Thanked 0 Times in 0 Posts
Default

I have a problem in one server with this version, all mail messages from hosted domains are tagged spam. The real reason for this is that postfix send all mails with senders ip then sorbs and spamhaus mark them.

Example:
Code:
Content analysis details:   (7.7 points, 5.0 required)

 pts rule name              description
---- ---------------------- --------------------------------------------------
 1.8 FH_HOST_ALMOST_IP      The host almost looks like an IP addr.
 4.1 FH_HOST_EQ_DYNAMICIP   Host is dynamicip
 0.0 HTML_MESSAGE           BODY: HTML included in message
 0.0 BAYES_50               BODY: Bayesian spam probability is 40 to 60%
                            [score: 0.5000]
 0.9 RCVD_IN_PBL            RBL: Received via a relay in Spamhaus PBL
                            [83.38.x.x listed in zen.spamhaus.org]
 0.9 RCVD_IN_SORBS_DUL      RBL: SORBS: sent directly from dynamic IP address
                            [83.38.x.x listed in dnsbl.sorbs.net]
 0.1 RDNS_DYNAMIC           Delivered to trusted network by host with
                            dynamic-looking rDNS
 0.0 AWL                    AWL: From: address is in the auto white-list
This happen with all domains in the server.

Before 2.2.13, mails were send ok.
Reply With Quote
  #28  
Old 6th June 2007, 17:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

You're hosting your server at home, on a dynamic IP address, right? Almost alll dynamic IP addresses are blacklisted nowadays, so you should relay your mails through your ISP's server or some other mail server: http://www.howtoforge.com/postfix_re...her_mailserver
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #29  
Old 7th June 2007, 10:08
minskog minskog is offline
Member
 
Join Date: Mar 2006
Posts: 73
Thanks: 7
Thanked 0 Times in 0 Posts
Default

No, the server is in a isp (all our servers). This ip is the senders ip, no servers ip. Before 2.2.13 this not happen.


the postconf -n:
Code:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
home_mailbox = Maildir/
inet_interfaces = all
mailbox_command = 
mailbox_size_limit = 0
message_size_limit = 20480000
mydestination = /etc/postfix/local-host-names
myhostname = mydomain.com
mynetworks = 127.0.0.0/8
myorigin = /etc/mailname
recipient_delimiter = +
relayhost = 
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_sasl_authenticated,        permit_mynetworks,        reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = 
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom

Last edited by minskog; 7th June 2007 at 16:13.
Reply With Quote
  #30  
Old 8th June 2007, 13:53
minskog minskog is offline
Member
 
Join Date: Mar 2006
Posts: 73
Thanks: 7
Thanked 0 Times in 0 Posts
 
Default

I think that problem is ispconfig's spamassasin, because i configure Postfix with this parameters:

Code:
smtpd_recipient_restrictions =
     reject_invalid_hostname,
     reject_unknown_recipient_domain,
    reject_unauth_pipelining,
     permit_mynetworks,
     permit_sasl_authenticated,
     reject_unauth_destination,
     reject_rbl_client multi.uribl.com,
     reject_rbl_client dsn.rfc-ignorant.org,
     reject_rbl_client dul.dnsbl.sorbs.net,
     reject_rbl_client list.dsbl.org,
     reject_rbl_client sbl-xbl.spamhaus.org,
     reject_rbl_client bl.spamcop.net,
     reject_rbl_client dnsbl.sorbs.net,
     reject_rbl_client cbl.abuseat.org,
     reject_rbl_client ix.dnsbl.manitu.net,
     reject_rbl_client combined.rbl.msrbl.net,
     reject_rbl_client rabl.nuclearelephant.com,
     permit
... and the mail is accepted correctly with this rejects. There are both sorbs and spamhaus lists, and the email is accepted without problems. I disabled spamassasin and the emails are acepted, then the problem must be spamassasin. But i dont find where is the problem. I send to other ispconfig server than we own and the emails are accepted correctly. This not happened before upgrade to ispconfig 2.2.13

Thanks in advance, i'm going crazy with this problem.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.3.2-dev released till General 9 4th June 2007 10:46
ISPConfig 2.2.13 Beta available till Developers' Forum 4 19th May 2007 15:14
ISPConfig 2.2.4 released till General 25 18th July 2006 13:04
ISPConfig 2.2.1 released till General 11 28th May 2006 10:39
ISPConfig 2.3.1-dev released till General 0 8th May 2006 22:18


All times are GMT +2. The time now is 12:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.