Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th May 2008, 18:47
bbrendon bbrendon is offline
Junior Member
 
Join Date: Apr 2008
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default ftp login doesn't work when using md5 ?

If I'm using md5 instead of crypt, users can not login using FTP and probably other things. If I manually set their password from the unix prompt, everything works, but setting passwords using the web interface only works when passwords are set to crypt.

Does this have something to do with PAM? I appear to have md5 enabled in PAM.

/etc/pam.d/common-password :
password required pam_unix.so nullok obscure min=4 max=8 md5
Reply With Quote
Sponsored Links
  #2  
Old 31st May 2008, 11:15
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

ISPConfig does not support md5 passwords, it supports only crypt-md5.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 31st May 2008, 18:47
bbrendon bbrendon is offline
Junior Member
 
Join Date: Apr 2008
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I guess thats what I meant. The comment in the config file says to specify md5. I currently have it set to crypt, because when I set it to md5, I have to set the password from the command line so that FTP authenticates successfully.

Should I set it = crypt-md5 instead?

Code:
$go_info["server"]["password_hash"] = 'crypt'; // 'crypt' = crypt; 'md5' = crypt-md5
Reply With Quote
  #4  
Old 31st May 2008, 19:09
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Should I set it = crypt-md5 instead?
No, md5 is the setting for crypt-md5. It seems as if your system does not support it, so you will have to stay with crypt.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 31st May 2008, 19:23
bbrendon bbrendon is offline
Junior Member
 
Join Date: Apr 2008
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Interestingly, it appears that it does. My shadow file:

Code:
a.com_jackiecell:P1EzLHIrBqaI:14019:0:99999:7:::
a.com_jon:$1$NHaLHhuG$3Qex8qBIeNWo3HExNy9D30:14019:0:99999:7:::
a.com_test:wYeM4cC3122L:14019:0:99999:7:::
b.com_support:$1$Webpp2xx$v9E5JRwBWf9nL60CPmWl30:14029:0:99999:7:::
They all work fine. The ones that are crypt were set with ispconfig and the md5 ones were set manually.
Reply With Quote
  #6  
Old 31st May 2008, 19:47
bbrendon bbrendon is offline
Junior Member
 
Join Date: Apr 2008
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

It seems to be working now. I wonder if it has something to do with the characters in the password. Hmmm
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 21:12
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38
ftp problems tgansert Installation/Configuration 20 27th May 2006 19:06
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 14:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.