#1  
Old 1st June 2007, 08:57
Alex1 Alex1 is offline
Junior Member
 
Join Date: May 2007
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default suphp on debian etch error

Forcing reload of web server (apache2)...Syntax error on line 55 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
failed!


it is php_admin_flag safe_mode on/off value

Last edited by Alex1; 1st June 2007 at 09:14.
Reply With Quote
Sponsored Links
  #2  
Old 1st June 2007, 09:58
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default Migration to suPHP on your ISPConfig server

Hi,
If you want to setup suPHP on your ISPConfig server please take exactly the steps (and in the right order) as mentioned within: http://www.howtoforge.com/suphp_debian_etch_ispconfig

Probably you forget to remove the admin entries within your Vhosts_ispconfig.conf.
After removing those admin entries, please retart Apache2 again.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #3  
Old 1st June 2007, 10:05
Alex1 Alex1 is offline
Junior Member
 
Join Date: May 2007
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i do it
but some vhosts are already present on the file so on them there is the entry php_admin_flag safe_mode
so at restart before
Code:
Edit /home/admispconfig/ispconfig/lib/config.inc.php find the line:
i've that error
Reply With Quote
  #4  
Old 1st June 2007, 10:33
Alex1 Alex1 is offline
Junior Member
 
Join Date: May 2007
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok i solved that part ... i manually remove php_admin flag record but when i edit

$go_info["server"]["apache2_php"] = 'suphp';


no modification are done on my Vhost file
Reply With Quote
  #5  
Old 1st June 2007, 16:36
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
 
Default

That's correct.
You can force ISPConfig to make a modification to your vhost-file by changing a setting within one of your sites on within ISPConfig.
For example enable cgi or standard-cgi for a website.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42
Frustrated with ISPConfig install! woozyerdaddee Installation/Configuration 4 19th May 2006 03:38
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Could not make OpenSSL yontengyatso Installation/Configuration 3 3rd November 2005 10:50
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 4th October 2005 23:53


All times are GMT +2. The time now is 09:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.