Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th May 2007, 18:52
octopus octopus is offline
Junior Member
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default php4 and php5 white debian4

hello

In my early post of FC6 white php4 an php5 didn’t work

I have decided to use debian 4 white php4 and followed the perfect how to.
Than I followed the suphp white php4 and php5

And i installed Ispconfig at the end

now i have same problems :-(


I Get in the apache error

[Sun May 06 17:25:38 2007] [notice] Graceful restart requested, doing restart
[Sun May 06 17:25:38 2007] [notice] Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c mod_perl/2.0.2 Perl/v5.8.8 configured -- resuming normal operations
[Sun May 06 17:25:38 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
[Sun May 06 17:25:39 2007] [warn] long lost child came home! (pid 2652)

Than searche (9)Bad file descriptor: apr_socket_accept: (client socket) in the forum

The work around to change this to addhandler? But doest work for me ? and I have debian not suse

$go_info["server"]["apache2_php"] = 'addhandler'; // 'filter' = set PHP filters, 'addtype' = Set PHP addtype or 'both' = Set Filter + Addtype, suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


In the suphp.conf file defind this when *php is called than use php5 and when say *php4 use php4


[handlers]
;Handler for php-scripts
x-httpd-php=php4:/usr/bin/php4-cgi
x-httpd-php=php:/usr/bin/php5-cgi

Help …
Reply With Quote
Sponsored Links
  #2  
Old 7th May 2007, 09:12
octopus octopus is offline
Junior Member
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default Update

Quote:
Originally Posted by octopus
hello

In my early post of FC6 white php4 an php5 didn’t work

I have decided to use debian 4 white php4 and followed the perfect how to.
Than I followed the suphp white php4 and php5

And i installed Ispconfig at the end

now i have same problems :-(


I Get in the apache error

[Sun May 06 17:25:38 2007] [notice] Graceful restart requested, doing restart
[Sun May 06 17:25:38 2007] [notice] Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c mod_perl/2.0.2 Perl/v5.8.8 configured -- resuming normal operations
[Sun May 06 17:25:38 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
[Sun May 06 17:25:39 2007] [warn] long lost child came home! (pid 2652)

Than searche (9)Bad file descriptor: apr_socket_accept: (client socket) in the forum

The work around to change this to addhandler? But doest work for me ? and I have debian not suse

$go_info["server"]["apache2_php"] = 'addhandler'; // 'filter' = set PHP filters, 'addtype' = Set PHP addtype or 'both' = Set Filter + Addtype, suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


In the suphp.conf file defind this when *php is called than use php5 and when say *php4 use php4


[handlers]
;Handler for php-scripts
x-httpd-php=php4:/usr/bin/php4-cgi
x-httpd-php=php:/usr/bin/php5-cgi

Help …
Iam die hard white reinstalls hahaha

Last night i have reinstall the server again.

but white no ispconfig and no suphp only debian 4 white php5 and the php4

http://www.howtoforge.com/apache2_with_php5_and_php4


That works fine ! i can excute both :-) than i install ispconfig and the first look it works but after 1 or 2 excutes i get again error

[Sun May 06 22:59:34 2007] [error] an unknown filter was not added: PHP

and

[Sun May 06 22:57:49 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)


but white out the suphp i get unknown filter the most
Reply With Quote
  #3  
Old 7th May 2007, 09:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

Quote:
[Sun May 06 22:59:34 2007] [error] an unknown filter was not added: PHP
First, this is not an error, you can ignore this. It has nothing to do with the fact if your setup works or not. If you want to remove this warning, change PHP to addtype in the config.inc.php file in ISPConfig.

Quote:
but white out the suphp i get unknown filter the most
As you did not install suphp, you can not use suphp! You will have to put the apache directives that are nescessary to run the cgi version of php in the apache directives field of the website and make sure that the checkboxes for cgi and php are not enabled for this website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 7th May 2007, 09:31
octopus octopus is offline
Junior Member
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
First, this is not an error, you can ignore this. It has nothing to do with the fact if your setup works or not. If you want to remove this warning, change PHP to addtype in the config.inc.php file in ISPConfig.



As you did not install suphp, you can not use suphp! You will have to put the apache directives that are nescessary to run the cgi version of php in the apache directives field of the website and make sure that the checkboxes for cgi and php are not enabled for this website.





i have done that but no succes.

only in the how to i put them in the apache2.conf.

Only strange thing is that the test file for seeing which php version is running .

that the server say that some times the file want to download or canot find the file.

Last edited by octopus; 7th May 2007 at 09:35.
Reply With Quote
  #5  
Old 7th May 2007, 09:49
octopus octopus is offline
Junior Member
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by octopus




i have done that but no succes.

only in the how to i put them in the apache2.conf.

Only strange thing is that the test file for seeing which php version is running .

that the server say that some times the file want to download or canot find the file.
When i put the addtype the error for filter is gone


when i do than like the picture i get this


[Mon May 07 08:39:57 2007] [notice] Graceful restart requested, doing restart
[Mon May 07 08:39:58 2007] [notice] Apache/2.2.3 (Debian) PHP/5.2.1-0.dotdeb.2 with Suhosin-Patch mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Mon May 07 08:39:58 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
[Mon May 07 08:39:59 2007] [warn] long lost child came home! (pid 3744)
Reply With Quote
  #6  
Old 7th May 2007, 22:18
octopus octopus is offline
Junior Member
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default I have reinstall debian again

Oke I have done it again the perfect debian setup version 4.
The only thing what is different that is I installed php4-cgi white php5


Everything is working perfect if I do test in


When I execute in the browser the my IP/info.php (/var/www/info.php its php5)
When I execute in the browser the my IP/info.php4 (/var/www/info.php4 its php4)


The only thing I have not change yet is in /etc/mime.types yet

#application/x-httpd-php phtml pht php
#application/x-httpd-php-source phps
#application/x-httpd-php3 php3
#application/x-httpd-php3-preprocessed php3p#application/x-httpd-php4



And the /etc/apache2/mods-enabled/php5.conf is not changed yet

<IfModule mod_php5.c>
AddType application/x-httpd-php .php .phtml .php3
AddType application/x-httpd-php-source .phps
</IfModule>

Only there is /etc/apache/conf.d/php4.conf must a change this to white the # ?

<IfModule mod_php4.c>
AddType application/x-httpd-php .php .phtml .php3
AddType application/x-httpd-php-source .phps
</IfModule>

And in the /etc/apache2.conf I put this but must this stay soo when I install ispconfig?

AddHandler php-script .php4
Action php-script /cgi-bin/php4


but when i install ispconfig its not working

Last edited by octopus; 7th May 2007 at 22:22.
Reply With Quote
  #7  
Old 8th May 2007, 09:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

1) Comment out the addtype lines in the php5.conf file and the php4.conf file.

2)
Quote:
And in the /etc/apache2.conf I put this but must this stay soo when I install ispconfig?
No, please comment this out.

3a) If you want to enable php5 in a website, enable the php checkbox in ISPConfig for this website.

3b) If you want to enable php4 for the website, make sure that the php checkbox and the cgi checkbox are not enabled. Then add the following lines in the aoache directives field:

AddHandler php-script .php
Action php-script /cgi-bin/php4

Now all files ending with .php are executed by php4 and not php5.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 8th May 2007, 21:20
octopus octopus is offline
Junior Member
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have now same proble again ......


php 5 works fine


only when vink out the

CGI Scripts:
Standard CGIs:
PHP Scripts:

and put by the Apache Directives (Optional): the

AddHandler php-script .php
Action php-script /cgi-bin/php4

it give file not found and error 404
Reply With Quote
  #9  
Old 8th May 2007, 23:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

Please post the exact error message from the http error log of this website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 8th May 2007, 23:20
octopus octopus is offline
Junior Member
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

[Tue May 08 22:14:19 2007] [notice] Graceful restart requested, doing restart
[Tue May 08 22:14:19 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
[Tue May 08 22:14:19 2007] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch3 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
[Tue May 08 22:14:20 2007] [warn] long lost child came home! (pid 9277)

Hello till this is the apache error log
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php4 and php5 at same time findafriend Installation/Configuration 7 22nd June 2007 17:44
PHP5 is on, but PHP4 (as cgi?) is needed... schmidtedv Installation/Configuration 1 12th April 2007 14:44
PHP5 in apache PHP4 at cli. how do get get PHP5 at both ThE-LyNX Installation/Configuration 1 29th August 2006 00:49
suse 10.1 php5 to php4 Boon-Dog-Danny Installation/Configuration 2 6th August 2006 16:09
PHP4 and PHP5 for SUSE 9.3 Prof M.Behrens Installation/Configuration 3 2nd April 2006 23:20


All times are GMT +2. The time now is 06:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.