Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd April 2007, 21:25
R0l@ndSm0ke R0l@ndSm0ke is offline
Member
 
Join Date: Dec 2006
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default UebiMiau and SPF Question

I posted in this section because my first question is regarding UebiMiau on ISPConfig. I am running the Perfect OpenSUSE 10.2 Setup.

When attempting to send email outside my domain from UebiMiau I receive the error:
Quote:
It was not possible to send this e-mail

SMTP Error: Recipient not accepted. Verify your relay rules
I would probably be more freaked out about this, but when I use a mail client (thunderbird, outlook, etc) I have absolutely no problem sending email. Except to Hotmail and Yahoo., which leads into my next question.

I am fairly certain that I'm sending out to Yahoo, but it is using the greylisting method and forcing a delay. Hotmail on the other hand does not seem to be receiving my messages at all. My log reports:
Quote:
postfix/smtp[21062]: 039DB479C6B: to=<drsmoke@hotmail.com>, relay=mx2.hotmail.com[65.54.244.40]:25, delay=2.2, delays=1.1/0.02/0.73/0.35, dsn=2.0.0, status=sent (250 <000001c7755b$7ec9da20$0f640e0a@corp.ene.com> Queued mail for delivery)
But no one ever receives the messages. And my spf records don't seem to functional on any of my domains. You can use www.frankentech.org to check spf on. I also read that I may need to email webmaster at hotmail to get my domains allowed. Is this true? Would it be the same for yahoo?

The record reads:
Quote:
mail.frankentech.org. TXT "v=spf1 a mx ptr include::q ?all"
I appreciate your help with this.
Reply With Quote
Sponsored Links
  #2  
Old 2nd April 2007, 21:54
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

You do not have a SPF record for frankentech.org
(have a look here)
Quote:
I also read that I may need to email webmaster at hotmail to get my domains allowed. Is this true? Would it be the same for yahoo?
Thats a yes for hotmail, and a yes for yahoo.

Here is a small quote from Hotmail that I got some time ago:
Quote:
We have identified that messages from your IP (my-server-ip) are being filtered based on the recommendations of the SmartScreen filter. SmartScreen is the spam filtering technology developed and operated by Microsoft. SmartScreen is built around the technology of machine learning. SmartScreen’s filters are trained to recognize what is spam and what isn’t spam. In short, we filter incoming emails that look like spam. I am not able to go into any specific details about what these filters specifically entail, as this would render them useless.

However, we also base our spam rating on the reputation of the sender. One way to positively impact the reputation of your IP is to obtain SPF/Sender ID records. This technology allows SmartScreen to better track emails from your IP, weeding out spoofed messages. You can find additional information on creating SPF records at http://www.microsoft.com/senderid
So.. Hotmail rates your mail by SmartScreen’s filters AND reputation of the sender

Some more from the Hotmail email:
Quote:
While you have SPF/SennderID records published for your domains (some-of-my-sites), they do not appear to be added to the SenderID program. We have added your domain to the SenderID program.
So.. Hotmail needs to add domains to the SenderID program.

Best is to contact hotmail, and ask if they can add your domain(s).
Before you do this, MAKE SURE, that all is working the way it should! (DNS, MX, SPF and reverse DNS)
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 2nd April 2007, 22:06
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

Quote:
Originally Posted by R0l@ndSm0ke
I posted in this section because my first question is regarding UebiMiau on ISPConfig. I am running the Perfect OpenSUSE 10.2 Setup.

When attempting to send email outside my domain from UebiMiau I receive the error:


I would probably be more freaked out about this, but when I use a mail client (thunderbird, outlook, etc) I have absolutely no problem sending email. Except to Hotmail and Yahoo., which leads into my next question.
Did you enable "My outgoing server (SMTP) requires authentication" in your email client?
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #4  
Old 2nd April 2007, 23:47
R0l@ndSm0ke R0l@ndSm0ke is offline
Member
 
Join Date: Dec 2006
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No problem with email clients. UebiMiau is the only real issue if emailing hotmail and yahoo pans out. I always get the mentioned error message when I try to email from UebiMiau which I installed with ISPConfig.

Now if there is a setting in UebiMiau that sets it to server authentication then I have completely overlooked it.

I have adjusted the spf record some, and finally have it working properly. This did not fix UebiMiau.

Thanks for the help.

Last edited by R0l@ndSm0ke; 2nd April 2007 at 23:55.
Reply With Quote
  #5  
Old 3rd April 2007, 11:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Now if there is a setting in UebiMiau that sets it to server authentication then I have completely overlooked it.
This is not nescessary for uebimiau, as ist sends from the localhost IP which is always allowed to send mail.

Have you entered a correct sender address in the uebimiau options?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 3rd April 2007, 17:49
R0l@ndSm0ke R0l@ndSm0ke is offline
Member
 
Join Date: Dec 2006
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you are referring to the "reply to" field in the "General Information" section of user options then the answer is yes.

Otherwise, I'm not aware of where the setting you refer to would be located.
Reply With Quote
  #7  
Old 4th April 2007, 13:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by R0l@ndSm0ke
If you are referring to the "reply to" field in the "General Information" section of user options then the answer is yes.
Yes, that's correct.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 4th April 2007, 18:40
R0l@ndSm0ke R0l@ndSm0ke is offline
Member
 
Join Date: Dec 2006
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am still unable to use UebiMiau to send email. I can check my email with it, just can't send to any outside domain. I can send to local domains.
Reply With Quote
  #9  
Old 5th April 2007, 13:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Please post an excerpt of ypur mail logfile.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 19th May 2007, 18:48
R0l@ndSm0ke R0l@ndSm0ke is offline
Member
 
Join Date: Dec 2006
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

OK, I've been dealing with so many other things that I couldn't get back to this until now.

So, the attached is an excerpt from the log file showing the exact instance that I logged into web mail and attempted to send a message to an outside location.

I installed Roundcube to be sure it wasn't an issue with UebiMiau and it is not. Roundcube has the exact same problem. They can send messages internally with no problem, but if I try to send outside I get the attached error. I took a look in the mail.info log to see what it had to say and I think I may have learned something about the problem, but still do not know how to fix it.

When you access using a client you are using pop3, but when you access through web mail you are on imapd. I have no problems with sending or receiving from pop3, and just sending with imapd on the web mail. So this issue appears to be specific to imapd.
mail.txt
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Spf maxx General 7 4th April 2007 17:16


All times are GMT +2. The time now is 04:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.