Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th May 2007, 11:01
Pasco Pasco is offline
Member
 
Join Date: Aug 2005
Location: Switzerland
Posts: 94
Thanks: 11
Thanked 0 Times in 0 Posts
Default Apache2: German umlauts in URL?

Little daft question:

I recently recognized that apache2 (ISPConfig Webserver on port 80 with debian etch 4.0) doesn't handle german umlauts in filenames. Is this normal or is it misconfigured? I can't remember.

For example: http://www.mydomain.tld/rcktritt.doc

doesn't work because apache2 doesn't understand umlauts or mistranslate them as I can see in the apache error.log.

For domain names I knew it's possible with a umlauts-capable browser, but as far as I can remember, apache handled umlauts correct in the URL earlier..
Reply With Quote
Sponsored Links
  #2  
Old 15th May 2007, 11:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
 
Default

Umlauts in URL's must be URL-encoded to work properly. This is normally done by the webbrowser. Even umlauts in domains are not used directly and passed to apache, the webbrowser must encode the domain name as IDN. The domain name system and apache are not able to handle umlauts directly.

Please have a look here for more information on conversions of domain names to PUNYCODE strings:

http://www.denic.de/de/domains/idns/tool.jsp

e.g. the domain "mller.de" is send as "xn--mller-kva.com".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSI with Apache2 on Debian jchaven Server Operation 7 25th August 2008 17:06
So my ISPConfig went German on me, should I be worried? FeraTechInc General 3 14th March 2007 08:29
Apache2 without APXS ctroyp Installation/Configuration 8 29th January 2007 03:05
PHP on Apache2 no longer works after ISPconfig azorman Installation/Configuration 6 23rd July 2006 22:06
Big problem with apache2 on Ubuntu piratta Installation/Configuration 2 18th January 2006 17:29


All times are GMT +2. The time now is 02:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.