Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th May 2007, 22:35
Pulkvedis Pulkvedis is offline
Junior Member
 
Join Date: May 2007
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default problem with proftpd 1.2.10 installation

Hi!

I download proftpd 1.2.10 and tray to install it...
when i write comand "make"
it's say "make: *** No targets specified and no makefile found. Stop."

What i do wrong?
Reply With Quote
Sponsored Links
  #2  
Old 16th May 2007, 22:51
Leszek Leszek is offline
Senior Member
 
Join Date: Nov 2006
Location: Poland,Włocławek
Posts: 369
Thanks: 22
Thanked 42 Times in 35 Posts
Send a message via Skype™ to Leszek
Default

Did You run:
Code:
./configure
first ?
Reply With Quote
  #3  
Old 16th May 2007, 23:00
Pulkvedis Pulkvedis is offline
Junior Member
 
Join Date: May 2007
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

yes i run it a the write

linux:~/proftpd-1.2.10 # ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

OK i find a problem. I install gcc pack and now it's ok

Last edited by Pulkvedis; 16th May 2007 at 23:09.
Reply With Quote
  #4  
Old 16th May 2007, 23:08
Leszek Leszek is offline
Senior Member
 
Join Date: Nov 2006
Location: Poland,Włocławek
Posts: 369
Thanks: 22
Thanked 42 Times in 35 Posts
Send a message via Skype™ to Leszek
Default

You don't have any C compilers installed.
You need to install gcc.
Reply With Quote
  #5  
Old 16th May 2007, 23:28
Pulkvedis Pulkvedis is offline
Junior Member
 
Join Date: May 2007
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

yes i install it now.

and next problem: How can i start this server?
Reply With Quote
  #6  
Old 16th May 2007, 23:42
Leszek Leszek is offline
Senior Member
 
Join Date: Nov 2006
Location: Poland,Włocławek
Posts: 369
Thanks: 22
Thanked 42 Times in 35 Posts
Send a message via Skype™ to Leszek
Default

I depends on Your distribution.
For example in Debian:

Quote:
/etc/init.d/proftpd start
It is similar in different distributions.
Reply With Quote
  #7  
Old 16th May 2007, 23:47
Pulkvedis Pulkvedis is offline
Junior Member
 
Join Date: May 2007
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

yes i tray but result ir bad

linux:~ # /etc/init.d/proftpd start
Starting ProFTPD Server: failed

how i understand this file "proftpd" in this init.d. directory i must create my self manualy yes? first time when i create it un tray start server result was:

linux:~ # /etc/init.d/proftpd start
bash: /etc/init.d/proftpd: Permission denied

then i in permission check field execuatable i do wrong?
Reply With Quote
  #8  
Old 16th May 2007, 23:56
Leszek Leszek is offline
Senior Member
 
Join Date: Nov 2006
Location: Poland,Włocławek
Posts: 369
Thanks: 22
Thanked 42 Times in 35 Posts
Send a message via Skype™ to Leszek
Default

This file should be created automatically and must be exacutable.
Code:
chmod u+x /etc/init.d/proftpd
Reply With Quote
  #9  
Old 17th May 2007, 00:17
Pulkvedis Pulkvedis is offline
Junior Member
 
Join Date: May 2007
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Default

linux:/ # chmod u+x /etc/init.d/proftpd
chmod: cannot access `/etc/init.d/proftpd': No such file or directory

what now?
Reply With Quote
  #10  
Old 17th May 2007, 00:28
Leszek Leszek is offline
Senior Member
 
Join Date: Nov 2006
Location: Poland,Włocławek
Posts: 369
Thanks: 22
Thanked 42 Times in 35 Posts
Send a message via Skype™ to Leszek
 
Default

My /etc/init.d/proftpd looks like this:

Code:
#!/bin/sh 

# Start the proftpd FTP daemon.

PATH=/bin:/usr/bin:/sbin:/usr/sbin
DAEMON=/usr/sbin/proftpd
NAME=proftpd

# Defaults
RUN="no"
OPTIONS=""

PIDFILE=`grep -i 'pidfile' /etc/proftpd/proftpd.conf | sed -e 's/pidfile[\t ]\+//i'`
if [ "x$PIDFILE" = "x" ];
then
	PIDFILE=/var/run/proftpd.pid
fi

# Read config (will override defaults)
[ -r /etc/default/proftpd ] && . /etc/default/proftpd

trap "" 1
trap "" 15

test -f $DAEMON || exit 0

#
# These compatibility funcs are here just for sarge backports.
# They will be removed post-etch.
#
log_daemon_msg() {
    echo -n "$1: $2"
}

log_end_msg() {
    if [ $1 -ne 0 ]; then
       echo " failed!"
    else
       echo "."
    fi
}

[ -f /lib/lsb/init-functions ] && . /lib/lsb/init-functions

#
# Servertype could be inetd|standalone|none.
# In all cases check against inetd and xinetd support.
#
if ! egrep -qi "^[[:space:]]*ServerType.*standalone" /etc/proftpd/proftpd.conf
then
    if [ $(dpkg-divert --list xinetd|wc -l) -eq 1 ] 
    then
	if egrep -qi "server[[:space:]]*=[[:space:]]*/usr/sbin/proftpd" /etc/xinetd.conf 2>/dev/null || \
	   egrep -qi "server[[:space:]]*=[[:space:]]*/usr/sbin/proftpd" /etc/xinetd.d/* 2>/dev/null
	then
    		RUN="no"
    		INETD="yes"
	else
		if ! egrep -qi "^[[:space:]]*ServerType.*inetd" /etc/proftpd/proftpd.conf
		then
    			RUN="yes"
			INETD="no"
		else
			RUN="no"
			INETD="no"
		fi
	fi
    else
    	if egrep -qi "^ftp.*/usr/sbin/proftpd" /etc/inetd.conf 2>/dev/null
    	then
    		RUN="no"
    		INETD="yes"
    	else
		if ! egrep -qi "^[[:space:]]*ServerType.*inetd" /etc/proftpd/proftpd.conf
		then
    			RUN="yes"
			INETD="no"
		else
			RUN="no"
			INETD="no"
		fi
    	fi
    fi
fi

# /var/run could be on a tmpfs

[ ! -d /var/run/proftpd ] && mkdir /var/run/proftpd

start()
{
    log_daemon_msg "Starting ftp server" "$NAME"

    start-stop-daemon --start --quiet --pidfile "$PIDFILE" --exec $DAEMON -- $OPTIONS  
    if [ $? != 0 ]; then
        log_end_msg 1
        exit 1
    else
        log_end_msg 0
    fi
}

signal()
{

    if [ "$1" = "stop" ]; then
	SIGNAL="TERM"
    	log_daemon_msg "Stopping ftp server" "$NAME"
    else
	if [ "$1" = "reload" ]; then
	    SIGNAL="HUP"
    	    log_daemon_msg "Reloading ftp server" "$NAME"
	else
	    echo "ERR: wrong parameter given to signal()"
	    exit 1
	fi
    fi
    if [ -f "$PIDFILE" ]; then
    	start-stop-daemon --stop --signal $SIGNAL --quiet --pidfile "$PIDFILE"
   	 if [ $? = 0 ]; then
        	log_end_msg 0
    	else
		SIGNAL="KILL"
		start-stop-daemon --stop --signal $SIGNAL --quiet --pidfile "$PIDFILE"
    		if [ $? != 0 ]; then
        		log_end_msg 1
        		[ $2 != 0 ] || exit 0
    		else
        		log_end_msg 0
    		fi
    	fi
   	if [ "$SIGNAL" = "KILL" ]; then
		rm -f "$PIDFILE"
    	fi
    else
        log_end_msg 0
    fi
}

case "$1" in
    start)
	if [ "x$RUN" = "xyes" ] ; then
	    start
	else
	    if [ "x$INETD" = "xyes" ] ; then
		echo "ProFTPd is started from inetd/xinetd."
	    else 
	    	echo "ProFTPd warning: cannot start neither in standalone nor in inetd/xinetd mode. Check your configuration."
	    fi
	fi
	;;

    force-start)
	if [ "x$INETD" = "xyes" ] ; then
	    echo "Warning: ProFTPd is started from inetd/xinetd (trying to start anyway)."
	fi
	start
	;;	
    
    stop)
	if [ "x$RUN" = "xyes" ] ; then
	    signal stop 0
	else
	    if [ "x$INETD" = "xyes" ] ; then
		echo "ProFTPd is started from inetd/xinetd."
	    else 
	    	echo "ProFTPd warning: cannot start neither in standalone nor in inetd/xinetd mode. Check your configuration."
	    fi
	fi
	;;

    force-stop)
	if [ "x$INETD" = "xyes" ] ; then
	    echo "Warning: ProFTPd is started from inetd/xinetd (trying to kill anyway)."
	fi
	signal stop 0
	;;

    reload)
	signal reload 0
	;;

    force-reload|restart)
	if [ "x$RUN" = "xyes" ] ; then
	    signal stop 1
	    sleep 2
	    start
	else
	    if [ "x$INETD" = "xyes" ] ; then
		echo "ProFTPd is started from inetd."
	    else 
	    	echo "ProFTPd warning: cannot start neither in standalone nor in inetd/xinetd mode. Check your configuration."
	    fi
	fi
	;;

    *)
	echo "Usage: /etc/init.d/$NAME {start|force-start|stop|force-stop|reload|restart|force-reload}"
	exit 1
	;;
esac

exit 0
Maybe You can find this file in the directory where You unpacked Proftp to compile and install it ? Then You should copy it in the right place (/etc/init.d/).
Reply With Quote
The Following User Says Thank You to Leszek For This Useful Post:
Pulkvedis (17th May 2007)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in Proftpd configuration tecnico001 Installation/Configuration 3 6th March 2007 09:22
MySQL related Installation Problem crn_admin Installation/Configuration 5 10th August 2006 20:03
ISPConfig-2.2.2 installation problem (empty mysql db after installation) sfrank Installation/Configuration 4 25th May 2006 15:56
proftpd virtual host not working DaddyFix Installation/Configuration 6 19th April 2006 20:59
Im thinking about throwing proftpd to the trashcan danf.1979 Installation/Configuration 2 23rd December 2005 10:27


All times are GMT +2. The time now is 12:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.