Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 15th November 2005, 19:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

Quote:
Originally Posted by dstme
For the email, I still unable to create with the same username. Anyway to delete it permanently and recreate again?
Please check the file /home/admispconfig/ispconfig/users if your username is in there. If it is, delete it from the file, but make sure that the user doesn't exist in /etc/password and /etc/shadow either.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 15th November 2005, 19:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,239 Times in 4,106 Posts
Default

Quote:
Originally Posted by dstme
For DB, can I reset it and not use web1_.
No. You can reset it only when you uninstall ISPConfig, remove the database and install ISPConfig again.

Quote:
Can I use username instead?
No.

Quote:
For the email, I still unable to create with the same username. Anyway to delete it permanently and recreate again?
Is the user still shown in the recycle bin after you emptied it? Have you created a user with the same username on the shell before you installed ISPConfig? Is a record in the database table isp_isp_user with that username?

Quote:
Also, when I emptied the prefix, I can't seem to login to FTP.
The prefix has nothing to do with FTP. Emptien the prefix does not change existing usernames, it will only affect new usernames.
Reply With Quote
  #13  
Old 15th November 2005, 19:52
dstme dstme is offline
Member
 
Join Date: Nov 2005
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Please check the file /home/admispconfig/ispconfig/users if your username is in there. If it is, delete it from the file, but make sure that the user doesn't exist in /etc/password and /etc/shadow either.
Thanks Superb! Yes found the name in the file /home/admispconfig/ispconfig/users
Deleted and it works like charms. Just wonder why it would not delete by itself.

I still cannot access to Web-FTP, seems username is wrong. Where can I check the username?
FYI, under the same file /home/admispconfig/ispconfig/users, it also shows:
web1_anonftp
web2_anonftp
web3_anonftp

As from /etc/passwd it shows:
web1_anonftp:x:12001:12001::/home/www/web1/ftp:/bin/false
web2_anonftp:x:12002:12002::/home/www/web2/ftp:/bin/false
web3_anonftp:x:12003:12003::/home/www/web3/ftp:/bin/false

And /etc/shadow it shows:
web1_anonftp:!!:13102:0:99999:7:::
web2_anonftp:!!:13102:0:99999:7:::
web3_anonftp:!!:13102:0:99999:7:::

Last edited by dstme; 15th November 2005 at 20:02.
Reply With Quote
  #14  
Old 15th November 2005, 19:53
dstme dstme is offline
Member
 
Join Date: Nov 2005
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
No. You can reset it only when you uninstall ISPConfig, remove the database and install ISPConfig again.



No.



Is the user still shown in the recycle bin after you emptied it? Have you created a user with the same username on the shell before you installed ISPConfig? Is a record in the database table isp_isp_user with that username?



The prefix has nothing to do with FTP. Emptien the prefix does not change existing usernames, it will only affect new usernames.
I tried with the username to login web-ftp, but can't
Reply With Quote
  #15  
Old 15th November 2005, 20:18
dstme dstme is offline
Member
 
Join Date: Nov 2005
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Almost give-up.

After able to recreate email account, I try to send email to the account, but it was returned.
Reply With Quote
  #16  
Old 15th November 2005, 20:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

What's in your mail log? Which distribution do you use? Did you follow any of the "Perfect Setups" on HowtoForge?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 15th November 2005, 20:33
dstme dstme is offline
Member
 
Join Date: Nov 2005
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default

From /var/log:
Quote:
Nov 16 03:15:49 chick postfix/smtpd[24713]: connect from smtpgate1.pacific.net.sg[203.120.90.30]
Nov 16 03:15:49 chick postfix/smtpd[24713]: NOQUEUE: reject: RCPT from smtpgate1.pacific.net.sg[203.120.90.30]: 554 <roystan@fotonetstudio.net>: Relay access denied; from=<romos@pacific.net.sg> to=<roystan@fotonetstudio.net> proto=SMTP helo=<smtpgate1.pacific.net.sg>
Nov 16 03:15:49 chick postfix/smtpd[24713]: disconnect from smtpgate1.pacific.net.sg[203.120.90.30]
Nov 16 03:17:46 chick postfix/smtpd[24758]: connect from smtpgate2.pacific.net.sg[203.120.90.29]
Nov 16 03:17:46 chick postfix/smtpd[24758]: NOQUEUE: reject: RCPT from smtpgate2.pacific.net.sg[203.120.90.29]: 554 <roystan@fotonetstudio.net>: Relay access denied; from=<romos@pacific.net.sg> to=<roystan@fotonetstudio.net> proto=SMTP helo=<smtpgate2.pacific.net.sg>
Nov 16 03:17:46 chick postfix/smtpd[24758]: disconnect from smtpgate2.pacific.net.sg[203.120.90.30]
Nov 16 03:18:49 chick postfix/trivial-rewrite[24717]: table hash:/etc/postfix/virtusertable(0,100) has changed -- restarting
Nov 16 03:21:06 chick postfix/anvil[24716]: statistics: max connection rate 1/60s for (smtp:203.120.90.30) at Nov 16 03:15:49
Nov 16 03:21:06 chick postfix/anvil[24716]: statistics: max connection count 1 for (smtp:203.120.90.30) at Nov 16 03:15:49
Nov 16 03:21:06 chick postfix/anvil[24716]: statistics: max cache size 1 at Nov 16 03:15:49
Nov 16 03:27:36 chick ipop3d[25731]: pop3 service init from 127.0.0.1
Nov 16 03:29:01 chick ipop3d[25764]: pop3 service init from 127.0.0.1
Nov 16 03:29:20 chick ipop3d[25775]: pop3 service init from 127.0.0.1
Nov 16 03:30:21 chick ipop3d[26006]: pop3 service init from 127.0.0.1
Nov 16 03:30:21 chick ipop3d[26006]: Login user=roystan host=chick.roystan.com [127.0.0.1] nmsgs=0/0
Nov 16 03:30:21 chick ipop3d[26006]: Command stream end of file while reading line user=roystan host=chick.roystan.com [127.0.0.1]
Anyway I can find my ftp username? I can't login with the username.

I followed step by steps on Perfect Setup with Fedora 4.

I think I might have to start over with ISPConfig. Can I just delete the whole folder and start over again?

Last edited by dstme; 15th November 2005 at 20:43.
Reply With Quote
  #18  
Old 15th November 2005, 21:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

Quote:
Originally Posted by dstme
From /var/log:
Is fotonetstudio.net in /etc/postfix/local-host-names? Did you enable "Server requires authentication." in your email client?

Quote:
Originally Posted by dstme
Anyway I can find my ftp username? I can't login with the username.
The username is the same as for email (normally web<id>_xxxx). It's important that you don't mix this up with the login for resellers and customers which is for ISPConfig only!
As you are on FC4, did you have a look at this thread? http://www.howtoforge.com/forums/showthread.php?t=196
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 15th November 2005, 21:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,239 Times in 4,106 Posts
Default

Quote:
Originally Posted by dstme
Thanks Superb! Yes found the name in the file /home/admispconfig/ispconfig/users
Deleted and it works like charms. Just wonder why it would not delete by itself.

I still cannot access to Web-FTP, seems username is wrong. Where can I check the username?
FYI, under the same file /home/admispconfig/ispconfig/users, it also shows:
web1_anonftp
web2_anonftp
web3_anonftp

As from /etc/passwd it shows:
web1_anonftp:x:12001:12001::/home/www/web1/ftp:/bin/false
web2_anonftp:x:12002:12002::/home/www/web2/ftp:/bin/false
web3_anonftp:x:12003:12003::/home/www/web3/ftp:/bin/false

And /etc/shadow it shows:
web1_anonftp:!!:13102:0:99999:7:::
web2_anonftp:!!:13102:0:99999:7:::
web3_anonftp:!!:13102:0:99999:7:::
All usernames taht you find in the file /home/admispconfig/ispconfig/users are not managed by ISPConfig. That means you cant delete or edit them in the ISPConfig Interface. The file /home/admispconfig/ispconfig/users is created by the ISPConfig installer to protect users to be overriden by ISPConfig that where in the /etc/passwd file before ISPConfig was installed.
Reply With Quote
  #20  
Old 16th November 2005, 07:39
dstme dstme is offline
Member
 
Join Date: Nov 2005
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I think I better re-install ISPConfig.
1. Do I uninstall by going to /root/ispconfig/uninstall ?
2. And to reinstall, do I follow the steps provided by ISPConfig? Will all data in db reset?
3.
Quote:
The username is the same as for email (normally web<id>_xxxx). It's important that you don't mix this up with the login for resellers and customers which is for ISPConfig only!
I have leave prefix blank.Till now, I still unable to receive email. Seems emails are not able to reach to server or has been rejected by the server.
Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Details on problem /mailuser login and more (long) linutzy Installation/Configuration 11 15th February 2006 18:45
Virtual Users And Domains With Postfix, etc, problem with SMTP/Auth wrong password ggere HOWTO-Related Questions 15 14th November 2005 16:08
username generation Lord_Garfield General 1 25th October 2005 10:00
Case Sensitive username for email Hellbound General 5 16th September 2005 15:10
Mail not accepting username and password! nformosa General 9 14th September 2005 09:58


All times are GMT +2. The time now is 01:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.