Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th May 2007, 22:35
Heinz09 Heinz09 is offline
Junior Member
 
Join Date: May 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default CentOS4.4 ISPConfig installation buggy...

I installed CentOS4.4 according to the step by step tutorial, everything went kinda perfect.
Until I wanted to install ISPConfig... Here is the final message I got with the installation.

Code:
All prerequisites are fulfilled.
Here we go...

Warning: include(config.inc.php): failed to open stream: No such file or directory in /root/Desktop/install_ispconfig/install.php on line 665

Warning: include(): Failed opening 'config.inc.php' for inclusion (include_path='.:') in /root/Desktop/install_ispconfig/install.php on line 665

Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /root/Desktop/install_ispconfig/install.php on line 685
Could not connect to db
Restarting some services...
./setup2: line 1117: [: ==: unary operator expected
./setup2: line 1135: /etc/rc.d/init.d/ispconfig_server: No such file or directory
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
From there I tried to get it running, and it kinda worked, until I try to actually run it.
Now for some reason this pops up

Code:
 /etc/rc.d/init.d/ispconfig_server start
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Starting ISPConfig system...
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
fopen: No such file or directory
ispconfig_httpd: could not open document config file /root/ispconfig/httpd/conf/httpd.conf
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started

Warning: include(/home/admispconfig/ispconfig/lib/config.inc.php): failed to open stream: No such file or directory in /root/ispconfig/scripts/lib/config.inc.php on line 30

Warning: include(): Failed opening '/home/admispconfig/ispconfig/lib/config.inc.php' for inclusion (include_path='.:') in /root/ispconfig/scripts/lib/config.inc.php on line 30
Could not connect to MySQL server!FreshClam is already running!
ISPConfig system is now up and running!
Please I am as lost as can be, can anyone help?
Reply With Quote
Sponsored Links
  #2  
Old 10th May 2007, 22:39
Heinz09 Heinz09 is offline
Junior Member
 
Join Date: May 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Code:
/etc/rc.d/init.d/ispconfig_server start

Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
/etc/rc.d/init.d/ispconfig_server: line 39: 20544 Segmentation fault      /root/ ispconfig/php/php -q /root/ispconfig/scripts/shell/firewall.php
ISPConfig system is now up and running!
Once again after messing around this is what it's doing now.... getting warmer?
Reply With Quote
  #3  
Old 11th May 2007, 08:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,768
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Quote:
Once again after messing around this is what it's doing now.... getting warmer?
Now, because ISPConfig is not installed completely on your server. We had to fix your first problem and then reinstall ISPConfig.

1) Uninstall ISPConfig be running:

rm -rf /root/ispconfig
rm -rf /home/admispconfig

2) Delete the complete ISPConfig mysql database.

3)
Installation:

- Download it to e.f. /tmp and unpack it. Do not try to install it from /root/ispconfig or /home/admispconfig
- make sure that you have enough space on your harddisk, you need approx 250 MB in the /root directory during installation
- Make sure that there exists nor mysl database with the same name that you choose for the ispconfig database in the installer.
- Make sure that your mysql user has root permissions ( to enable the installer to create the mysql database during setup)
- enter theinstall_ispconfig directory with the cd command before you execute the setup script.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Heinz09 (11th May 2007)
  #4  
Old 11th May 2007, 12:53
Heinz09 Heinz09 is offline
Junior Member
 
Join Date: May 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default now again...

Well for some reason now when it asks for the host name and domain it keeps telling me that the URL is not reachable.

I can ping it, I can see it, but ISPconfig just ignores it
Reply With Quote
  #5  
Old 11th May 2007, 13:57
Heinz09 Heinz09 is offline
Junior Member
 
Join Date: May 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default :) Happy :)

It works after a bit more messing around, lots of thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig after installation CoDonCo Installation/Configuration 46 14th July 2010 16:54
ISPconfig after installation cannot reach www.xyz.de:81 Figth4Linux Installation/Configuration 23 6th March 2008 22:38
Ispconfig Installation Problems 2XTREME4U Installation/Configuration 6 21st June 2007 11:43
newbie ububtu 6.0.6 error PHP binary line 816 davidsky73 Installation/Configuration 8 17th September 2006 11:51
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 09:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.