Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 11th June 2007, 22:26
lapena lapena is offline
Junior Member
 
Join Date: Apr 2007
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

I've just found somethinginteresting. I added this command to the .procmailrc file :
LOGFILE=.procmail-log
Si erverything is logged in this file. Here's the output after one test:

/bin/sh: line 2: -oi: command not found
/bin/sh: /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin: N
o such file or directory
procmail: Program failure (127) of "/home/admispconfig/ispconfig/tools/spamassas
sin/usr/bin/spamassassin"
procmail: Rescue of unfiltered data succeeded
/bin/sh: line 3: -oi: command not found


So I think the problem is that the .autoresponder.rc isn't working well with spamassassin (No such file or directory).

Moreover the error '-oi: command not found' seems to be due to the fact that the system can't lookup $SENDMAIL.


How can I fix $SENDMAIL ? And how can I fix spamassassin error ?


Kindest regards,
lapena

Last edited by lapena; 11th June 2007 at 22:30.
Reply With Quote
Sponsored Links
  #22  
Old 12th June 2007, 13:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's the output of
Code:
which sendmail
?
Did you accidentally delete /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #23  
Old 12th June 2007, 15:42
lapena lapena is offline
Junior Member
 
Join Date: Apr 2007
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default

i'm sure I didn't delete this folder, accidentally or not. i really take care before deleting anything.

here's the output of the command which sendmail :
/usr/sbin/sendmail

and as said before, postfix is installed and here is exactly what is installed in /usr/sbin :

ls -al /usr/sbin/sendmail*
lrwxrwxrwx 1 root root 34 jun 4 12:48 /usr/sbin/sendmail -> /etc/alternatives/sendmail-command*
-rwxr-xr-x 1 root root 23776 mar 8 17:19 /usr/sbin/sendmail.postfix*
Reply With Quote
  #24  
Old 13th June 2007, 01:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's the output of
Code:
ls -la /etc/alternatives
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #25  
Old 13th June 2007, 12:04
lapena lapena is offline
Junior Member
 
Join Date: Apr 2007
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default

lrwxrwxrwx 1 root root 26 jun 4 12:48 sendmail-command -> /usr/sbin/sendmail.postfix*
lrwxrwxrwx 1 root root 26 jun 4 12:48 sendmail-command-in_libdir -> /usr/sbin/sendmail.postfix*
Reply With Quote
  #26  
Old 13th June 2007, 19:51
lapena lapena is offline
Junior Member
 
Join Date: Apr 2007
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default $SENDMAIL variable

as said before, I saw in the log that the variable $SENDMAIL was unknown for procmail.
so I've modified .autoresponder.rc to include this variable. I've added the line above:

SENDMAIL=/usr/sbin/sendmail

and it worked fine, until Ispconfig recreates the file, and this line didn't appear anymore.
where should I write this variable so that it works anytime for any user ?


kindest regards,
lapena
Reply With Quote
The Following User Says Thank You to lapena For This Useful Post:
cambo (19th June 2007)
  #27  
Old 13th June 2007, 20:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,339 Times in 4,188 Posts
Default

You can put it in the procmailrc master template in /root/ispconfig/isp/conf/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #28  
Old 13th June 2007, 20:22
lapena lapena is offline
Junior Member
 
Join Date: Apr 2007
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default

thanks, I'll try this. I'm pretty sure it will work.

and do you have any idea why i don't have this folder :

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin ?

(I'm sure i didn't deleted it - I even looked on history) and do you have any idea on how to recreate it ?

thanks
Reply With Quote
  #29  
Old 13th June 2007, 20:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,339 Times in 4,188 Posts
Default

Thats not a folder, it is a file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #30  
Old 13th June 2007, 21:19
lapena lapena is offline
Junior Member
 
Join Date: Apr 2007
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

you're right it's a file

but the folder /home/admispconfig/ispconfig/tools/spamassassin/usr/bin doesn't exist. so the file doesn't exist too.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS stop working MZH General 3 22nd February 2008 11:10
Autoresponder called from PHP not working TheRudy General 4 6th September 2006 18:46
ftp not working pesja Installation/Configuration 3 17th July 2006 12:37
Debian 3.1 install - Autoresponder not working jockstrap Installation/Configuration 4 15th July 2006 12:58
Autoresponder / Local Username / Reject / Bounce Yves Installation/Configuration 3 12th July 2006 13:58


All times are GMT +2. The time now is 21:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.