Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd May 2007, 12:39
ayuu ayuu is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy scripts not able to send out email to external

Hi All

I have just simple bash script to send out email to my external email.
I configure sendmail.cf smart relay to IP of my smtp server (running qmail).
I can see the mail are qued not delievered.
How can I make the email are sent.


I tried sending email from command line.
/var/log/maillog showed
......................
May 3 18:21:49 S106PU02 sendmail[15436]: l43ALnfI015436: from=root, size=45, class=0, nrcpts=1, msgid=<200705031021.l43ALnfI015436@localhost.local domain>, relay=root@localhost
May 3 18:21:49 S106PU02 sendmail[15436]: l43ALnfI015436: to=me@xxxxx.com, delay=00:00:00, mailer=esmtp, pri=30045, dsn=4.4.3, stat=queued
.........................................

/var/spool/clientqueue showed

root@ttttt [/var/spool/clientmqueue]
# more qfl43ALnfI015436
V8
T1178187709
K1178187709
N1
P30045
Mhost map: lookup (xxxxx.com): deferred
Fbs
$_root@localhost
${daemon_flags}c u
Sroot
Aroot@localhost.localdomain
rRFC822; me@xxxxx.com
RPFD:me@xxxxx.com
H?P?Return-Path: <g>
H??Received: (from root@localhost)
by localhost.localdomain (8.13.1/8.13.1/Submit) id l43ALnfI015436
for me@xxxxx.com; Thu, 3 May 2007 18:21:49 +0800
H?D?Date: Thu, 3 May 2007 18:21:49 +0800
H?F?From: root <root>
H?x?Full-Name: root
H?M?Message-Id: <200705031021.l43ALnfI015436@localhost.localdoma in >
H??To: me@xxxxx.com
H??Subject: TEST


Any help is appreciated. Pls advise.
Thans in deed. Regards, Ayuu.
Reply With Quote
Sponsored Links
  #2  
Old 4th May 2007, 09:46
ayuu ayuu is offline
Junior Member
 
Join Date: May 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I managed to get mail sent out. but still have not received.
I am not sure smtp server received and relayed.
any guidenace how to verify smtp server function?
thanks in advance.
Reply With Quote
  #3  
Old 5th May 2007, 19:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Do the MX records of the domains for which you want to receive mails point to the correct server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot send email from OE through ISPconfig site tomd General 10 12th March 2009 06:05
Can't send email with attachments to another email nysprite Installation/Configuration 2 29th June 2006 18:09
Can't send email with attachments to a user rafaelenrike General 9 15th June 2006 19:01
newbie...need to send out a bulk email for work.. pjm2211 HOWTO-Related Questions 1 22nd May 2006 22:58
External Email Getting Lost jash General 10 8th November 2005 21:55


All times are GMT +2. The time now is 14:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.