Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th April 2007, 23:45
FadeOUT FadeOUT is offline
Member
 
Join Date: Apr 2007
Posts: 30
Thanks: 3
Thanked 2 Times in 1 Post
Question PHP not working in ISPConfig website

Hi,

Sorry, I know this has come up before, but I've been searching for hours and I've yet to come up with a solution.

I have installed ISPConfig on a openSuse 10.2 server using Falko's Perfect Setup (Thanks, Falko) and all is well - apart from PHP; If I check the PHP Scripts box on the control panel it makes no difference. Trying to open a PHP page in Firebox just gives me:

You have chosen to open
Which is a: application/x-httpd-php

...In other words it looks like PHP pages aren't being parsed.

Any ideas
Reply With Quote
Sponsored Links
  #2  
Old 26th April 2007, 11:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Is the PHP file located in the website directory that ISPConfig created for the website?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th April 2007, 12:02
FadeOUT FadeOUT is offline
Member
 
Join Date: Apr 2007
Posts: 30
Thanks: 3
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by till
Is the PHP file located in the website directory that ISPConfig created for the website?
Hi, thanks for replying...

I believe so; for instance /srv/www/web1/web/myfile.php
Reply With Quote
  #4  
Old 26th April 2007, 21:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Is PHP enabled in the vhost configuration of that web site in the file Vhosts_ispconfig.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 26th April 2007, 22:19
FadeOUT FadeOUT is offline
Member
 
Join Date: Apr 2007
Posts: 30
Thanks: 3
Thanked 2 Times in 1 Post
Default

I think so..!

######################################
# Vhost: www.mydomain.com:80
######################################
#
#
<VirtualHost ***.my.ip.***:80>
ServerName www.mydomain.com:80
ServerAdmin webmaster@mydomain.com
DocumentRoot /srv/www/web3/web
ServerAlias mydomain.com www.mydomain.co.uk mydomain.co.uk
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /srv/www/web3/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/srv/www/web3/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web3/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web3/user/$1/web/$3
</VirtualHost>
Reply With Quote
  #6  
Old 27th April 2007, 15:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Are there any error messages in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 27th April 2007, 15:51
FadeOUT FadeOUT is offline
Member
 
Join Date: Apr 2007
Posts: 30
Thanks: 3
Thanked 2 Times in 1 Post
Default

Mmm... It's packed with:

[error] an unknown filter was not added: PHP


(And that's it)

Last edited by FadeOUT; 27th April 2007 at 15:57.
Reply With Quote
  #8  
Old 27th April 2007, 16:33
FadeOUT FadeOUT is offline
Member
 
Join Date: Apr 2007
Posts: 30
Thanks: 3
Thanked 2 Times in 1 Post
Default

Mmm... Have I been caught with that AddHandler / AddType thing, I wonder?

I should have used something other than SUSE, shouldn't I? Trouble is, a handful of friends are already using the thing, so I hope I don't have to start from scratch...

(I was thinking for a moment I was using a 64 bit machine here, but it is just a 32 bit box, in this case).

Last edited by FadeOUT; 27th April 2007 at 16:57.
Reply With Quote
  #9  
Old 27th April 2007, 16:40
FadeOUT FadeOUT is offline
Member
 
Join Date: Apr 2007
Posts: 30
Thanks: 3
Thanked 2 Times in 1 Post
Default

If I try turning php on and off in a website, I get the following in the apache2 error log:

[Fri Apr 27 14:10:02 2007] [warn] long lost child came home! (pid 16154)
[Fri Apr 27 14:10:49 2007] [notice] Graceful restart requested, doing restart
[Fri Apr 27 14:10:49 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
[Fri Apr 27 14:10:51 2007] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
Reply With Quote
  #10  
Old 27th April 2007, 20:01
Grizzly Grizzly is offline
Member
 
Join Date: Feb 2006
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Same error this side

any ideas on what to do to resolve this issue
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hotfix PHP segfaults ISPConfig 2.2.x till General 22 12th October 2007 13:16
Transferring Hard Drive to new System latcarf Installation/Configuration 26 20th February 2007 19:51
ISPConfig stop working after i add a new site xTiNcTion Installation/Configuration 4 6th January 2007 00:55
PHP on Apache2 no longer works after ISPconfig azorman Installation/Configuration 6 23rd July 2006 23:06
PHP & MySQL working, but AREN'T WORKING???? lipp9000 Installation/Configuration 4 21st July 2006 18:01


All times are GMT +2. The time now is 13:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.