#1  
Old 23rd April 2007, 12:20
pyro pyro is offline
Junior Member
 
Join Date: Apr 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default anonymous ftp without ispconfig

Hi all!

i`m using opensuse 10.2 perfect setup with ISPConfig. I want use anonymous ftp different root directory that ISPConfig proftpd_ispconfig.conf. I cant put it to proftpd_ispconfig.conf file becaus when ftp service restarts it makeing new conf file every time. How can i add to proftpd.conf file anonymous ftp login?
Sorry my poor english.
Reply With Quote
Sponsored Links
  #2  
Old 24th April 2007, 18:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

You can add your changes to the template in /root/ispconfig/isp/conf/.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th April 2007, 10:50
pyro pyro is offline
Junior Member
 
Join Date: Apr 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy not working

i maked lines to /root/ispconfig/isp/conf/proftpd_ispconfig.conf.master

PHP Code:
<VirtualHost IP>
<
Anonymous /srvData/ftp>
          
User                          ftp
          Group                         ftp
          UserAlias                     anonymous ftp
          UserAlias                     guest ftp
          MaxClients                    10 
"Sorry, max %m users -- try again later"
          
<Directory /srvData/ftp>
            <
Limit WRITE>
              
DenyAll
            
</Limit>
          </
Directory>
          <
Directory /srvData/ftp/incoming>
            
Umask                       022
            
<Limit STOR>
              
AllowAll
            
</Limit>
            <
Limit READ>
              
DenyAll
            
</Limit>
          </
Directory>
        </
Anonymous>
</
VirtualHost
but its not worrking (Password required for anonymous - login incorrect)
Reply With Quote
  #4  
Old 27th April 2007, 14:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Do you see your changes in /etc/proftpd_ispconfig.conf? If not, you have to change something in the ISPConfig web interface so that ISPConfig rewrites the configuration files.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 30th April 2007, 12:05
pyro pyro is offline
Junior Member
 
Join Date: Apr 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

aah, now i understand, ispconfig writes second anonymous virtualhost - i replaced my settings first and ispconfig second and all works

sorry poor english
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anonymous FTP Not Working robin99 Installation/Configuration 15 27th October 2008 12:27
Cannot connect to anonymus ftp n1kol1s Installation/Configuration 39 15th February 2007 18:36
FTP Error joshabts Installation/Configuration 3 4th November 2006 16:19
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 08:03
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 16:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.