Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd April 2007, 03:40
ghmercado ghmercado is offline
Junior Member
 
Join Date: Apr 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default while installing i screwed up the 'please enter' part

hey folks. I was following the instns at this page: http://www.ispconfig.org/manual_installation.htm

when i got to this part:

Please enter your MySQL server: E.G. localhost
Please enter your MySQL user: E.G. root
Please enter your MySQL password: Your MySQL password
Please enter a name for the ISPConfig database: E.g. ispconfigdb
Please enter the IP address of the ISPConfig web: E.g. 192.168.0.1
Please enter the host name: E.g. www
Please enter the domain: E.g. xyz.de


i mistakenly entered the wrong mysql password . Anyway, I forget what happened next exactly, except I had to reboot for some reason (i think it was unresponsive after awhile), and I went thru ./setup again, and this time it went through to the very end, saying I had successfully installed it.

but when I check out http://192.168.1.6:81, I get a blank page (although http://192.168.1.6 results in a dir page, meaning apache's working).

So basically, I want to go back to that part where I go through the "Please Enter your".... phase, so I can correct all the info.

Is it saved in some config file somewhere? Where and how do I edit it? Or do I just go through ./setup again? (someone needs to write on the install page that it can take as long as an hour btw).

Many thanks!!!
Reply With Quote
Sponsored Links
  #2  
Old 23rd April 2007, 09:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
ut when I check out http://192.168.1.6:81, I get a blank page
Please make sure that you have neta refresh, header redirects and javascript enabled in your browser. Please try e.g. firefox to get a better error message in case your SSL cert is corrupted.

A reinstallation is most likely not nescessary.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd April 2007, 09:33
ghmercado ghmercado is offline
Junior Member
 
Join Date: Apr 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

im sorry for not being clear. I am using Firefox, the message is:

Unable to connect
Firefox can't establish a connection to the server at 192.168.1.6:81.
Reply With Quote
  #4  
Old 23rd April 2007, 09:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Please run:

netstat -tap

and:

iptables -L

on your server and post the output.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 23rd April 2007, 09:49
ghmercado ghmercado is offline
Junior Member
 
Join Date: Apr 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

sudo netstat -tap results:

Code:
myadmin@myserver:~$ sudo netstat -tap
Password:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State                                                                    PID/Program name
tcp        0      0 *:mysql                 *:*                     LISTEN     3                                                             805/mysqld
tcp        0      0 *:ftp                   *:*                     LISTEN     4                                                             042/proftpd: (acce
tcp        0      0 myserver:domain       *:*                     LISTEN     3                                                             609/named
tcp        0      0 localhost.locald:domain *:*                     LISTEN     3                                                             609/named
tcp        0      0 *:smtp                  *:*                     LISTEN     3                                                             947/master
tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     3                                                             609/named
tcp6       0      0 *:imaps                 *:*                     LISTEN     3                                                             679/couriertcpd
tcp6       0      0 *:pop3s                 *:*                     LISTEN     3                                                             714/couriertcpd
tcp6       0      0 *:pop3                  *:*                     LISTEN     3                                                             694/couriertcpd
tcp6       0      0 *:imap2                 *:*                     LISTEN     3                                                             659/couriertcpd
tcp6       0      0 *:www                   *:*                     LISTEN     4                                                             085/apache2
tcp6       0      0 *:ssh                   *:*                     LISTEN     3                                                             972/sshd
tcp6       0      0 *:smtp                  *:*                     LISTEN     3                                                             947/master
tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     3                                                             609/named
tcp6       0      0 *:https                 *:*                     LISTEN     4                                                             085/apache2
tcp6       0    296 myserver:ssh          ::ffff:192.168.1.5:1961 ESTABLISHED4                                                             145/sshd: myadm
sudo iptables -L results:

Code:
myadmin@myserver:~$ sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
thanks so much till
Reply With Quote
  #6  
Old 23rd April 2007, 09:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

I hope you did not run the ISPConfig setup script trough sudo as this wont work. You must run it as root user.

ISPConfig is not running at all, so I guess the complete setup ISPConfig setup is not ok. In this case, you will have to reinstall ISPConfig.

1) Switch to the root user:

sudo -s

2) Uninstall ISPConfig:

/root/ispconfig/uninstall

3) Unpack and install ISPConfig again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 23rd April 2007, 10:00
ghmercado ghmercado is offline
Junior Member
 
Join Date: Apr 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

argg kinda suspected that. but sorry had to ask here anyway since the installation takes so long i wanted to make sure before I tried again.

question though, i do not seem to have uninstall:

Code:
root@myadmin-mail:/root/ispconfig# cd /root/ispconfig/uninstall
bash: cd: /root/ispconfig/uninstall: No such file or directory
any other way to uninstall? many thanks again.
Reply With Quote
  #8  
Old 23rd April 2007, 10:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
 
Default

Quote:
Originally Posted by ghmercado
any other way to uninstall? many thanks again.
Yes, just run:

rm -rf /root/ispconfig
rm -rf /home/admispconfig

and delete the ISPConfig mysql database.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
while installing i screwed up the 'please enter' part ghmercado Installation/Configuration 3 23rd April 2007 09:22
Please enter the host name: E.g. www ????? xinapsys Installation/Configuration 2 17th June 2006 13:02
enter the host name (e.g. www):www - I have a second server tadelste Installation/Configuration 1 26th April 2006 19:51
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
error while installing..... securitywonks Installation/Configuration 1 23rd December 2005 12:07


All times are GMT +2. The time now is 19:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.