Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th April 2007, 04:21
Craig Craig is offline
Member
 
Join Date: Dec 2006
Posts: 56
Thanks: 1
Thanked 3 Times in 1 Post
Default Mail for one virtual domain works but not another

I have been having no problems with a site and mail server I set up under ISPConfig.

I added another site and the web service works flawlessly, as I have come to expect from ISPConfig but the mail service, PostiFix is not a happy camper, which I have also come to expect trying to set up mail service.

Note this would seem to NOT be an ISPConfig problem as a previous site/mail account works perfectly.

The symptoms are:
1. Mail clients can connect and send mail from the problem accounts to anywhere on any other mail server with no problems.
2. Mail can be sent to and received from either mail accounts on either site/mail server on the box.
3. The initial mail accounts can receive e-mail sent to them from mail servers/accounts outside of its domain.
4. The second site's mail accounts can not receive e-mail sent to them from other mail servers outside of its domain and the error listed is "530 relay not allowed"
5. The second site's mail was set up using exactly the same procedure in ISPConfig as the first.
6. Doing an MX Record check for the first site results with :
Code:
Non-authoritative answer:
cass-hacks.com  mail exchanger = 0 cass-hacks.com.

Authoritative answers can be found from:
Doing the same for the second gives basically the exact same results :
Code:
Non-authoritative answer:
oceanvodka.com  mail exchanger = 0 oceanvodka.com.

Authoritative answers can be found from:
Although there is no Authoritative answers for the second, there aren't for the first either and the first works fine.

Things I know :
1. From an ISPConfig point of view, both site's mail were set up exactly the same way.
2. MX Record lookups return virtually the same results for both.
3. The same mail accounts on other servers that can send mail to the first can not send to the second.
4. Firewall is not a problem due to #3.
5. Blacklists are not a problem due to #3
6. The first site's domain is registered and set up using GoDaddy.
7. The second site's domain is registered and set up using register.com
8. I am losing the last few hairs I have left on my head!!!

Anyone got any ideas or suggestions as to what to check?

Craig

[EDIT] I should add, there are no entries in "maillog" when the mail is attempting to be delivered from outside mail servers. Also, the undelivered mails are NOT ending up in "assp"'s spam directory so I know it is NOT a matter of the incoming mail being identified as spam and never making it to PostFix.[/EDIT]
__________________
cass-hacks.com

Last edited by Craig; 27th April 2007 at 04:38.
Reply With Quote
Sponsored Links
  #2  
Old 27th April 2007, 07:16
Craig Craig is offline
Member
 
Join Date: Dec 2006
Posts: 56
Thanks: 1
Thanked 3 Times in 1 Post
 
Default

I found the solution!!!

I forgot to engage my brain!!!

Seriously though, I had forgotten to inform ASSP about the new domain in its "Relay" section of the configuration. I added the site that wasn't working and BOOM! it of course started to work!

[EDIT] I should also add that since ASSP (Anti-Spam SMTP Proxy) is NOT part of the ISPConfig install that this obviously was not an ISPConfig problem, as I originally mentioned but since it was an ASSP configuration problem, definitely doesn't even belong in this forum. Could the powers that be please move it to a more appropriate forum, or the junk bin? [/EDIT]
__________________
cass-hacks.com

Last edited by Craig; 27th April 2007 at 07:21.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL Radukn HOWTO-Related Questions 14 12th October 2008 17:10
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
ISPConfig creates virtual domain even when the mail server is external mxc General 1 25th July 2006 12:32
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 05:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.