Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th April 2007, 21:20
tony98 tony98 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default .htaccess and Rewrite woes with Debian4.0 and ISPconfig

I recently installed Debian4.0 via the perfect install guide and ISPconfig ontop of that. I've attempted to setup myPh3 Gallery (http://myph.sourceforge.net/) and phpAutoGallery (http://phpautogallery.sourceforge.net/) with little or no sucess. (I've run phpAutoGallery before with no troubles)

myPh3 started with complaining about "Options not allowed here" I changed the apache2.conf to AllowOverride All in that directory but that just lead me to a new problem.
[Fri Apr 20 11:32:07 2007] [error] [client x.x.x.x] Directory index forbidden by Options directive: /var/www/web7/web/myPh3/

web/myPh3/.htaccess should be redirecting the client....

Quote:
Options +FollowSymLinks -MultiViews

RewriteEngine On
RewriteRule ^myPh3/?$ myPh3.core.php [L]
RewriteRule ^myPh3/(album|photo)/(.*)$ myPh3.core.php?$1=$2 [L]
So, after that I figured something was broken and proceeded to not find any information on myPh3 users.. so, I moved to something I've used before (even so I think I would like to try myPh3 in the future)

phpAutoGallery is also giving me problems with the url rewrite.. This is the page that loads when I go to the main gallery page.. notice the recursive /photobox
Quote:
Page: //home/www/web7/web/photobox//photobox/ not found!
[ admin ]
Indexed by phpAutoGallery v0.9.6
2004 All rights reserved.
and here is the .htaccess file for that directory.
Quote:
RewriteEngine on

RewriteCond %{REQUEST_URI} !.*__phpAutoGallery/wrapper\.php.*
RewriteRule .* /photobox/__phpAutoGallery/wrapper.php [NE,QSA,L]
Any ideas? I've checked /etc/apache2/mods-enabled and rewrite is turned on.


Thanks !

-Tony
Reply With Quote
Sponsored Links
  #2  
Old 27th April 2007, 02:30
elmotheelk elmotheelk is offline
Junior Member
 
Join Date: Apr 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi Tony,

Search Google on my own script, I came across your problem with my myPh3 script. Very nice to see people actually trying it out and using it! THerefor, I'd be more than willing to help you with your problems.

First of all, you can simply turn off URL rewriting to see it the script is set up correctly. Get your browser to /myPh3/myPh3.core.php (if you installed the script in a website subdirectory /myPh3) hereafter. If this works, we can direct to the rewrite problem. Are you sure your used the /myPh3/myPh3 URL? It does NOT use the directory default page... You can also contact me at the SourceForge site http://myph.sf.net . Hope to hear from you.

Eric
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig Roadmap till General 34 12th March 2009 11:19
ISPConfig, Drupal, and .htaccess jon335 General 23 16th November 2008 13:22
ISPConfig Roadmap till Developers' Forum 26 10th June 2007 22:38
wordpress MU and ISPconfig .htaccess isues palkat General 4 18th October 2006 11:57
.htaccess login challenge broken with mod_rewrite ozonblue Installation/Configuration 2 13th September 2006 10:09


All times are GMT +2. The time now is 14:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.