#1  
Old 20th April 2007, 16:50
tommyboy180 tommyboy180 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Squid Problem

Hi, my first post here.
I have installed Squid on my LAN. Right now I am having a real difficult time getting Squid to work. I am getting the dreaded Access Denied error.
I am really confused because my ACL looks fine to me.
I was wondering if anyone would be interested in looking at my squid.conf for me. I am not sure if i should post it here as an attachment or send it via email to you.
This would be much appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 21st April 2007, 14:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by tommyboy180
I am getting the dreaded Access Denied error.
What's the exact error message, and where/when do you get it?

Quote:
Originally Posted by tommyboy180
I was wondering if anyone would be interested in looking at my squid.conf for me. I am not sure if i should post it here as an attachment or send it via email to you.
You can post it here directly (not as an attachment!).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st April 2007, 14:13
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,158
Thanks: 4
Thanked 58 Times in 54 Posts
Default

Just use the
[ code ] [ /code ] tags around it (of course without white-spaces
Reply With Quote
  #4  
Old 21st April 2007, 17:27
tommyboy180 tommyboy180 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you for your reply.
here is a snippet of some of the code
Code:
1177197588.512      3 192.168.1.1 TCP_DENIED/403 1432 GET http://spa.snap.com/snap_preview_anywhere.js? - NONE/- text/html
1177197588.512      3 192.168.1.1 TCP_DENIED/403 1482 GET http://www.game-monitor.com/server-stat-image/203.82.114.251:27015.png - NONE/- text/html
1177197588.512      3 192.168.1.1 TCP_DENIED/403 1482 GET http://www.game-monitor.com/server-stat-image/203.82.114.251:27960.png - NONE/- text/html
1177197588.548      2 192.168.1.1 TCP_DENIED/403 1482 GET http://www.game-monitor.com/server-stat-image/203.82.114.251:27016.png - NONE/- text/html
1177197588.577      0 192.168.1.1 TCP_DENIED/403 1482 GET http://www.game-monitor.com/server-stat-image/203.82.114.251:28004.png - NONE/- text/html
1177197588.665     25 192.168.1.1 TCP_DENIED/403 1482 GET http://www.game-monitor.com/server-stat-image/203.82.114.251:27888.png - NONE/- text/html
1177197598.537      7 192.168.1.1 TCP_DENIED/403 1386 GET http://mail.yahoo.com/ - NONE/- text/html
1177197706.617      7 192.168.1.1 TCP_DENIED/403 1384 GET http://www.yahoo.com/ - NONE/- text/html
1177197713.505      8 192.168.1.1 TCP_DENIED/403 1394 GET http://gd.geobytes.com/gd? - NONE/- text/html
1177197716.758     13 192.168.1.1 TCP_DENIED/403 1384 GET http://www.yahoo.com/ - NONE/- text/html
1177197726.757     15 192.168.1.1 TCP_DENIED/403 1384 GET http://www.yahoo.com/ - NONE/- text/html
And to answer you question... I receive these errors immediately after I try to browse a web site.
Thank you for your help. Let me know what I can do to help generate a solution.

Last edited by tommyboy180; 21st April 2007 at 17:31.
Reply With Quote
  #5  
Old 28th April 2007, 04:38
tommyboy180 tommyboy180 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Was there anything else that I can provide inorder to make this easy? I appreciate your help.
Reply With Quote
  #6  
Old 6th May 2007, 05:47
tommyboy180 tommyboy180 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

_-*bump*-_
Reply With Quote
  #7  
Old 6th May 2007, 11:34
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,158
Thanks: 4
Thanked 58 Times in 54 Posts
Default

post the squid.conf
Reply With Quote
  #8  
Old 6th May 2007, 16:58
tommyboy180 tommyboy180 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you for the reply

Here is the squid.conf
Code:
#  TAG: http_port
http_port 3128 transparent

#  TAG: hierarchy_stoplist
hierarchy_stoplist cgi-bin ?
acl QUERY urlpath_regex cgi-bin \?
cache deny QUERY
#  TAG: cache_vary
#  TAG: broken_vary_encoding
acl apache rep_header Server ^Apache
broken_vary_encoding allow apache
#  TAG: access_log
access_log /var/log/squid/access.log squid
#  TAG: hosts_file
hosts_file /etc/hosts
#  TAG: refresh_pattern
refresh_pattern ^ftp:		1440	20%	10080
refresh_pattern ^gopher:	1440	0%	1440
refresh_pattern .		0	20%	4320
#  TAG: acl
#Recommended minimum configuration:
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 # https
acl SSL_ports port 563 # snews
acl SSL_ports port 873 # rsync
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl Safe_ports port 631 # cups
acl Safe_ports port 873 # rsync
acl Safe_ports port 901 # SWAT
acl purge method PURGE
acl CONNECT method CONNECT

#____TOM_____
acl my_network src 192.168.1.0/24
acl time time SMTWHFA
#__
#__TOM__
http_access allow my_network
http_access allow time
#_
#Recommended minimum configuration:
#
# Only allow cachemgr access from localhost
http_access allow manager localhost
http_access deny manager
# Only allow purge requests from localhost
http_access allow purge localhost
http_access deny purge
# Deny requests to unknown ports
#http_access deny !Safe_ports
# Deny CONNECT to other than SSL ports
#http_access deny CONNECT !SSL_ports
http_access allow CONNECT
#
# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost
#

acl our_networks src 192.168.1.0/24 192.168.2.0/24
http_access allow our_networks
#http_access allow localhost

# And finally deny all other access to this proxy
http_access deny all

# http_reply_access allow all
#
#Recommended minimum configuration:
#
# Insert your own rules here.
#
#
# and finally allow by default
http_reply_access allow all

#  TAG: icp_access

# icp_access deny all
#
#Allow ICP queries from everyone
icp_access allow all

# cache_effective_user proxy
cache_effective_user tom

#  TAG: cache_effective_group
cache_effective_group tom


visible_hostname proxy
Due to the 10000 character limit I have attached the squid.conf that was not edited.
Attached Files
File Type: zip squid.conf.zip (45.9 KB, 288 views)
Reply With Quote
  #9  
Old 20th May 2007, 15:19
tommyboy180 tommyboy180 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I take the echoing silence that this config is really fubar’d!
Reply With Quote
  #10  
Old 21st May 2007, 13:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

I'm no Squid expert...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 18:58
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 17:06
Squid Problem.....Access Denied tbaker HOWTO-Related Questions 3 4th February 2006 14:46


All times are GMT +2. The time now is 19:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.