#11  
Old 13th November 2005, 14:11
Mahir Mahir is offline
Member
 
Join Date: Oct 2005
Location: The Netherlands, Apeldoorn
Posts: 40
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to Mahir Send a message via Yahoo to Mahir
Default

Falk i really don't understand i tryed everything,
also i did the guide of mail and copy and pasted eveything again to check if it was correct and checked if everything was running wel.
But i can't send mail it doesn't want to connect to my smtp server if i do in Outlook 2003 a test it says pop3 is ok it also read the mail but at sending it is not ok isn't there anything else u maybe think it could be wrong?
Reply With Quote
Sponsored Links
  #12  
Old 2nd December 2005, 15:25
maroonworks maroonworks is offline
Junior Member
 
Join Date: Nov 2005
Posts: 25
Thanks: 0
Thanked 1 Time in 1 Post
Default

Mahir i'm facing the same problem too...

what distrubution of linux ur using?

Falko .. it's really annoying ...

anyway i'm thankful for your support
Reply With Quote
  #13  
Old 2nd December 2005, 20:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by maroonworks
Mahir i'm facing the same problem too...

what distrubution of linux ur using?

Falko .. it's really annoying ...

anyway i'm thankful for your support
What's in your mail log? Does it also happen when you use other email clients (Thunderbird, Outlook Express, ...)? Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 23rd April 2007, 21:09
docuweb docuweb is offline
Junior Member
 
Join Date: Apr 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you guys ever get to the bottom of this issue?

I just loaded a brand new Suse 10.2 + ISPConfig and everything works *except* sending mail from a client outside of the machine. Webmail send & receive works fine, I can download to Outlook Express, but i can't send using OE.

I get the following error message:

Quote:
"The connection to the server has failed. Account: 'mail.justpink.ca', Server: 'mail.justpink.ca', Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error: 10060, Error Number: 0x800CCC0E"
When I tail the mail log, I do not see a connection for SMTP, but I see POP logging on, no problem:

Quote:
Apr 23 14:00:38 arch postfix/master[21631]: terminating on signal 15
Apr 23 14:00:39 arch postfix/postfix-script: starting the Postfix mail system
Apr 23 14:00:39 arch postfix/master[22002]: daemon started -- version 2.3.2, configuration /etc/postfix
Apr 23 14:02:28 arch pop3d: Connection, ip=[::ffff:74.104.228.147]
Apr 23 14:02:28 arch pop3d: LOGIN, user=pennypink, ip=[::ffff:74.104.228.147]
Apr 23 14:02:28 arch pop3d: LOGOUT, user=pennypink, ip=[::ffff:74.104.228.147], top=0, retr=0, rcvd=12, sent=39, time=0
Thinking that maybe my IP wasn't being allowed, I even added my IP block to the $mynetworks.

Quote:
mynetworks = 127.0.0.0/8, 74.0.0.0/8
I have interfaces set to all:

Quote:
inet_interfaces = all
and netstat says it's accepting connections:

Quote:
arch:/etc/postfix # netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 19708/mysqld
tcp 0 0 localhost:asf-rmcp *:* LISTEN 3415/famd
tcp 0 0 *:sunrpc *:* LISTEN 2706/portmap
tcp 0 0 localhost:novell-zen *:* LISTEN 2948/zmd
tcp 0 0 *:hosts2-ns *:* LISTEN 24131/ispconfig_htt
tcp 0 0 199.246.50.101:domain *:* LISTEN 20542/named
tcp 0 0 arch.docuweb.ca:domain *:* LISTEN 20542/named
tcp 0 0 localhost:domain *:* LISTEN 20542/named
tcp 0 0 *:ftp *:* LISTEN 17733/proftpd: (acc
tcp 0 0 localhost:ipp *:* LISTEN 3215/cupsd
tcp 0 0 *:smtp *:* LISTEN 22002/master
tcp 0 0 localhost:953 *:* LISTEN 20542/named
tcp 0 0 *:imaps *:* LISTEN 2833/couriertcpd
tcp 0 0 *:pop3s *:* LISTEN 2822/couriertcpd
tcp 0 0 *:pop3 *:* LISTEN 2806/couriertcpd
tcp 0 0 *:imap *:* LISTEN 2814/couriertcpd
tcp 0 0 *:www-http *:* LISTEN 24199/httpd2-prefor
tcp 0 0 *:ssh *:* LISTEN 3089/sshd
tcp 0 0 localhost:ipp *:* LISTEN 3215/cupsd
tcp 0 0 *:smtp *:* LISTEN 22002/master
tcp 0 0 localhost:953 *:* LISTEN 20542/named
tcp 0 0 *:https *:* LISTEN 24199/httpd2-prefor
Other factors: firewall for both Suse and ISPConfig are disabled. The installation of both Suse and ISPConfig were done to the letter from the manuals. The machine sits forward (no NAT - I have my own class C block) and I have other machines (not ISPConfig, but all linux) that accept SMTP connections so I know it's not blocked at my Cisco. But on most of those I use EXIM, not PostFix. There are no entries in iptables.

Any ideas?
Reply With Quote
  #15  
Old 24th April 2007, 19:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Any errors in your mail log? What's the output of
Code:
iptables -L
? Is AppArmor disabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 24th April 2007, 20:10
docuweb docuweb is offline
Junior Member
 
Join Date: Apr 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Any errors in your mail log? What's the output of
Code:
iptables -L
? Is AppArmor disabled?
1. No Errors in mail log.

2. At the time I posted, I had ISPConfig firewall and Suse's firewall both shut off, so there were no items listed in iptables. Since then, I have turned on ONLY the ISPConfig firewall, thinking that perhaps having no entry at all for SMTP in the tables might be part of the problem.

iptables -L *now* reports:

Quote:
Chain INPUT (policy DROP)
target prot opt source destination
DROP tcp -- anywhere loopback/8
ACCEPT 0 -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT 0 -- anywhere anywhere
DROP 0 -- BASE-ADDRESS.MCAST.NET/4 anywhere
PUB_IN 0 -- anywhere anywhere
PUB_IN 0 -- anywhere anywhere
PUB_IN 0 -- anywhere anywhere
PUB_IN 0 -- anywhere anywhere
DROP 0 -- anywhere anywhere

Chain FORWARD (policy DROP)
target prot opt source destination
ACCEPT 0 -- anywhere anywhere state RELATED,ESTABLISHED
DROP 0 -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
PUB_OUT 0 -- anywhere anywhere
PUB_OUT 0 -- anywhere anywhere
PUB_OUT 0 -- anywhere anywhere
PUB_OUT 0 -- anywhere anywhere

Chain INT_IN (0 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere
DROP 0 -- anywhere anywhere

Chain INT_OUT (0 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere
ACCEPT 0 -- anywhere anywhere

Chain PAROLE (9 references)
target prot opt source destination
ACCEPT 0 -- anywhere anywhere

Chain PUB_IN (4 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere icmp destination-unreachable
ACCEPT icmp -- anywhere anywhere icmp echo-reply
ACCEPT icmp -- anywhere anywhere icmp time-exceeded
ACCEPT icmp -- anywhere anywhere icmp echo-request
PAROLE tcp -- anywhere anywhere tcp dpt:ftp
PAROLE tcp -- anywhere anywhere tcp dpt:ssh
PAROLE tcp -- anywhere anywhere tcp dpt:smtp
PAROLE tcp -- anywhere anywhere tcp dpt:domain
PAROLE tcp -- anywhere anywhere tcp dpt:http
PAROLE tcp -- anywhere anywhere tcp dpt:hosts2-ns
PAROLE tcp -- anywhere anywhere tcp dpt:pop3
PAROLE tcp -- anywhere anywhere tcp dpt:https
PAROLE tcp -- anywhere anywhere tcp dpt:ndmp
ACCEPT udp -- anywhere anywhere udp dpt:domain
DROP icmp -- anywhere anywhere
DROP 0 -- anywhere anywhere

Chain PUB_OUT (4 references)
target prot opt source destination
ACCEPT 0 -- anywhere anywhere
3. AppArmor being the Suse firewall software? According to Yast2, yes - it is disabled.

---

I discovered something that might give us a clue - it answers on port 25 from another machine on in my block, but it won't answer from anywhere else.

arch.docuweb.ca = 199.246.50.100
girt.docuweb.ca = 199.246.50.22 (this machine is sitting literally next to arch)
sean.docuweb.ca = 74.104.228.147 (this machine is at my home, outside of the facility)

Quote:
girt:~ # telnet arch.docuweb.ca 25
Trying 199.246.50.100...
Connected to arch.docuweb.ca.
Escape character is '^]'.
220 arch.docuweb.ca ESMTP Postfix
ehlo arch
250-arch.docuweb.ca
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye
Connection closed by foreign host.
Quote:
sean:~# telnet arch.docuweb.ca 25
Trying 199.246.50.100...
telnet: connect to address 199.246.50.100: Connection timed out
edit:

Just found the solution to this - see: http://www.howtoforge.com/forums/sho...5&postcount=17

Last edited by docuweb; 24th April 2007 at 20:57.
Reply With Quote
  #17  
Old 24th April 2007, 20:22
docuweb docuweb is offline
Junior Member
 
Join Date: Apr 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Another question:

how do I add alternative ports? I.E.: client can connect on either 25 *or* 587?

edit:

Figured this one out on my own - not very hard, actually.

In /etc/services, commented out:

Quote:
#submission 587/tcp # Submission
#submission 587/udp # Submission
and added:

Quote:
smtp2 587/tcp mail # Simple Mail Transfer
smtp2 587/udp mail # Simple Mail Transfer
- then, in master.cf, right below:

Quote:
smtp inet n - n - - smtpd
I added:

Quote:
smtp2 inet n - n - - smtpd
Happily, this also seems to solve the problem I was having, because my ISP at home (Rogers Cable Hi-Speed Internet) appears to block traffic on port 25. I can now send mail from OE on port 587 with no issue.

Last edited by docuweb; 24th April 2007 at 20:54.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Read but not send mail briggers HOWTO-Related Questions 24 7th April 2006 19:22
Mail Problem toyito Installation/Configuration 9 8th November 2005 18:15
internal domain error with mail matehortua Installation/Configuration 5 16th October 2005 18:31
saslauthd problem ... tmwtp Server Operation 11 16th October 2005 16:50


All times are GMT +2. The time now is 01:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.