#1  
Old 20th April 2007, 23:13
rvarkevisser rvarkevisser is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default UTF-8 conversion

Hi there,

I have a problem and I can not figure out how to solve this. I've been at it for the last three weeks and still don't have a solution. Here's the problem

http://www.la-capirinha.nl/test.htm

The Euro, apostrophe etc. are all shown as squares. I use apache2.0.54 with ISPConfig. The OS is Debian Etch Stable. I installed every Charset I could find and tried every locale setting. I now use nl_NL@EURO.

I have another server which runs Debian Sarge stable and here every thing is fine. The problem is that on the Debian Edge server, I have around 130 customer websites running. So I really need a solution!
I tried to set the default charset to UTF-8 in apache2.conf. I tried defaultcharset off. I tried everything. Maybe UTF-8 isn't properly installed within apache2, so how can I reinstall it without causing any damage to the customers websites?
Reply With Quote
Sponsored Links
  #2  
Old 20th April 2007, 23:42
rvarkevisser rvarkevisser is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi there,

I have a problem and I can not figure out how to solve this. I've been at it for the last three weeks and still don't have a solution. Here's the problem

http://www.la-capirinha.nl/test.htm

The Euro, apostrophe etc. are all shown as squares when converted from a different charset (like windows-1252). I use apache2.0.54 with ISPConfig. The OS is Debian Etch Stable. When using utf-8 as the coding for the page, it works perfectly.

http://www.la-capirinha.nl/test2.htm

I have another server which runs Debian Sarge stable and here every thing is fine. The problem is that on the Debian Edge server, I have around 130 customer websites running. So I really need a solution!
Reply With Quote
  #3  
Old 20th April 2007, 23:49
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default

You can try to enable more locales by giving the command:

dpkg-reconfigure locales

Choose the locales you need.
Probably this will work for you.
__________________
Hans

MrHostman | Managed Hosting
Reply With Quote
  #4  
Old 20th April 2007, 23:51
rvarkevisser rvarkevisser is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Hans,

I matched the LANG and every setting in locale to the server where it does work correctly. After restarting apache2 it looks fine now. The strange think is that I had to set it to POSIX.

LANG=POSIX
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

Don't ask me why ??? but it works for now. I managed to get it working once, but after a few nights, the problem was back. (probably after a restart of apache)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
qmail uni-code to sJIS Conversion gg234 Server Operation 1 22nd July 2006 16:27
php and rar probs ColdDoT Server Operation 8 26th May 2006 17:40


All times are GMT +2. The time now is 08:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.