#1  
Old 12th April 2007, 18:20
cryptic cryptic is offline
Senior Member
 
Join Date: Sep 2006
Posts: 137
Thanks: 6
Thanked 6 Times in 5 Posts
Default named won't start

ISPConfig 2.2.11 CentOS 4.4

When I try to start named, I get the following error:
# service named start
Starting named:
Error in named configuration:
/etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found
/etc/named.conf:3: parsing failed [FAILED]

ls -l /home/admispconfig/ispconfig/web/multidoc/edit
total 104
-rwxr-xr-x 1 admispconfig admispconfig 2769 Mar 15 16:38 delete.php
-rwxr-xr-x 1 admispconfig admispconfig 31646 Mar 15 16:38 edit.php
-rwxr-xr-x 1 admispconfig admispconfig 2021 Mar 15 16:38 empty_trash.php
-rw-r--r-- 1 root root 2769 Apr 10 13:08 named.ca
-rw-r--r-- 1 root root 256 Apr 10 13:08 named.local
-rwxr-xr-x 1 admispconfig admispconfig 3649 Mar 15 16:38 new_switch.php
-rwxr-xr-x 1 admispconfig admispconfig 2190 Mar 15 16:38 node_insert.php
-rwxr-xr-x 1 admispconfig admispconfig 7167 Mar 15 16:38 node.php
-rwxr-xr-x 1 admispconfig admispconfig 6048 Mar 15 16:38 papierkorb.php



My /etc/named.conf

options {
pid-file "/var/named/chroot/var/run/named/named.pid";
directory "/home/admispconfig/ispconfig/web/multidoc/edit";
auth-nxdomain no;
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};
Reply With Quote
Sponsored Links
  #2  
Old 13th April 2007, 08:36
cryptic cryptic is offline
Senior Member
 
Join Date: Sep 2006
Posts: 137
Thanks: 6
Thanked 6 Times in 5 Posts
 
Default

I figured it out thanks to http://howtoforge.com/forums/showthread.php?t=11207
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS - named will not start ?? brainz Installation/Configuration 66 13th June 2010 21:53
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error Hellbound General 4 7th January 2007 12:50
Named crashing every 20 min RingofFire Installation/Configuration 4 23rd November 2006 03:39
DNS: Multiple IPs, want to setup a "private" nameserver on each IP for resellers bpmee Server Operation 8 17th September 2006 10:35
BIND broke adamluz Installation/Configuration 4 2nd June 2006 22:31


All times are GMT +2. The time now is 04:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.